La recherche a retourné 12 résultats

par irevoire
ven. 20 juil. 2018, 11:55
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

Non il n'y a aucun fichier root dans mon home et je n'ai pas lancé startx en root... machin@msi ~ % la total 196 drwx------ 4 machin machin 4096 20 juil. 11:43 . drwxr-xr-x 5 root root 4096 18 juil. 14:56 .. drwxr-xr-x 3 machin machin 4096 19 juil. 00:40 .cache drwxr-xr-x 3 machin machin 4096 18 jui...
par irevoire
jeu. 19 juil. 2018, 23:57
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

Quand je fais un startx le "log" qui sors sur stderr c'est exactement ce que j'ai posté : xinit: giving up xinit: unable to connect to X server: Connection refused xinit: server error Et aucun fichier n'est créé dans /var/log. En revanche en utilisant xinit exec xterm les logs de stdout/stderr je le...
par irevoire
jeu. 19 juil. 2018, 18:40
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

non, le fait que startx dise xinit: giving up xinit: unable to connect to X server: Connection refused xinit: server error n'est pas normal et xinit n'est pas capable de démarrer quoi que ce soit, il éteint juste l'écran... Dans le xinitrc j'avais rien mis a la base puisque que pour le testé ce n'es...
par irevoire
jeu. 19 juil. 2018, 01:12
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

Bon j'suis assez déçu, ça s'annonçait facile a régler comme bug mais finalement pas tant que ça alors vu que le thread est déjà ouvert je me dis que je vais poster là. Pour commencer je ne lance pas startx en ssh ni en root. Ensuite malgré que startx ne marche pas j'arrive a lancer xinit exec xterm,...
par irevoire
mer. 18 juil. 2018, 15:54
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

C'est terminé, y a un nouveau bug totalement mystique, les touches "r", "c" et backspace marchent plus mais bref, startx donne un :

Code : Tout sélectionner

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
par irevoire
mer. 18 juil. 2018, 15:26
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

Bon après avoir mon truc j'avais un retour de startx (une erreur) mais j'ai lancé les commandes que tu as donné pour repartir d'une *vraie* base saine.
Par contre ma connexion en prend un coup, j'éditerais ce message quand ce sera terminé.
par irevoire
mer. 18 juil. 2018, 15:16
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

ah oui effectivement il semble y avoir un problème, j'avais même pas envisagé que ce soit possible ça ! machin@msi ~ % hexdump /usr/bin/startx machin@msi ~ % machin@msi ~ % hexdump /usr/bin/xinit machin@msi ~ % Du coup j'ai tout désinstallé -> root@msi ~ # pacman -Rns nvidia nvidia-utils sddm sddm-k...
par irevoire
mer. 18 juil. 2018, 15:09
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

Pour info j'ai installé zsh dès le début du coup je t'ai ajouté which zsh ^^ machin@msi ~ % which startx /usr/bin/startx machin@msi ~ % which bash /usr/bin/bash machin@msi ~ % which zsh /usr/bin/zsh machin@msi ~ % echo "$PATH" /usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendo...
par irevoire
mer. 18 juil. 2018, 14:48
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

Ah oui mince j'avais pas fait gaffe et comme je venais de refaire l'installation j'étais resté en root, par contre quand je lance startx je le fais bien en utilisateur. Oui je passe en ssh. J'ai installé xorg-server et d'autre, je du faire quelque chose comme : `pacman -S xorg-server xorg-xinit xorg...
par irevoire
mer. 18 juil. 2018, 14:11
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

J'ai laissé mesa, il ne me semble pas qu'il soit en conflit avec nvidia ? root@msi ~ # pacman -Qs "nvidia|libgl|nouveau|mesa" local/glu 9.0.0-5 Mesa OpenGL Utility library local/libglvnd 1.0.0-1 The GL Vendor-Neutral Dispatch library local/libvdpau 1.1.1+3+ga21bf7a-1 Nvidia VDPAU library local/mesa ...
par irevoire
mer. 18 juil. 2018, 13:40
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

Re: [installation xorg nouveau] pas de log

J'avais commencé avec les drivers nvidia mais quand j'ai vu le problème je suis reparti sur nouveau en me disant que ce serait plus simple a régler. Et non justement, je n'ai vraiment rien, je récupère la main instantanément et il n'y a rien qui s'affiche. Des trucs comme startx & ps ne montrent rie...
par irevoire
mer. 18 juil. 2018, 13:15
Forum : Environnements graphiques
Sujet : [installation xorg nouveau] pas de log
Réponses : 24
Vues : 2270

[installation xorg nouveau] pas de log

Hey salut tout le monde ! Je viens d'installer archlinux en UEFI sur un PC portable (i7 + GTX 1050), j'ai installé nouveau comme driver graphique. Jusque là tout s'est bien passé, mais le problème c'est que startx/xinit ne fait rien, pas de log (pas de /var/log/Xorg généré) pas d'erreur pas de fenêt...