[Xorg/Gnome] Probleme d'affichage bureau

Questions et astuces concernant l'installation et la configuration d'archlinux
redband59
newbie
Messages : 4
Inscription : mer. 17 mai 2017, 08:57

[Xorg/Gnome] Probleme d'affichage bureau

Message par redband59 » mer. 17 mai 2017, 09:11

Bonjour à tous,

J'ai tenté d'installer Arch en suivant le tutoriel sur ce site http://frederic.bezies.free.fr/blog/?p=15567 ainsi que sur https://wiki.archlinux.fr/ et chaque fois, j'installe le driver nvidia propriétaire en suivant le guide, j'installe Xorg et ensuite Gnome, le guide dis que je dois retrouver un environnement de bureau au reboot mais je n'ai rien ... j'arrive sur un mode terminal normal et classique.

Je me log, j'entre mon user et mon passwd, et la je tente un startx, mon deuxième écran s'allume, et j'ai trois fenêtres terminal blanche, une souris mais rien d'autres ...

Image

en tentant la commande lspci -nk je vois bien que le driver est nvidia donc de ce coté la j'imagine que ca va.
Si j'essaie de faire "gnome-session", boum je retombe sur le terminal noir, classique.

J'ai essayé de chercher beaucoup de solutions mais même en chipotant beaucoup je n'y arrive pas, je suis encore trop débutant :p

Si quelqu'un peut m'aider a chercher le bon diagnostic, j'en serais très heureux.

Edit1 : Il m'est venu une idée un peu farfelue, mais en vérifiant sur Ubuntu, le driver graphique est 'snd_hda_intel' tandis que sur Arch c'est juste 'nvidia'. Devrais-je essayer d'installer le même driver ?

Merci

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 14347
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Xorg/Gnome] Probleme d'affichage bureau

Message par benjarobin » mer. 17 mai 2017, 11:45

Bonjour,
snd_... c'est le driver de la carte son...
As tu activé le service de login (GDM) ? Que donne le statut du service GDM ?

Sinon vraiment les tutoriels de ce genre c'est vraiment une mauvaise idée, voir à tendance à m'énerver copieusement !!! Il t'impose des choix que tu n'as pas forcément envie de suivre :
  • Il te dis par exemple pour installer KDE il te faut lancer cette commande, ce qui est absolument faux, tu ne veux par forcément installé ce qui est décrit
  • Ou encore configurer les logs de cette façon (qui utilise encore syslog aujourd'hui ?)
  • Il parle pour installer certain paquet de faire : pacman -Syy nom-du-paquet, il n'y a pas mieux pour casser son système.
Bref il donne de "mauvais" conseil. Le mieux est de lire et comprendre le Wiki (fr + anglophone) et faire ses propres choix. Et on sera ravi d'y répondre ici !
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

redband59
newbie
Messages : 4
Inscription : mer. 17 mai 2017, 08:57

Re: [Xorg/Gnome] Probleme d'affichage bureau

Message par redband59 » mer. 17 mai 2017, 19:12

Merci de prendre le temps de m'aider.

J'ai essayé de lancer le gdm.service via systemctl enable gdm.service, je reboot et la je tombe sur une fenêtre "Oh mince ! Quelque chose s'est mal passé".

J'imagine que le problème ne vient pas de ma carte graphique, effectivemment après un double check sur Ubuntu, les drivers sont bien ceux de nvidia et non le driver son (quel erreur de noob).

Y a til des logs de Gnome par rapport au lancement ?

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 14347
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Xorg/Gnome] Probleme d'affichage bureau

Message par benjarobin » mer. 17 mai 2017, 19:32

Désactive waylang, utilise xorg
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

redband59
newbie
Messages : 4
Inscription : mer. 17 mai 2017, 08:57

Re: [Xorg/Gnome] Probleme d'affichage bureau

Message par redband59 » mer. 17 mai 2017, 22:38

benjarobin a écrit :
mer. 17 mai 2017, 19:32
Désactive waylang, utilise xorg
Merci de ton aide,

Je vais tester ça quand je serai rentré.

A l'installation de Xorg il ne désactive pas waylang ?

Bonne soirée

Avatar de l’utilisateur
alh54
archer de cavalerie
Messages : 166
Inscription : lun. 02 déc. 2013, 21:52

Re: [Xorg/Gnome] Probleme d'affichage bureau

Message par alh54 » jeu. 18 mai 2017, 16:44

A l'écran de connexion de GDM tu as un bouton à la forme engrenage, il te permet de choisir le type de session. tu as 3 choix:
- Gnome : session Wayland
- Gnome xorg ; gnome sous xorg
- Gnome classic : gnome avec apparence de gnome 2

redband59
newbie
Messages : 4
Inscription : mer. 17 mai 2017, 08:57

Re: [Xorg/Gnome] Probleme d'affichage bureau

Message par redband59 » mar. 30 mai 2017, 18:11

Hello et désolé du retard.
Je n'ai finalement jamais su lancer Archlinux mais j'ai tenté l'installation sur mon portable équipé d'un autre chipset graphique et ... tout s'est déroulé sans problèmes.

J'estime donc que j'ai du me tromper dans le choix du driver graphique ou que celui-ci montre une incompatibilité...

Maintenant je ne renonce pas mais j'ai eu des problèmes avec Grub également, dur dur la vie de noob sur linux :p

Si je résous mon problème dans le futur je posterai la solution ici

yostral
Daikyu
Messages : 51
Inscription : mar. 05 nov. 2013, 18:51

Re: [Xorg/Gnome] Probleme d'affichage bureau

Message par yostral » mar. 30 mai 2017, 22:25

GDM utilise Wayland par défaut. C'est indépendant de ta session.
Pour désactiver Wayland de GDM, et donc utiliser Xorg, ouvre le fichier /etc/gdm/custom.conf et décommente la ligne WaylandEnable=false . Puis reboote.

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 13 invités