[LUKS] Problème sur une installation chiffrée (syslinux) ! (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

[LUKS] Problème sur une installation chiffrée (syslinux) ! (résolu)

Message par soufianta »

Bonjour,

J'essaye de faire une installation avec LUKS mais j'ai un message d'erreur:

"start job is running for /dev/mapper/cryptroot".

J'ai ajouté le hook "sd-encrypt" à l'initRAMFS et rajouter le "cryptdevice" dans syslinux mais rien n'y fait.

Mon fichier fstab est correctement configuré également. J'ai suivi le wiki, des tutos en ligne mais rien n'y fait :-(.

Merci.
Dernière modification par soufianta le jeu. 15 oct. 2020, 10:23, modifié 1 fois.
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par soufianta »

Il n’y a donc vraiment personne qui puisse m’aiguillez ???
laurent85
Elfe
Messages : 665
Inscription : mar. 16 oct. 2018, 21:05

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par laurent85 »

Bonjour,
Donne les détails de la configuration.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
Backtoback
yeomen
Messages : 258
Inscription : jeu. 26 avr. 2012, 23:33
Contact :

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par Backtoback »

Bonsoir,

peux tu fournir des infos sur tes fstab et crypttab?
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par soufianta »

Bonjour,

fstab:
#/dev/mapper/crypt
UUID=***

cryptab:
/ UUID (mapper) none luks,timeout=180

J'ai toujours un "a start job is running for /dev/mapper/crypt". Je pense l'avoir mal configuré mais ... je ne vois pas où...
laurent85
Elfe
Messages : 665
Inscription : mar. 16 oct. 2018, 21:05

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par laurent85 »

Donne le détail de ce que tu as fait en suivant la procédure du wiki sachant que les uuid ne sont pas des informations secrètes tu peux les publier https://wiki.archlinux.org/index.php/Dm ... _partition.

Pour info il n'y a pas besoin de crypttab pour la partition racine "/", ni de ligne dans fstab.

Ce qui compte est la configuration de mkinitcpio.conf https://wiki.archlinux.org/index.php/Dm ... mkinitcpio :

Code : Tout sélectionner

HOOKS=(base udev autodetect keyboard keymap consolefont modconf block encrypt filesystems fsck)
et les paramètres du noyau Linux au démarrage https://wiki.archlinux.org/index.php/Dm ... oot_loader :

Code : Tout sélectionner

cryptdevice=UUID=device-UUID:cryptroot root=/dev/mapper/cryptroot
Avec ça et en suivant la procédure pour la partition /boot et la génération de l'initramfs ça doit marcher.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par soufianta »

Merci Laurent. Figures toi que j’ai suivi tout cela (sd-encrypt au lieu de encrypt pour les hook mkinitcpio) et la ligne dans syslinux ! Ce qui est bizarre c’est que ça paraît tellement facile dans les tutos / wiki mais chez moi, c’est le parcours du combattant ! Je n’ai pas envie de passé sur une distribution « friendly »(où le chiffrement est configuré en 2 clics) à cause de cette petite mésaventure !
laurent85
Elfe
Messages : 665
Inscription : mar. 16 oct. 2018, 21:05

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par laurent85 »

Oui mais sans réponse aux demandes d'infos personne ne pourra aider davantage à part dire des généralités qui se trouvent dans le wiki.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par soufianta »

Les détails:

J’ai d’abord partitioner le disque + cryptsetup. J’ai déchiffré le disque avec cryptsetup open et formater en ext4. J’ai fais l’installation et générer le fichier fstab. J’ai installé syslinux et configurer les entrée APPEND avec le cryptdevice mais je pense que la syntaxe est incorrecte. Je ne peux rien dire de plus ..
laurent85
Elfe
Messages : 665
Inscription : mar. 16 oct. 2018, 21:05

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par laurent85 »

Quelle est la partition /boot, les uuid des partitions, le contenu de fstab complet, le contenu de mkinitcpio.conf, le contenu de la config du bootloader, c'est à dire les infos concrètes de la configuration.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par soufianta »

Je vous envoi ça demain mais quel est la meilleure façon de vous procurer ça? Les captures d’écran ne vont pas bien marcher sur ce forum :-(
laurent85
Elfe
Messages : 665
Inscription : mar. 16 oct. 2018, 21:05

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par laurent85 »

Le texte c'est mieux que des images écran. Copie les contenus vers un fichier ou à partir d'un live usb avec environnement graphique accède aux contenus. J'ai mis en ligne des iso générées par archuseriso adaptées à ce type de besoin http://dl.gnutux.fr/archuseriso/fr_FR/
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

Re: [LUKS] Problème sur une installation chiffrée (syslinux) !

Message par soufianta »

Bonjour,

J'ai refais tout la configuration en suivant scrupuleusement le wiki (et bootctl au lieu de syslinux) et j'y suis ENFIN arrivé tout seul comme un grand !

Merci à vous d'avoir voulu m'aider (et en particulier @laurent85) !!

Bonne journée à tous !
Répondre