[résolu][lightDM] ne donne pas la possibilité d'autre langue?

Questions et astuces concernant l'installation et la configuration d'archlinux
Nico73
Hankyu
Messages : 16
Inscription : lun. 23 mai 2016, 09:50

[résolu][lightDM] ne donne pas la possibilité d'autre langue?

Message par Nico73 »

Bonjour,

J'ai deux utilisateurs pour le même ordinateur. Il en faudrait 1 en hongrois, l'autre en français. J'ai bien suivi le [wiki]https://wiki.archlinux.fr/locale[/wiki] en français sur locale et j'ai aussi pris des infos sur le [wiki]https://wiki.archlinux.org/title/locale[/wiki] en anglais. J'ai mis les bonnes infos dans le fichier /etc/locale.conf et j'ai bien généré tout ce dont j'avais besoin. Le tout est en hongrois, comme prévu. Par contre, impossible d'activer le français pour le deuxième utilisateur (moi).

Locale -a donne ceci:

Code : Tout sélectionner

locale -a
be_BY
be_BY.cp1251
be_BY@latin
be_BY.utf8
be_BY.utf8@latin
C
fr_BE
fr_BE.iso88591
fr_BE.utf8
hu_HU
hu_HU.iso88592
hu_HU.utf8
hungarian
POSIX
Je ne comprends pas la phrase "Pour configurer une locale (qui peut être différente de celle du système) seulement pour votre session, il faut exporter la bonne variable dans votre ~/.bashrc, par exemple, pour avoir le système en anglais, mais les dates en français : export LANG=en_US.UTF-8
export LC_TIME=fr_FR" sur le [wiki]https://wiki.archlinux.fr/locale[/wiki] francophone. J'ai bien compris qu'il faut mettre ces données quelque part, mais bon... je ne vois pas comment le faire.

Sur le [wiki]https://wiki.archlinux.org/title/locale[/wiki] anglais, ils proposent de créer un locale.conf dans ~/.config ce que j'ai fait aussi

Code : Tout sélectionner

LANG=fr_be.UTF-8
LANGUAGE=fr_be.UTF-8
Enfin, j'ai lu que pour ligthDM il y a un sélecteur de langues. J'ai beau l'activer avec lightdm-gtk-greeter-settings le bouton de sélection n'apparaît pas auprès des autres. Je me dis donc qu'actuellement lightDM ne lit que le fichier /etc/locale.conf

J'ai aussi installé [pkg]https://archlinux.org/packages/extra/x8 ... tsservice/[/pkg], parce qu'il a l'air d'être utilisé par lightDM.

Si quelqu'un pouvait m'aider à trouver la solution ce serait top. Merci beaucoup,

Nico
Dernière modification par Nico73 le mer. 09 juin 2021, 22:32, modifié 1 fois.
laurent85
Elfe
Messages : 764
Inscription : mar. 16 oct. 2018, 21:05

Re: [lightDM] ne donne pas la possibilité d'autre langue?

Message par laurent85 »

Bonjour,
J'ai fait quelques tests et une solution qui marche est de mettre la variable dans ~/.pam_environment :

Code : Tout sélectionner

LANG=fr_BE.UTF-8
NB: la variable c'est LANG=fr_BE.UTF-8, et non pas LANG=fr_be.UTF-8 comme dans ton message.

https://wiki.archlinux.org/title/Enviro ... s#Per_user
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
Nico73
Hankyu
Messages : 16
Inscription : lun. 23 mai 2016, 09:50

Re: [résolu][lightDM] ne donne pas la possibilité d'autre langue?

Message par Nico73 »

Merci beaucoup Laurent85. Cela fonctionne. J'avais lu que lightDM utilisait Pam, mais je ne savais pas que c'était ce fichier, d'autant que j'ai dû le créer.
Répondre