[Erreur au boot] Unable to find root device (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
Tangrim
archer de cavalerie
Messages : 181
Inscription : mer. 26 sept. 2007, 16:31
Localisation : dans l'underground

[Erreur au boot] Unable to find root device (résolu)

Message par Tangrim »

En allumant mon pc ce matin (mis à jour hier soir), j'ai eu une petite surprise:

Code : Tout sélectionner

    Booting the kernel.
    :: Starting udevd...
    done.
    :: Running Hook [udev]
    :: Triggering uevents...done.
    Waiting 10 seconds for device /dev/sda3 ...
    ERROR: Unable to find root device '/dev/sda3'.
    You are being dropped to a recovery shell
           Type 'exit' to try and continue booting
    sh: can't access tty: job control turned off
    [rootfs /]#

Argh.
Je met ma gallette de system rescue cd et je cherche un peu sur le net mon problème, je tombe sur ce message:
https://bbs.archlinux.org/viewtopic.php?id=135288

Donc je chroot, j'installe mkinitcpio
mkinitcpio -p linux

Même problème.

J'ai installé grub2-bios à la place de grub, j'ai mis à jour le menu
grub-mkconfig -o /boot/grub/grub.cfg
(Maintenant j'ai un grub tout moche, merci bien...)

Et le problème reste le même (avec l'UUID à la place de sda3 évidement).

Que faire ?
Merci pour votre aide.
Dernière modification par Tangrim le dim. 25 mars 2012, 15:53, modifié 1 fois.
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Erreur au boot] Unable to find root device

Message par benjarobin »

C'est suite à une mise à jour ? Si oui essaye de downgrader le kernel.
De toute façon il faut utiliser des UUID !
As tu un partitionnement spécial ?
Quel est le contenu de ton fstab une fois corrigé ?
La sortie de

Code : Tout sélectionner

ls -l /dev/disk/by-uuid/
fdisk -l
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
Tangrim
archer de cavalerie
Messages : 181
Inscription : mer. 26 sept. 2007, 16:31
Localisation : dans l'underground

Re: [Erreur au boot] Unable to find root device

Message par Tangrim »

Le schéma de partionnement est:
sda1 -> /boot
sda2 -> swap
sda3 -> /
sda5 -> /home
sda6 -> partition de stockage

Code : Tout sélectionner

[root@sysresccd /]# ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 Mar 25 15:48 2A28455F28452AE1 -> ../../sdb1
lrwxrwxrwx 1 root root 10 Mar 25 15:48 972361b0-41a5-45e3-8e39-bbea70e5ee6a -> ../../sda1
lrwxrwxrwx 1 root root 10 Mar 25 15:48 b6c49d36-07c3-4ef0-9b53-572c784ab42f -> ../../sda5
lrwxrwxrwx 1 root root 10 Mar 25 15:48 c739157b-36ed-4c5e-8b1a-2038e956e06b -> ../../sda3
lrwxrwxrwx 1 root root 10 Mar 25 15:48 e23d7222-7c5e-490d-9cde-948638a4fdd9 -> ../../sda2
lrwxrwxrwx 1 root root 10 Mar 25 15:48 e376d457-e033-4e21-89b2-080c3c86b24b -> ../../sda6

Code : Tout sélectionner

[root@sysresccd /]# fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xbc73bc73

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63      578339      289138+  83  Linux
/dev/sda2          578340     2538269      979965   82  Linux swap / Solaris
/dev/sda3         2538270    51359804    24410767+  83  Linux
/dev/sda4        51359805   234441647    91540921+   5  Extended
/dev/sda5        51359868    61127324     4883728+  83  Linux
/dev/sda6        61127388   234441647    86657130   83  Linux

Disk /dev/sdb: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders, total 160836480 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000001

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63   160810649    80405293+   7  HPFS/NTFS/exFAT
Le n'avais pas modifié le fstab, maintenant c'est:

Code : Tout sélectionner

[root@sysresccd /]# cat /etc/fstab
# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
tmpfs		/tmp	tmpfs	nodev,nosuid	0	0
/dev/972361b0-41a5-45e3-8e39-bbea70e5ee6a /boot ext2 defaults 0 1
/dev/e23d7222-7c5e-490d-9cde-948638a4fdd9 swap swap defaults 0 0
/dev/c739157b-36ed-4c5e-8b1a-2038e956e06b / ext4 defaults 0 1
/dev/b6c49d36-07c3-4ef0-9b53-572c784ab42f /home ext4 defaults 0 1
/dev/e376d457-e033-4e21-89b2-080c3c86b24b /home/lutin/data ext4 defaults 0 1
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Erreur au boot] Unable to find root device

Message par benjarobin »

Le fstab étant complètement faux, cela ne risque pas de fonctionner :copain:
Tu as 2 choix pour le fstab, soit : /dev/disk/by-uuid/xxxxxxxxxxxxxxx, soit : UUID=xxxxxxxxxxxxxxx
Par contre pour Grub 1, uniquement la première syntaxe est autorisée

Ce qui donne donc

Code : Tout sélectionner

#
# /etc/fstab: static file system information
#
# <file system>   <dir>   <type>   <options>   <dump>   <pass>
tmpfs      /tmp   tmpfs   nodev,nosuid   0   0
UUID=972361b0-41a5-45e3-8e39-bbea70e5ee6a /boot ext2 defaults 0 1
UUID=e23d7222-7c5e-490d-9cde-948638a4fdd9 swap swap defaults 0 0
UUID=c739157b-36ed-4c5e-8b1a-2038e956e06b / ext4 defaults 0 1
UUID=b6c49d36-07c3-4ef0-9b53-572c784ab42f /home ext4 defaults 0 2
UUID=e376d457-e033-4e21-89b2-080c3c86b24b /home/lutin/data ext4 defaults 0 2
Donne nous aussi la configuration de ton Grub (corrigée)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
Tangrim
archer de cavalerie
Messages : 181
Inscription : mer. 26 sept. 2007, 16:31
Localisation : dans l'underground

Re: [Erreur au boot] Unable to find root device

Message par Tangrim »

Oui je viens de voir ça, j'avais fait ça un peu trop vite en ayant lu ta remarque.
J'ai donc remis un fstab correct.
Ça n'a pas fonctionné.

J'ai ensuite downgradé le kernel, et la j'ai pu booter \o/

Je vais devoir sauter toutes les maj du kernell ? On peut savoir d'où viens le propblème?

Par contre maintenant j'ai un problème avec X,
si je lance startX:
coul not insert nvidia: exec format error

Le problème viens de la même source ou ça en est un neuf ?

Merci beaucoup pour ton aide en tout cas.
Avatar de l’utilisateur
Tangrim
archer de cavalerie
Messages : 181
Inscription : mer. 26 sept. 2007, 16:31
Localisation : dans l'underground

Re: [Erreur au boot] Unable to find root device

Message par Tangrim »

Bon j'ai downgradé nvidia ça ne marche pas mieux, avec vesa ça tourne.

Je vais bûcher sur ça.
Encore merci.
Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10626
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Erreur au boot] Unable to find root device [résolu]

Message par FoolEcho »

Ce n'est donc trop résolu, en fait... :|

Il faut que la version du paquet compilé de nvidia/nvidia-utils colle avec celle du kernel. Le mieux est de passer par ARM: Downgrade.
Tangrim a écrit :J'ai ensuite downgradé le kernel, et la j'ai pu booter \o/

Je vais devoir sauter toutes les maj du kernell ? On peut savoir d'où viens le propblème?
Tu as essayé de tout remettre à jour, quand même ? C'est la même erreur qu'au début, même avec les uuids ?
«The following statement is not true. The previous statement is true.» :nage:
Avatar de l’utilisateur
Tangrim
archer de cavalerie
Messages : 181
Inscription : mer. 26 sept. 2007, 16:31
Localisation : dans l'underground

Re: [Erreur au boot] Unable to find root device [résolu]

Message par Tangrim »

Oui je me suis amusé à faire quelque aller-retour, c'est bien le changement du noyau qui casse tout.

Merci beaucoup pour ARM, c'est exactement ce qu'il me faut, je pourrais l'essayer ce soir.
Avatar de l’utilisateur
Tangrim
archer de cavalerie
Messages : 181
Inscription : mer. 26 sept. 2007, 16:31
Localisation : dans l'underground

Re: [Erreur au boot] Unable to find root device [résolu]

Message par Tangrim »

Grâce à ARM tout refonctionne (je me suis remis au premier Février 2012), merci encore à vous deux pour votre aide.

Je verrais pour me remettre à jour lors de la prochaine version majeure du noayu.
Répondre