[Touchpad] Très capricieux (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
Avatar de l’utilisateur
nicollivier
yeomen
Messages : 247
Inscription : ven. 07 janv. 2011, 07:02

[Touchpad] Très capricieux (résolu)

Message par nicollivier » lun. 23 avr. 2012, 06:59

Bonjour,

Depuis ce week-end j'ai quelques soucis avec touchpad [Ordi: Acer 1810TZ].
Lorsque je fais défiler une page web vers le bas, il n'y pas de possibilité de l'arrêter au milieu. Le plus pénible c'est lorsque je remonte, la page revient au début, mais dès que je veux fermer un onglet via la combinaison de touche Ctl+W, alors l'affichage part en vrac, il y a un gros zoom car l'info "défilement vers le haut" est toujours actif.

Est-ce que cela peut être du à un problème software, ou alors c'est plus hardware? [ L'ordinateur à 2 ans 1/2]
Surtout est-ce qu'il y a la possibilité d'empêcher ce changement de zoom de la page? J'ai regardé du côté de "l'accessibilité" mais je n'ai rien trouvé.

Merci de votre aide :)

Nicolas
Dernière modification par nicollivier le lun. 23 avr. 2012, 20:23, modifié 1 fois.

Avatar de l’utilisateur
widapit
Maître du Kyudo
Messages : 1148
Inscription : mar. 30 mars 2010, 22:53
Localisation : Toulouse
Contact :

Re: [Touchpad] Très capricieux

Message par widapit » lun. 23 avr. 2012, 09:02

Salut !

J'ai aussi remarqué des soucis au niveau du scrolling...
je ne sais pas si ça vient de la conf du touchpad car je n'ai pas constaté le phénomène lorsque je fais défiler dans la fenêtre d'un autre programme. Il n'y a qu'avec le navigateur; j'utilises firefox et toi ?
passerelle(Arch32) & serveurs(Arch64) = {iptables, snort, bind, privoxy, postfix, dovecot, spamassassin}
mon ordi(Arch64) = {wmii, conky} || le blog = {KaotroniC}

Avatar de l’utilisateur
Rolinh
Chu Ko Nu
Messages : 392
Inscription : sam. 15 août 2009, 09:15
Localisation : Suisse
Contact :

Re: [Touchpad] Très capricieux

Message par Rolinh » lun. 23 avr. 2012, 11:21

Salut,

il s'agit d'un bug de xf86-input-synaptics.
Il est normalement corrigé "upstream". Il suffit donc d'attendre une nouvelle version ou de compiler la version avec le patch.

En attendant, la solution pour avoir un touchpad utilisable consiste à désactiver le coasting en modifiant /etc/X11/xorg.conf.d/10-synaptics.conf comme ceci:

Code : Tout sélectionner

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
	Option "CoastingSpeed" "0"
EndSection
(coasting speed à 0 donc)

Avatar de l’utilisateur
widapit
Maître du Kyudo
Messages : 1148
Inscription : mar. 30 mars 2010, 22:53
Localisation : Toulouse
Contact :

Re: [Touchpad] Très capricieux

Message par widapit » lun. 23 avr. 2012, 18:32

C'est bon pour ma part...

effectivement, ce soir après mises à jour : comportement OK !
Si "nicollivier" peut confirmer...
passerelle(Arch32) & serveurs(Arch64) = {iptables, snort, bind, privoxy, postfix, dovecot, spamassassin}
mon ordi(Arch64) = {wmii, conky} || le blog = {KaotroniC}

Avatar de l’utilisateur
Rolinh
Chu Ko Nu
Messages : 392
Inscription : sam. 15 août 2009, 09:15
Localisation : Suisse
Contact :

Re: [Touchpad] Très capricieux

Message par Rolinh » lun. 23 avr. 2012, 18:38

widapit a écrit :effectivement, ce soir après mises à jour : comportement OK !
Gné? Le paquet n'a pas été mis-à-jour depuis le 16 avril...

Avatar de l’utilisateur
widapit
Maître du Kyudo
Messages : 1148
Inscription : mar. 30 mars 2010, 22:53
Localisation : Toulouse
Contact :

Re: [Touchpad] Très capricieux

Message par widapit » lun. 23 avr. 2012, 19:39

Exact! Je ne sais que dire... cependant je n'ai modifié aucun fichier; tout ce weekend ca bugguait et jusqu'à hier soir; hier avant d'éteindre j'ai lancé un "pacman -Syu" et c'est tout ! et cet après-midi en rallumant, ça scrolle nickel.... je ne vois pas du tout a quoi c'est dû...
passerelle(Arch32) & serveurs(Arch64) = {iptables, snort, bind, privoxy, postfix, dovecot, spamassassin}
mon ordi(Arch64) = {wmii, conky} || le blog = {KaotroniC}

Avatar de l’utilisateur
nicollivier
yeomen
Messages : 247
Inscription : ven. 07 janv. 2011, 07:02

Re: [Touchpad] Très capricieux

Message par nicollivier » lun. 23 avr. 2012, 20:23

Merci beaucoup @Rolinh, la modification du fichier de configuration a corrigé le problème.
Sans cette modification, j'avais toujours le problème.

Avatar de l’utilisateur
widapit
Maître du Kyudo
Messages : 1148
Inscription : mar. 30 mars 2010, 22:53
Localisation : Toulouse
Contact :

Re: [Touchpad] Très capricieux [RESOLU]

Message par widapit » lun. 23 avr. 2012, 22:12

bon ok, j'avais été trop vite ... :oops:
mais c'est très sensible, et que sur certaines fenêtres mais ça me l'a refait ce soir en ouvrant une nouvelle...
donc la bonne ligne dans le fichier indiqué et c'est vraiment OK ce coup-ci !! :chinois:
merci !
et de suite c'est plus logique (? pas d'émoticone qui fait le signe de Spock ?) !!
Dernière modification par widapit le mar. 24 avr. 2012, 19:09, modifié 2 fois.
passerelle(Arch32) & serveurs(Arch64) = {iptables, snort, bind, privoxy, postfix, dovecot, spamassassin}
mon ordi(Arch64) = {wmii, conky} || le blog = {KaotroniC}

Avatar de l’utilisateur
CroK
Elfe
Messages : 607
Inscription : dim. 26 juil. 2009, 14:27
Localisation : France > Auxerre

Re: [Touchpad] Très capricieux (résolu)

Message par CroK » mar. 24 avr. 2012, 11:16

Tu vas te faire pendre sur la place publique pour avoir mal écrit le nom de Spock, toi…
Save the penguins, burn the flags ! -- c[] <- beeeeeeeeer!

Avatar de l’utilisateur
widapit
Maître du Kyudo
Messages : 1148
Inscription : mar. 30 mars 2010, 22:53
Localisation : Toulouse
Contact :

Re: [Touchpad] Très capricieux (résolu)

Message par widapit » mar. 24 avr. 2012, 19:08

:sm: :lol:
corrigé !!
:copain:
passerelle(Arch32) & serveurs(Arch64) = {iptables, snort, bind, privoxy, postfix, dovecot, spamassassin}
mon ordi(Arch64) = {wmii, conky} || le blog = {KaotroniC}

Avatar de l’utilisateur
mart-e
newbie
Messages : 6
Inscription : mer. 25 avr. 2012, 08:47
Localisation : World
Contact :

Re: [Touchpad] Très capricieux (résolu)

Message par mart-e » mer. 25 avr. 2012, 09:00

Merci j'avais ce problème depuis quelques jours, très énervant
Archlinux depuis Jan 2010
GNOME Shell sur HP Pavillon, E17 sur Dell Vostro, toujours Archlinux
[Blog]

Répondre