[lightdm] Lancer une session gnome

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
Avatar de l’utilisateur
lesebas
Chu Ko Nu
Messages : 300
Inscription : ven. 01 févr. 2013, 19:16

[lightdm] Lancer une session gnome

Message par lesebas » lun. 18 févr. 2013, 23:09

Salut,

Je viens d'installer lightdm mais je n'arrive pas à lancer ma session gnome... quand je me logue depuis le greeter : écran noir et retour à la case départ!

J'ai bien créé un ~./xinitrc avec

Code : Tout sélectionner

exec gnome-session


dedans...

Quelqu’un a-t-il une idée?
Dernière modification par tuxce le mar. 19 févr. 2013, 08:20, modifié 1 fois.
Raison : http://wiki.archlinux.fr/Forum#Format_du_titre
Seb

Archlinux sur AMD64 (xfce / lightdm)

Avatar de l’utilisateur
jc51
Chu Ko Nu
Messages : 317
Inscription : jeu. 08 déc. 2011, 16:37

Re: Lancer session gnome avec Lightdm

Message par jc51 » lun. 18 févr. 2013, 23:18

bonjour

c'est

Code : Tout sélectionner

~/.xinitrc
ThinkPad T410, 8GO, ssd Samsung 860 evo Archlinux/Gnome

Avatar de l’utilisateur
lesebas
Chu Ko Nu
Messages : 300
Inscription : ven. 01 févr. 2013, 19:16

Re: Lancer session gnome avec Lightdm

Message par lesebas » mar. 19 févr. 2013, 06:52

Oui, bien-sur... l'erreur n'est que dans mon post! Mon ~/.xinitrc semble correct de toute façon car un startx depuis le tty lance bien mon gnome.
Seb

Archlinux sur AMD64 (xfce / lightdm)

Avatar de l’utilisateur
Ypnose
Maître du Kyudo
Messages : 1363
Inscription : sam. 01 mai 2010, 13:17
Contact :

Re: [lightdm] Lancer une session gnome

Message par Ypnose » mar. 19 févr. 2013, 11:56

As-tu activé le service lightdm comme c'est précisé sur le wiki?

Avatar de l’utilisateur
lesebas
Chu Ko Nu
Messages : 300
Inscription : ven. 01 févr. 2013, 19:16

Re: [lightdm] Lancer une session gnome

Message par lesebas » mar. 19 févr. 2013, 18:41

Oui... sinon je n'aurais pas l'écran de login au démarrage...

En fait je viens de réussir à me loguer en modifiant /etc/lightdm/lightdm.conf:

Code : Tout sélectionner

[SeatDefaults]
...

user-session=gnome

...
Par contre ça veut dire que lightdm ne tient pas compte du ~/.xinitrc ... contrairement à ce qui est écrit dans le wiki anglophone.

Etape suivante choisir entre plusieurs environnements (avec webkit).
Seb

Archlinux sur AMD64 (xfce / lightdm)

benjarobin
Maître du Kyudo
Messages : 15922
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [lightdm] Lancer une session gnome

Message par benjarobin » mar. 19 févr. 2013, 19:04

Je viens de relire le Wiki, je n'ai pas trouvé de trace parlant de xinitrc
Peux tu donner le lien qui en parle ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
lesebas
Chu Ko Nu
Messages : 300
Inscription : ven. 01 févr. 2013, 19:16

Re: [lightdm] Lancer une session gnome

Message par lesebas » mar. 19 févr. 2013, 22:34

Salut, autant pour moi au gré de mes surfs sur le wiki j'ai confondu avec la doc sur le xinitrc https://wiki.archlinux.org/index.php/Xinit...

Mais bon rien n'indique dans le wiki sur lightdm qu'il faut initialiser la variable user-session dans lightdm.conf... j'ai trouvé la solution ici :

http://doc.ubuntu-fr.org/lightdm#change ... ilisateurs

Au passage le switch entre les users ne fonctionne pas non plus nativement, il faut extraire gdmfelxiserver de l'archive de lightdm ( https://launchpad.net/lightdm/+download et le copier dans /usr/local/bin :

Code : Tout sélectionner

tar -Jxf lightdm-1.5.0.tar.xz
cd lightdm-1.5.0/utils/
sudo cp gdmflexiserver /usr/local/bin/
Seb

Archlinux sur AMD64 (xfce / lightdm)

Avatar de l’utilisateur
lesebas
Chu Ko Nu
Messages : 300
Inscription : ven. 01 févr. 2013, 19:16

Re: [lightdm] Lancer une session gnome

Message par lesebas » mar. 05 mars 2013, 23:33

Bonjour,

Je cherche à lancer des sessions personnalisées pour chaque utilisateur (notamment un en gnome et l'autre en gnome fallback). J'ai donc crée des .xinitrc spécifiques à chaque utilisateur (qui fonctionnent avec startx depuis un console) puis un fichier /usr/share/xsessions/default.desktop qui contient les lignes suivantes:

Code : Tout sélectionner

[Desktop Entry]
Name=default
Exec=startx
Ensuite j'ai défini le paramètre dans /etc/lightdm/lightdm.conf

Code : Tout sélectionner

[SeatDefaults]
...

user-session=default

...
Mais ça ne marche pas... mes recherches sur google n'aboutissent pas, quelqu'un à-t-il une idée?
Seb

Archlinux sur AMD64 (xfce / lightdm)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10578
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [lightdm] Lancer une session gnome

Message par FoolEcho » mer. 06 mars 2013, 09:48

Pour avoir jeté un œil sur lightdm, je ne comprends pas ce que tu cherches à trafiquer. Lancer une session et conserver le réglage comme défaut pour l'utilisateur, c'est déjà le comportement par défaut, non ? :|

(ou alors c'est la session gnome fallback que tu veux rajouter dans les entrées ? :?: ... là je ne sais pas par contre, car c'est une modification par l'utilisateur sauf si bien sûr c'est la seule chose à lancer http://wiki.archlinux.fr/GNOME#Mode_restreint... Sinon ça passe plutôt par un /usr/share/xsessions/gnome-fallback.desktop et c'est tout -- mais pas qui lance startx en tous cas)
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [lightdm] Lancer une session gnome

Message par tuxce » mer. 06 mars 2013, 10:20

Salut, pour info, le prochain gnome n'aura plus le mode fallback (il aura un mode avec gnome-shell + extension qui singera l'ancienne interface)

Pour ce qui est du lancement de la session, déjà, lightdm lance une session mais X est déjà lancé. startx lance X, donc c'est plutôt ce que tu mets dans .xinitrc qu'il faut mettre dans le default.desktop

Sinon, vu que le mode de session gnome est une option utilisateur, si ton choix est juste gnome mode normal et mode fallback, il suffit d'utiliser la session gnome et de changer l'option au niveau de l'utilisateur.

Avatar de l’utilisateur
lesebas
Chu Ko Nu
Messages : 300
Inscription : ven. 01 févr. 2013, 19:16

Re: [lightdm] Lancer une session gnome

Message par lesebas » mer. 06 mars 2013, 12:17

Fool Echo

Quand tu dis :
Lancer une session et conserver le réglage comme défaut pour l'utilisateur
Je pense que c’est l’option dans le greeter unity (pas mal développé par Ubuntu).
Le truc c’est que je souhaite utiliser lightdm avec webkit comme greeter (en utilisant le thème suivant : https://github.com/jfbrazeau/lightdm-we ... ty-greeter). Ce thème ne propose pas de liste de choix de type de session. Je n’ai pas les connaissances suffisantes pour implémenter cette fonction dans le thème donc mon idée était de lancer chaque session utilisateur selon un script spécifique type ~/.xinit ou ~/.xsession.
Dans /etc/lightdm/lightdm.conf je n’ai pas trouvé d’option permettant de préciser d’ouvrir la session propre à chaque utilisateur, il y a juste une option pour définir la session par défaut mais pour tous les utilisateurs (user-session=<non du fichier.desktop>). Je vais quand même essayer d’ajouter un :

Code : Tout sélectionner

Exec = ~/.xinitrc
Dans mon custom.desktop, visiblement c’est la solution utilisée par le paquet https://aur.archlinux.org/packages/xses ... 0sur%20AUR.

Tuxce:

je ne savais que le mode fallback pour être défini indépendamment pour chaque user. Effectivement dans un premier temps ça pourrait régler mon problème (ensuite je souhaite tester d'autre environnements). Comment définit-on le mode pour chaque utilisateur? La commande :

Code : Tout sélectionner

gsettings set org.gnome.desktop.session session-name gnome-fallback
ne s'applique pas à tous les utilisateurs?
Seb

Archlinux sur AMD64 (xfce / lightdm)

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [lightdm] Lancer une session gnome

Message par tuxce » mer. 06 mars 2013, 12:32

lesebas a écrit :Dans /etc/lightdm/lightdm.conf je n’ai pas trouvé d’option permettant de préciser d’ouvrir la session propre à chaque utilisateur, il y a juste une option pour définir la session par défaut mais pour tous les utilisateurs (user-session=<non du fichier.desktop>). Je vais quand même essayer d’ajouter un :

Code : Tout sélectionner

Exec = ~/.xinitrc
Pour lancer un script chez l'utilisateur, il faut mettre un .desktop qui lance un script général qui lui appellera un script utilisateur. Par exemple :

Code : Tout sélectionner

[Desktop Entry]
Name=Session utilisateur
Exec=session_utilisateur
Type=XSession
et session_utilisateur :

Code : Tout sélectionner

#!/bin/bash
. $HOME/.xinitrc
lesebas a écrit :La commande :

Code : Tout sélectionner

gsettings set org.gnome.desktop.session session-name gnome-fallback
ne s'applique pas à tous les utilisateurs?
Non.

Sinon, pour info, avec lightdm, par défaut, il sauvegarde ce que l'utilisateur lance en dernier pour ensuite lancer la même chose.

Avatar de l’utilisateur
lesebas
Chu Ko Nu
Messages : 300
Inscription : ven. 01 févr. 2013, 19:16

Re: [lightdm] Lancer une session gnome

Message par lesebas » mer. 06 mars 2013, 13:18

Sinon, pour info, avec lightdm, par défaut, il sauvegarde ce que l'utilisateur lance en dernier pour ensuite lancer la même chose.
Oui, si tenté que l'option de choix soit activée depuis le greeter... Par contre ça veut dire que cette donnée est stockée dans un fichier de config lightdm propre à l'utilisateur? Je peux surement l'éditer et forcer la valeur, c'est ou?

Merci pour l'info du script général qui en appelle un autre, je vais essayer.
Seb

Archlinux sur AMD64 (xfce / lightdm)

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [lightdm] Lancer une session gnome

Message par tuxce » mer. 06 mars 2013, 13:47

C'est dans ~/.dmrc

Avatar de l’utilisateur
lesebas
Chu Ko Nu
Messages : 300
Inscription : ven. 01 févr. 2013, 19:16

Re: [lightdm] Lancer une session gnome

Message par lesebas » mer. 06 mars 2013, 23:10

Bon j'ai testé toutes les solutions mais rien ne marche pas:

modif de ~/.dmrc : ça me lance toujours la session renseignée dans lighdm.conf

le bouclage vers un fichier intermédiare qui lance :

Code : Tout sélectionner

. $HOME/.xinitrc
Ça n'ouvre rien...

Je sens que je vais retourner vers un greeter GTK standard...
Seb

Archlinux sur AMD64 (xfce / lightdm)

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [lightdm] Lancer une session gnome

Message par tuxce » jeu. 07 mars 2013, 13:04

Pour dmrc, j'ai pas lightdm sous la main pour tester.
Par contre, pour la session qui lance le .xinitrc, elle devrait fonctionner de la même façon qu'une autre session. Tu as une erreur dans ~/.xsession-errors ?

Avatar de l’utilisateur
lesebas
Chu Ko Nu
Messages : 300
Inscription : ven. 01 févr. 2013, 19:16

Re: [lightdm] Lancer une session gnome

Message par lesebas » jeu. 07 mars 2013, 19:26

Oui pas mal d'erreurs mais vu que j'ai testé pas mal de solutions... difficile de dire ce qui cloche. Je refais un essai ce soir et je poste mon ~/xsession-errors
Seb

Archlinux sur AMD64 (xfce / lightdm)

Avatar de l’utilisateur
lesebas
Chu Ko Nu
Messages : 300
Inscription : ven. 01 févr. 2013, 19:16

Re: [lightdm] Lancer une session gnome

Message par lesebas » jeu. 07 mars 2013, 22:25

Finalement j'ai tout repris à plat... ca marche !!! :bravo: Je devais commencer à fatiguer hier-soir! Merci beaucoup tuxce ! Maintenant reste à activer le mode composit en fallback....
Seb

Archlinux sur AMD64 (xfce / lightdm)

Répondre