[Mise à jour du 03/06/2013] XFCE ne se lance plus (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Grydz
Hankyu
Messages : 31
Inscription : ven. 27 nov. 2009, 18:18
Localisation : Paris

[Mise à jour du 03/06/2013] XFCE ne se lance plus (résolu)

Message par Grydz » lun. 03 juin 2013, 21:14

Rebonjour,

J'ai effectué la mise à jour d'aujourd'hui avec succès sur mon ordinateur de bureau avec Gnome 3.

Tout s'est bien passé aussi sur mon laptop avec XFCE (qui ne possède pas desktop manager) mais je n'arrive plus à lancer XFCE au reboot.

Pour information je lançais ma session X en me connectant à mon utilisateur avec la technique du .bash_profile.

En gros ça fait comme si ça se lançait sans rien afficher puis je reviens dans la tty avec:

Code : Tout sélectionner

waiting for X server to shut down .Server terminated successfully (0). closing log file.s not installed.Aborted startup...xinit: conection to X server lostng
J'ai finalement retiré ce que j'avais mis dans le .bash_profile mais les classiques :

Code : Tout sélectionner

startx
ne fonctionnent plus non plus...

Je n'ai rien dans :

Code : Tout sélectionner

/var/log/Xorg.0.log
Des idées ?


Merci :)
Dernière modification par Grydz le lun. 03 juin 2013, 22:55, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Mise à jour du 03/06/2013] XFCE ne se lance plus

Message par benjarobin » lun. 03 juin 2013, 21:31

Il y a quoi dans le .xinitrc ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Grydz
Hankyu
Messages : 31
Inscription : ven. 27 nov. 2009, 18:18
Localisation : Paris

Re: [Mise à jour du 03/06/2013] XFCE ne se lance plus

Message par Grydz » lun. 03 juin 2013, 22:50

Dans le .xinitrc :

Code : Tout sélectionner

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

exec startxfce4 --with-ck-launch

Grydz
Hankyu
Messages : 31
Inscription : ven. 27 nov. 2009, 18:18
Localisation : Paris

Re: [Mise à jour du 03/06/2013] XFCE ne se lance plus

Message par Grydz » lun. 03 juin 2013, 22:55

Il fallait remplacer par :

Code : Tout sélectionner

exec startxfce4
C'est résolu !

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10578
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Mise à jour du 03/06/2013] XFCE ne se lance plus (résol

Message par FoolEcho » mar. 04 juin 2013, 09:16

...tu ferais bien de te débarasser de consolekit de toutes manières... http://archlinux.fr/news/consolekit-est ... par-logind
«The following statement is not true. The previous statement is true.» :nage:

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Mise à jour du 03/06/2013] XFCE ne se lance plus (résol

Message par benjarobin » mar. 04 juin 2013, 09:51

C'est ce qu'il a fait, mais cela empêchait de démarrer startxfce4 car il avait toujours l'option --with-ck-launch
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre