[install] script d'installation, démarrage de gnome

Questions et astuces concernant l'installation et la configuration d'archlinux
Fnux
Hankyu
Messages : 29
Inscription : ven. 31 mai 2013, 02:30
Localisation : Palm Beach (Fl, USA)

[install] script d'installation, démarrage de gnome

Message par Fnux » mer. 05 juin 2013, 07:28

[EDIT MODO]split depuis http://forums.archlinux.fr/topic13671.html[/EDIT]
Salut Anghirrm,
Anghirrim a écrit :Salut,

Pour le Wiki, honnêtement, avec trois pages (allez, quatre en rajoutant le gestionnaire de connexion), tu arrives à un Arch fonctionnel.

Tu ne devrais pas dépasser le A, B et C :wink:

Jusqu'où est-tu allé dans l'installation, à quel moment bloques-tu? X est-il installé?

[Edit] A lire tes autres sujets j'imagine que X est installé. Est-il fonctionnel, as-tu installé un environnement et si oui, comment tentes-tu de le lancer?
Merci de ton message, mais Tabernacle, je dois être le dernier des niaiseux des Trois Rivières pour ne pas être capable d'exécuter à la lettre les A, B et C (ce que je pense quand même faire)!

Donc, je récapipète :

J'aimerai installer ArchLinux sur un disque qui a déjà Debian Wheezy (/dev/sda2) et Ubuntu Raring (/dev/sda3) avec un swap commun (/dev/sda1) et surtout Grub comme OS loader.

Voici donc la liste complète des commandes que je passe pour "tenter" d'installer ArchLinux depuis le dernier .iso que j'ai téléchargé :

Boot sur l'iso et séquence de commandes :

Code : Tout sélectionner

setterm -blank 0
export LANG=fr_FR.UTF-8
loadkeys fr-pc
swapon /dev/sda1
mkfs.ext4 /dev/sda5
mount /dev/sda5 /mnt
mkdir /mnt/{boot,home}
pacstrap /mnt base base-devel
arch-chroot /mnt pacman -S grub-bios os-prober libisoburn mtools libx11 libsm
arch-chroot /mnt
echo "acer-arch-64" >> /etc/hostname
echo "fr_FR.UTF-8 UTF-8" >> /etc/locale.gen
locale-gen
echo "fr-pc" >> /etc/locale.conf
export LANG=fr_FR.UTF-8
echo "KEYMAP=fr-pc" >> /etc/vconsole.conf
ln -s /usr/share/zoneinfo/Europe/Paris /etc/localtime
mkinitcpio -p linux
os-prober
grub-mkconfig -o /boot/grub/grub.cfg
modprobe dm-mod
grub-install --boot-directory=/boot --no-floppy --recheck /dev/sda
cp /usr/share/grub/{unicode.pf2,ascii.pf2} /boot/grub
passwd
useradd -g users -m -s /bin/bash fnux
passwd fnux
systemctl start dhcpcd.service
pacman -Syu xorg-server xorg-xinit xorg-server-utils

pacman -S xf86-video-vmware #pour une installation sous VMware
#pacman -S xf86-video-nouveau #pour une installation sur mon portable Acer

pacman -S xorg-fonts-type1 ttf-dejavu artwiz-fonts font-bh-ttf font-bitstream-speedo gsfonts sdl_ttf ttf-bitstream-vera ttf-cheapskate ttf-liberation
echo "Section \"InputClass\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
echo "  Identifier       \"Keyboard Layout\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
echo "  MatchIsKeyboard  \"yes\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
echo "  MatchDevicePath  \"/dev/input/event*\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
echo "  Option           \"XkbLayout\"  \"fr\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
echo "  Option           \"XkbVariant\" \"oss\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
echo "EndSection" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
echo "Section \"InputClass\"" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
echo "  Identifier       \"Keyboard Layout\"" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
echo "  MatchIsKeyboard  \"yes\"" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
echo "  MatchDevicePath  \"/dev/input/event*\"" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
echo "  Option           \"XkbOptions\"  \"terminate:ctrl_alt_bksp\"" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
echo "EndSection" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
echo "Section \"Monitor\"" >> /etc/X11/xorg.conf.d/10-monitor.conf
echo "  Identifier  \"Monitor0\"" >> /etc/X11/xorg.conf.d/10-monitor.conf
echo "  Modeline    \"1024x768_60.00\" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync" >> /etc/X11/xorg.conf.d/10-monitor.conf
echo "  Option      \"PrefferedMode\" \"1024x768\"" >> /etc/X11/xorg.conf.d/10-monitor.conf
echo "EndSection" >> /etc/X11/xorg.conf.d/10-monitor.conf
pacman -Syu gnome gnome-extra gdm
exec gnome-session
umount /mnt
reboot
J'ai aussi essayé la séquence de commandes suivante qui abouti au même résultat :

Code : Tout sélectionner

setterm -blank 0
export LANG=fr_FR.UTF-8
loadkeys fr-pc
swapon /dev/sda1
mkfs.ext4 /dev/sda5
mount /dev/sda5 /mnt
mkdir /mnt/{boot,home}
pacstrap /mnt base base-devel
arch-chroot /mnt pacman -S grub-bios os-prober libisoburn mtools libx11 libsm
arch-chroot /mnt echo "acer-arch-64" >> /etc/hostname
arch-chroot /mnt echo "fr_FR.UTF-8 UTF-8" >> /etc/locale.gen
arch-chroot /mnt locale-gen
arch-chroot /mnt echo "fr-pc" >> /etc/locale.conf
arch-chroot /mnt export LANG=fr_FR.UTF-8
arch-chroot /mnt echo "KEYMAP=fr-pc" >> /etc/vconsole.conf
arch-chroot /mnt ln -s /usr/share/zoneinfo/Europe/Paris /etc/localtime
arch-chroot /mnt mkinitcpio -p linux
arch-chroot /mnt os-prober
arch-chroot /mnt grub-mkconfig -o /boot/grub/grub.cfg
arch-chroot /mnt modprobe dm-mod
arch-chroot /mnt grub-install --boot-directory=/boot --no-floppy --recheck /dev/sda
arch-chroot /mnt cp /usr/share/grub/{unicode.pf2,ascii.pf2} /boot/grub
arch-chroot /mnt passwd
arch-chroot /mnt useradd -g users -m -s /bin/bash fnux
arch-chroot /mnt passwd fnux
arch-chroot /mnt systemctl start dhcpcd.service
arch-chroot /mnt pacman -Syu xorg-server xorg-xinit xorg-server-utils
arch-chroot /mnt pacman -S xf86-video-vmware
arch-chroot /mnt pacman -S xorg-fonts-type1 ttf-dejavu artwiz-fonts font-bh-ttf font-bitstream-speedo gsfonts sdl_ttf ttf-bitstream-vera ttf-cheapskate ttf-liberation
arch-chroot /mnt echo "Section \"InputClass\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
arch-chroot /mnt echo "  Identifier       \"Keyboard Layout\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
arch-chroot /mnt echo "  MatchIsKeyboard  \"yes\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
arch-chroot /mnt echo "  MatchDevicePath  \"/dev/input/event*\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
arch-chroot /mnt echo "  Option           \"XkbLayout\"  \"fr\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
arch-chroot /mnt echo "  Option           \"XkbVariant\" \"oss\"" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
arch-chroot /mnt echo "EndSection" >> /etc/X11/xorg.conf.d/10-keyboard-layout.conf
arch-chroot /mnt echo "Section \"InputClass\"" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
arch-chroot /mnt echo "  Identifier       \"Keyboard Layout\"" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
arch-chroot /mnt echo "  MatchIsKeyboard  \"yes\"" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
arch-chroot /mnt echo "  MatchDevicePath  \"/dev/input/event*\"" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
arch-chroot /mnt echo "  Option           \"XkbOptions\"  \"terminate:ctrl_alt_bksp\"" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
arch-chroot /mnt echo "EndSection" >> /etc/X11/xorg.conf.d/10-keyboard-terminate.conf
arch-chroot /mnt echo "Section \"Monitor\"" >> /etc/X11/xorg.conf.d/10-monitor.conf
arch-chroot /mnt echo "  Identifier  \"Monitor0\"" >> /etc/X11/xorg.conf.d/10-monitor.conf
arch-chroot /mnt echo "  Modeline    \"1024x768_60.00\" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync" >> /etc/X11/xorg.conf.d/10-monitor.conf
arch-chroot /mnt echo "  Option      \"PrefferedMode\" \"1024x768\"" >> /etc/X11/xorg.conf.d/10-monitor.conf
arch-chroot /mnt echo "EndSection" >> /etc/X11/xorg.conf.d/10-monitor.conf
arch-chroot /mnt pacman -Syu gnome gnome-extra gdm
arch-chroot /mnt exec gnome-session
arch-chroot /mnt exit
arch-chroot umount /mnt
reboot
Donc, déjà dans cette séquence de commandes, je dois avoir oublié quelque chose puisque je ne démarre pas avec Gnome (bon, je sais que je suis nul -pas la peine aux autres de le redire!).

Ensuite, après le reboot, que je me "log" (ou sign in si tu préfères) en "root" ou avec "fnux", j'ai un premier message :

"-bash: fr-pc: command not found" alors que le clavier est bien en Français!

Ensuite, je suis dans une session terminal et, oh surprise... je ne peut même pas créer un fichier du genre :

Code : Tout sélectionner

nano test.sh
echo "Bonjour."
Ctrl O
car j'obtiens le message suivant dans la ligne du bas de nano:

"[ Error writing test.sh: Read-only file system ]

Donc, c'est plutôt mal parti pour continuer à faire quoi que ce soit ! :shock:

Question : pourquoi le "file system" est-il donc en "read-only" car je ne vois aucune des commandes précédentes qui pu faire cela.

Si tu (ou quelqu'un d'autre) veux bien m'aider, ça serait très sympa de ta part car je veux absolument utiliser ArchLinux.

Merci d'avance.
Dernière modification par Fnux le mer. 05 juin 2013, 07:52, modifié 1 fois.

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [GUI] Y a-t-il un LiveCD récent qui installe Arch avec G

Message par tuxce » mer. 05 juin 2013, 08:05

Merci d'arrêter de poster x message à la suite, tu peux utiliser le bouton citer dans la page répondre pour citer dans un même message toute personne à qui tu veux répondre.

Comme tu as 3 ou 4 topics qui finissent par tourner autour des même choses, on va en limiter (je vais quand même attendre que tu répondes aux autres), ça évitera d'avoir à suivre x topics pour le même souci.

Comme tu as posté le script ici, on va continuer ici si ça ne te dérange pas.
Fnux a écrit :

Code : Tout sélectionner

pacman -Syu gnome gnome-extra gdm
exec gnome-session
umount /mnt
reboot
- le "exec gnome-session" est à mettre dans le .xinitrc pour pouvoir lancer "startx" mais je sais, la page startx est perdue parmi les autres.
- il faut d'abord démarrer sur le système installé avant de démarrer une session graphique
Fnux a écrit :

Code : Tout sélectionner

arch-chroot /mnt echo "acer-arch-64" >> /etc/hostname
Cette commande lance le "echo ..." dans le chroot, par contre, le ">> ..." est une syntaxe dans le shell non chrooté ce qui aura pour conséquence de rajouter un fichier dans le live et non dans le système installé.
Pour juste un echo :

Code : Tout sélectionner

echo "KEYMAP=fr-pc" > /mnt/etc/vconsole.conf
Sinon, écrire un fr-pc dans locale.conf, je ne sais pas où t'as vu ça.

oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [GUI] Y a-t-il un LiveCD récent qui installe Arch avec G

Message par oktoberfest » mer. 05 juin 2013, 08:07

Fnux a écrit : Ensuite, après le reboot, que je me "log" (ou sign in si tu préfères) en "root" ou avec "fnux", j'ai un premier message :

"-bash: fr-pc: command not found" alors que le clavier est bien en Français!
Tout à fait normal. Tu as écris :

Code : Tout sélectionner

arch-chroot /mnt echo "fr-pc" >> /etc/locale.conf
Alors qu'il faut faire

Code : Tout sélectionner

arch-chroot /mnt echo "LANG=fr_FR.UTF-8" >> /etc/locale.conf
cd wiki :) (Tu as du confondre /etc/locale.conf et /etc/vconsole.conf)

Fnux a écrit :Ensuite, je suis dans une session terminal et, oh surprise... je ne peut même pas créer un fichier du genre :

Code : Tout sélectionner

nano test.sh
echo "Bonjour."
Ctrl O
car j'obtiens le message suivant dans la ligne du bas de nano:

"[ Error writing test.sh: Read-only file system ]

Donc, c'est plutôt mal parti pour continuer à faire quoi que ce soit ! :shock:

Question : pourquoi le "file system" est-il donc en "read-only" car je ne vois aucune des commandes précédentes qui pu faire cela.
Je pense que la réponse est dans ton /etc/fstab. A priori tu n'en as pas créé, et il y a de fortes chances que par défaut la racine soit monté en lecture seule.
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM

Verrouillé