[Grub2] EFI boot

Questions et astuces concernant l'installation et la configuration d'archlinux
Grydz
Hankyu
Messages : 31
Inscription : ven. 27 nov. 2009, 18:18
Localisation : Paris

[Grub2] EFI boot

Message par Grydz » lun. 02 déc. 2013, 21:29

Bonjour,

En faisant l'installation d'Arch avec UEFI sur mon Sony Vaio Pro 13 je recontre un soucis qui vient des cartes mères avec un BIOS H20.

Du coup je n'arrive pas à avoir accès au bootloader à la fin de l'installation. Pour information j'ai essayé avec grub2 mais aussi avec gummiboot.

Voila mon problème : j'ai supprimé tout windows et je n'ai donc plus d'entrée dans mon shell UEFI. Hors maintenant même si gummiboot s'installent bien je n'arrive pas à y avoir accès au reboot. C'est comme si les fichiers .efi n'avait pas été pris en compte.

Dans le cas de grub2 j'ai

Code : Tout sélectionner

show boot order() no such file or directory
au moment du grub-install.

Aussi je n'ai pas accès à un shell UEFI depuis le Bios du coup je ne peux avoir accès que à celui de la clé USB ce qui est un peu embêtant.

J'ai trouvé quelques information avec [1] et [2] mais je ne m'en sors toujours pas. J'imagine que tout se passe comme dans [3] si vous avez gardé Windows mais pas si vous n'avez plus rien sur le disque.

Des idées ?

[1] http://svparch.blogspot.fr/2013/09/arch ... -vaio.html
[2] http://www.linuxquestions.org/questions ... 175411129/
[3] https://wiki.archlinux.org/index.php/So ... stallation

Grydz
Hankyu
Messages : 31
Inscription : ven. 27 nov. 2009, 18:18
Localisation : Paris

Re: [Grub2] EFI boot

Message par Grydz » lun. 02 déc. 2013, 23:43

J'ai refait une install de zéro. Grub2 s'est bien installé sans erreur mais toujours pas de grub quand je redémarre.

J'ai bien rajouté l'option

Code : Tout sélectionner

libata.force=noncq
dans /etc/default/grub avant de faire

Code : Tout sélectionner

# grub-mkconfig -o /boot/grub/grub.cfg
ce que je remarque c'est que dès que je remonte le système et que je fais

Code : Tout sélectionner

# efibootmgr
j'obtiens

Code : Tout sélectionner

Timeout: 0 seconds
BootOrder: 0001
Boot0001* UEFI : USB DISK Pro PMAP
qui est ma clé bootable. Pourtant en faisant

Code : Tout sélectionner

efibootmgr -c -d /dev/sda -p 1 -l /EFI/arch_grub/grubx64.efi -L "arch"
j'obtiens bien une deuxième entrée mais elle n'aparait plus quand je remonte le système :?

Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1265
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [Grub2] EFI boot

Message par floflo77890 » mer. 04 déc. 2013, 21:46

si tu a un bios de type EFI tu n'as pas besoin de chargeur de démarrage.

Grydz
Hankyu
Messages : 31
Inscription : ven. 27 nov. 2009, 18:18
Localisation : Paris

Re: [Grub2] EFI boot

Message par Grydz » lun. 09 déc. 2013, 21:07

Pour ceux qui aurait ce problème, il faut voir ici : https://bbs.archlinux.org/viewtopic.php?pid=1358570

Pour le moment, il semblerait que le firmware soit bugé.

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Grub2] EFI boot

Message par Xorg » jeu. 12 déc. 2013, 19:32

C'est normal, tu ne peux pas avoir deux entrées avec le même "noyau" (bon, ici c'est Grub). Ça va apparaître après avoir tapé la commande, mais dès que tu vas redémarrer, ça va tout naturellement s'évaporer.
Tu peux essayer ainsi :

Code : Tout sélectionner

# efibootmgr -B -b 0001
# efibootmgr -c -d /dev/sda -p 1 -w -L "arch" -l '\EFI\arch_grub\grubx64.efi'
Je ne garantie pas que ça va fonctionner, mais ça devrait si tu nous a donné les bonnes informations. :)
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Répondre