[Configuration] Archlinux sur Sony Vaio (Résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
shindenryu
archer
Messages : 110
Inscription : mer. 25 déc. 2013, 18:18

Re: [Configuration] Archlinux sur Sony Vaio

Message par shindenryu »

Bon apparament j'ai reussi a faire une verification de l'iso que j'ai telecharge et tout est bon donc je continu, j'ai verifie l'integrite de l'image. Je continue ...
Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1266
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [Configuration] Archlinux sur Sony Vaio

Message par floflo77890 »

Normalement avec le wiki si tu le suis correctement et que tu comprebd ce que tu fait tu ne devrait pas avoir de problem.
shindenryu
archer
Messages : 110
Inscription : mer. 25 déc. 2013, 18:18

Re: [Configuration] Archlinux sur Sony Vaio

Message par shindenryu »

Bonjour,

J'ai effectue tous les reglages necessaires et j'ai toujours ce probleme de mkinitcpio.
avec le message suivant:


$ ~ > mkinitcpio -p linux
==> Building image from preset: 'default'
-> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> ERROR: Unable to write to /boot/initramfs-linux.img
==> Building image from preset: 'fallback'
-> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> ERROR: Unable to write to /boot/initramfs-linux-fallback.img

Bien que j'ai fait respecte tous les etapes des Wikis et que je fais mes essais sur Virtualbox avec l'image ISO d'archlinux,
J'ai controle l'integrite de l'image est il est correct.

Que puis je faire d'autre?
benjarobin
Maître du Kyudo
Messages : 16081
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Configuration] Archlinux sur Sony Vaio

Message par benjarobin »

Lance mkinitcpio depuis le chroot en root ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1266
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [Configuration] Archlinux sur Sony Vaio

Message par floflo77890 »

Si ton image est bonne que tu as bien suivi le wiki tu ne devrait pas qvoir cette erreur. Comme l'a dit benjarobin lance tu la commande depuis chroot. Si c''est le cas poste nous exactement tous ce que tu as fait pour l'installation.
shindenryu
archer
Messages : 110
Inscription : mer. 25 déc. 2013, 18:18

Re: [Configuration] Archlinux sur Sony Vaio

Message par shindenryu »

Bonjour,

Je reprends tout depuis le debut et j'ai deja une question sur la verification de l'iso.

J'ai cree un dossier Arch dans lequel j'ai le fichier ISO telecharge et j'ai mis dedans mes deux fichiers texte
md5sums.txt et sha1sums.txt. Ensuite avec Virtual je suis alle recherche l'ISO, et lordqu'il y a le root je demande a faire
la verification et la j'ai un message d'erreur.
Voici l'image de l'ecran.
md5sum: md5sums.txt: No such file or directory
Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1266
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [Configuration] Archlinux sur Sony Vaio

Message par floflo77890 »

ta as certainement su prendre que l'iso et non tout le dossier. car la ton erreur indique que le fichier que tu demande n'est pas présent.
shindenryu
archer
Messages : 110
Inscription : mer. 25 déc. 2013, 18:18

Re: [Configuration] Archlinux sur Sony Vaio

Message par shindenryu »

Mais lorsqu'on le telecharge sur les differents serveurs les fichiers textes sont separes de l'ISO,
donc je les enregistre et je les place dans un dossier unique.
Dois je rechercher un ISO avec integration de ces fichiers textes?
Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1266
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [Configuration] Archlinux sur Sony Vaio

Message par floflo77890 »

au pire tu peut passer la vérification. si tu as bien télécharger l'iso depuis archlinux.fr tu ne devrais pas avoir de problème.
je ne sais pas si on trouve des image iso avec les fichiers de vérification directement intégrer dedans.
benjarobin
Maître du Kyudo
Messages : 16081
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Configuration] Archlinux sur Sony Vaio

Message par benjarobin »

@floflo77890 C'est techniquement impossible car cela voudrait dire que :

Code : Tout sélectionner

( iso + hash(iso) ) = hash(iso)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1266
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [Configuration] Archlinux sur Sony Vaio

Message par floflo77890 »

Il faut donc faire comment dans son cas.
PS: je n'est pas fait de vérification lors de mon installation je ne sais donc pas comment faire.
benjarobin
Maître du Kyudo
Messages : 16081
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Configuration] Archlinux sur Sony Vaio

Message par benjarobin »

Son ISO il doit la monter avec VirtualBox, donc pas besoin de faire une gravure de CD...
Il suffit de faire comme décrit dans le Wiki Installation :

Code : Tout sélectionner

md5sum archlinux-2013.12.01-dual.iso
et tu compares à la main le md5sum, ou tu fait tout simplement :

Code : Tout sélectionner

md5sum -c md5sums.txt
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1266
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [Configuration] Archlinux sur Sony Vaio

Message par floflo77890 »

D'accord je viens de lire la partie du wiki.
shindenryu
archer
Messages : 110
Inscription : mer. 25 déc. 2013, 18:18

Re: [Configuration] Archlinux sur Sony Vaio

Message par shindenryu »

OK merci je vais regarder ca, j'ai juste une derniere question pour le partionnement je vais utliser cfdisk, concernant l'architecture suivante :

/dev/sda1 pour le /boot
/dev/sda2 pour la swap
/dev/sda3 pour le /
/dev/sda4 pour le /home

quelle partie doit etre en primary et quelle partie en logical s'il vous plait?
Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1266
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [Configuration] Archlinux sur Sony Vaio

Message par floflo77890 »

Il me semble que le boot et le swap son en primary et les deux autre en extended en gros tu auras:
/dev/sda1 pour le boot (primaire)
/dev/sda2 pour le swap (primaire)
/dev/sda3 parution conteneur (extended)
/dev/sda5 pour le / (logical)
/dev/sda6 home (logical)
shindenryu
archer
Messages : 110
Inscription : mer. 25 déc. 2013, 18:18

Re: [Configuration] Archlinux sur Sony Vaio

Message par shindenryu »

Merci pour les precisions, ca y est j'ai attaque je vais voir jusqu'ou je peux aller en respectant les wikis.
Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1266
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [Configuration] Archlinux sur Sony Vaio

Message par floflo77890 »

Si tu suis correctement tu ne devrais pas avoir de problème.
shindenryu
archer
Messages : 110
Inscription : mer. 25 déc. 2013, 18:18

Re: [Configuration] Archlinux sur Sony Vaio

Message par shindenryu »

Oui c'est ce que je suis en train de faire en relisant plusieurs fois le wiki ou du moins la partie qui me semble pas tres clair et en decortiquant les mots et le sens.
Du coup je ne le fais plus sur mon Sony Vaio mais sur mon PC fixe et ensuite je le ferai sur le portable, car sur le portable c'etait pas evident a bosser avec le petit ecran, on est plus a l'aise avec un grand ecran.
shindenryu
archer
Messages : 110
Inscription : mer. 25 déc. 2013, 18:18

Re: [Configuration] Archlinux sur Sony Vaio

Message par shindenryu »

En y allant lentement mais surement j'ai reussi a passer le cap pour mkinintcpio, et benjarobin avait raison il fallait bien etre en chroot. Ouf ca y est.
Mais je suis confronte a un autre souci, il y a des erreurs de syntaxe apparement.

Image
Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1266
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [Configuration] Archlinux sur Sony Vaio

Message par floflo77890 »

Tu as choisi GRUB je te conseil plus syslinux mais bon. Pour ton problème tu as du faire une erreur dans la commande.
Peut tu nous poster les logs.
Répondre