[Système] - Impossible de démarrer après une mise-à-jour

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
lama02
Hankyu
Messages : 29
Inscription : sam. 14 déc. 2013, 09:53

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par lama02 » mar. 04 mars 2014, 11:02

Si j'ai bien compris il faut faire tab sur syslinux et ajouter la commande décrite en fin de ligne ?
Je suis un peu paumé là, enfin voila une photo de mon démarrage avec la commande modifiée : https://s.gks.gs/img/img/03-2014/IMG_20 ... 20_403.jpg
Il reste 5 seconde bloqué sur la dernière ligne puis redémarre.

oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par oktoberfest » mar. 04 mars 2014, 11:53

Désolé mais ça sert à rien... j'avais mal lu. Il te faut un shell pour ensuite taper dmesg pour récupérer les messages.
Quand ton pc redémarre, il fait cela proprement (avec arrêt des services via systemd) ?
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM

Avatar de l’utilisateur
lama02
Hankyu
Messages : 29
Inscription : sam. 14 déc. 2013, 09:53

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par lama02 » mar. 04 mars 2014, 12:44

Non, il se freeze 5 secondes, écran noir et reboot (écran du BIOS).

oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par oktoberfest » mar. 04 mars 2014, 14:26

En mode rescue il démarre bien ? ('systemd.unit=rescue.target' à ajouter au démarrage du noyau).
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM

Avatar de l’utilisateur
lama02
Hankyu
Messages : 29
Inscription : sam. 14 déc. 2013, 09:53

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par lama02 » mar. 04 mars 2014, 20:36

Alors il démarre, me demande d'entrer mon mot-de-passe root pour la maintenance mais je ne peux pas l'écrire : il plante de manière identique.

oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par oktoberfest » mer. 05 mars 2014, 09:03

C'est donc plus sérieux que je ne pensais. Il ne s'agit pas d'un service systemd qui fait tout planter.
Tu as deux disques dans ton pc ? Si tu débranches le disque non système est-ce que ça marche mieux ?
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM

Avatar de l’utilisateur
lama02
Hankyu
Messages : 29
Inscription : sam. 14 déc. 2013, 09:53

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par lama02 » mer. 05 mars 2014, 18:57

J'ai un disque SSD (contenant les deux systèmes Linux et Windows) ainsi que deux disques de données (un en format ext4 et l'autre en ntfs).
J'ai essayé de les enlever ça ne change rien. Et en arch-chroot je peux monter les deux sans encombre, ils ne sont donc à priori pas endommager.

Ça commence à m'inquiéter moi aussi, qu'a-t-il pu bien se passer ? Et je m'interroge quant à l'utilité de formater et de réinstaller le système, ça a une chance de changer quelque chose ?

benjarobin
Maître du Kyudo
Messages : 15901
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par benjarobin » mer. 05 mars 2014, 19:50

Avant de passer aux extrémités essayes déjà de lancer le dernier CD d'installation d'ArchLinux de ce mois.
Si cela ne démarre pas, c'est que le souci est peut être au niveau du kernel/systemd. Si le PC démarre c'est que le souci est certainement au niveau du SSD : Donnée corrompu ou SSD mal en point...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Anghirrim
Elfe
Messages : 692
Inscription : mar. 28 févr. 2012, 11:09
Localisation : Loire-Atlantique

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par Anghirrim » jeu. 06 mars 2014, 08:08

@Benjarobin:

Il a déjà chrooté avec lelivecd pour obtenir les logs.

Pour la piste du SSD mal en point, je ne sais pas si c'est utile, mais avant un reboot, journalctl a eu le temps de marquer ça (extrait de son "journalctl -b" en chroot):

Code : Tout sélectionner

Feb 28 19:55:44 al-fixe systemd[1]: Mounted /mnt/Barracuda.
Feb 28 19:55:44 al-fixe systemd[1]: Starting Local File Systems.
Feb 28 19:55:44 al-fixe systemd[1]: Reached target Local File Systems.
Feb 28 19:55:44 al-fixe systemd[1]: Starting Recreate Volatile Files and Directories...
Feb 28 19:55:44 al-fixe systemd[1]: Starting Trigger Flushing of Journal to Persistent Storage...
Feb 28 19:55:44 al-fixe ntfs-3g[290]: Version 2013.1.13 external FUSE 29
Feb 28 19:55:44 al-fixe ntfs-3g[290]: Mounted /dev/sdb1 (Read-Write, label "Barracuda", NTFS 3.1)
Feb 28 19:55:44 al-fixe ntfs-3g[290]: Cmdline options: rw
Feb 28 19:55:44 al-fixe ntfs-3g[290]: Mount options: rw,allow_other,nonempty,relatime,fsname=/dev/sdb1,blkdev,blksize=4096
Feb 28 19:55:44 al-fixe ntfs-3g[290]: Ownership and permissions disabled, configuration type 7
Feb 28 19:55:44 al-fixe systemd[1]: Started Recreate Volatile Files and Directories.
Feb 28 19:55:44 al-fixe systemd[1]: Starting Update UTMP about System Reboot/Shutdown...
Feb 28 19:55:44 al-fixe systemd-journal[126]: Permanent journal is using 990.2M (max 4.0G, leaving 4.0G of free 159.1G, current limit 4.0G).
Des problèmes de droits. Je ne sais pas si ça peut jouer?
Tour Intel© Core™ i5-4670, Arch Linux Cinnamon + Windows 10
Asus X53S, Linux Mint Tricia 19.3 Cinnamon

benjarobin
Maître du Kyudo
Messages : 15901
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par benjarobin » jeu. 06 mars 2014, 10:01

Quelle problème de droit, je en vois rien dans l'extrait que tu as donné
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Anghirrim
Elfe
Messages : 692
Inscription : mar. 28 févr. 2012, 11:09
Localisation : Loire-Atlantique

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par Anghirrim » jeu. 06 mars 2014, 10:25

Lignes 4 et 5 en partant du bas. Celles qui disent "ownership and permissions disabled". Après je n'en sais rien du tout si ça a quelque chose à voir...

Et sur le log complet, à chaque reboot, une des dernières actions concerne le barracuda.
Tour Intel© Core™ i5-4670, Arch Linux Cinnamon + Windows 10
Asus X53S, Linux Mint Tricia 19.3 Cinnamon

Avatar de l’utilisateur
lama02
Hankyu
Messages : 29
Inscription : sam. 14 déc. 2013, 09:53

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par lama02 » sam. 08 mars 2014, 10:36

Bon j'ai voulu reformater le système donc j'ai téléchargé la dernière iso en date via torrent sur le site d'Arch et mauvaise surprise : impossible de démarrer sur la clé (le même bug, il plante lors du chargement) !

iso du 2014.03.01 avec vérification md5 / pgp signature.

Incompatibilité matérielle ?

benjarobin
Maître du Kyudo
Messages : 15901
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par benjarobin » sam. 08 mars 2014, 10:55

Donc c'est comme j'ai dit, soit un problème kernel soit un problème avec systemd.
Pour exclure le problème avec systemd, il suffit de tester avec un kernel plus ancien : Le paquet linux-lts est fait pour cela
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Tucnacek
Chu Ko Nu
Messages : 332
Inscription : sam. 28 sept. 2013, 22:40

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par Tucnacek » sam. 08 mars 2014, 13:29

Je crois me souvenir qu'il a déjà effectué le test avec le kernel lts.
Il ne reste donc plus que l'autre solution (et je ne peux en apporter aucune pour ma part).

Avatar de l’utilisateur
lama02
Hankyu
Messages : 29
Inscription : sam. 14 déc. 2013, 09:53

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par lama02 » sam. 08 mars 2014, 14:23

Oui j'ai mis le noyau LTS et rien n'a changé.
Donc le problème correspond à quoi ?

Avatar de l’utilisateur
lama02
Hankyu
Messages : 29
Inscription : sam. 14 déc. 2013, 09:53

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par lama02 » mar. 01 avr. 2014, 17:34

Bon en ce 1er avril je démarre l'ordinateur et ayant oublié de sélectionner Windows dans le bootloader mon pc à démarrer sous Linux - et ça a marché !
J'ai tenté un reboot et le problème était revenus. Mais après avoir redémarrer une dizaine de fois j'ai réussi à me connecter à nouveau... et après un pacman -Syu ça a l'air de démarrer correctement...

Je serai bien curieux de savoir quel était le problème !

Elbarto
Elfe
Messages : 671
Inscription : jeu. 22 déc. 2011, 23:15

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par Elbarto » sam. 05 avr. 2014, 20:13

faut regarder si le problème est matériel, des données corrompues qui apparaissent de manière aléatoire :

- tester les barettes ram avec memtest ( via un cd de boot, clé usb ou disquette, ou menu "memtest" à rajouter dans grub ou syslinux c'est relativement facile à faire )

- vérifier l'état de santé du disque dur ( et du SSD ) en regardant les données smart, ou en utilisant un utilitaire qui lancera des tests ( court, étendu ), généralement un utilitaire du fabricant de ce disque dur et SDD, le paquet smartmontools peut aussi faire l'affaire

vérifier aussi la bonne ventilation du PC ( température CPU ) et le bloc d'alimentation ( voltages qui doivent être compris dans un intervalle acceptable ), les paquets lm_sensors et xsensors seront utiles pour accéder à ces valeurs

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par Xorg » dim. 06 avr. 2014, 15:03

Pour les tensions (et, accessoirement, les températures), en général on peut les vérifier dans le setup du BIOS/UEFI. Mais je penche aussi pour un problème matériel, ayant déjà connu ce genre de problèmes incompréhensibles (mais à en devenir fou). :roll:

Le matériel que tu as, il est vieux ou récent ? Peut-être qu'on pourra trouver une piste avec ces indications. :chinois:
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Avatar de l’utilisateur
lama02
Hankyu
Messages : 29
Inscription : sam. 14 déc. 2013, 09:53

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par lama02 » lun. 21 avr. 2014, 23:12

Bon j'ai trouvé : c'était la carte graphique (ATI Radeon HD4870 1Go).
Je pense qu'elle n'a rien (aucun problème avec Windows) et que donc c'était un soucis du pilote (le fait que le PC arrive à démarrer de temps à autre sous Linux).

Bref j'ai changé la carte graphique et tout est rentré dans l'ordre.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10576
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Système] - Impossible de démarrer après une mise-à-jour

Message par FoolEcho » mar. 22 avr. 2014, 11:37

:contourne:
«The following statement is not true. The previous statement is true.» :nage:

Répondre