[fstab] Partition NTFS montée automatiquement (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Dohtem
Hankyu
Messages : 13
Inscription : sam. 09 août 2014, 11:51

[fstab] Partition NTFS montée automatiquement (résolu)

Message par Dohtem »

Eh bien, il suffit d'une mission de 6 mois sur du dev windows pour ne plus savoir se servir d'un autre système, c'en est triste :roll:

J'imagine que c'est un problème récurrent, j'utilise mon laptop en dual boot avec windows, je communique donc avec une partition data en ntfs. J'aurais bien voulu l'utiliser en tant que /home mais j'ai lu quelque part que c'était impossible :(

Bref, du coup je compte monter ma partition data au démarrage pour que je puisse avoir accès en écriture/lecture aux users.

Du coup je récupère un bout de code que j'ai trouvé dans un autre topic

Code : Tout sélectionner

UUID=3AF4D7FB5FDB4FEC		/mnt/DATA	ntfs-3g	defaults,uid=root,gid=users,fmask=0113,dmask=0002  0 0	
Evidemment cet UUID correspond à ma partition data et j'ai installé le paquet ntfs-3g

Donc je rajoute cette ligne dans mon fstab et je démarre en mode d'urgence, il faut que je l'enlève pour pouvoir démarrer correctement :(
Dernière modification par Dohtem le ven. 15 août 2014, 19:47, modifié 1 fois.
Fanch
archer
Messages : 140
Inscription : lun. 01 déc. 2008, 21:16
Contact :

Re: [fstab] Partition NTFS montée automatiquement

Message par Fanch »

Tu n'as pas besoins de redémarrer pour tester ton fstab ;)


Tu peux faire en root :

Code : Tout sélectionner

mount -a
qui va essayer de monter toutes les lignes de ton fstab (qui ne sont pas déjà monté)




ou

Code : Tout sélectionner

mount /mnt/DATA
qui va utiliser la ligne correspondante dans ton fstab pour monter /mnt/DATA
"The three principal virtues of a programmer are Laziness, Impatience, and Hubris." -> man perl
benjarobin
Maître du Kyudo
Messages : 16075
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [fstab] Partition NTFS montée automatiquement

Message par benjarobin »

Quelle est la sortie (en root) de :

Code : Tout sélectionner

blkid
ls -ld /mnt/DATA
ls -la /mnt/
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Dohtem
Hankyu
Messages : 13
Inscription : sam. 09 août 2014, 11:51

Re: [fstab] Partition NTFS montée automatiquement

Message par Dohtem »

Ok merci pour l'astuce, quand je fais mount -a j'ai :

Code : Tout sélectionner

[root@max-arch max]# mount -a
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda5': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Code : Tout sélectionner

[root@max-arch max]# blkid
/dev/sda1: UUID="5537-D6CA" TYPE="vfat" PARTUUID="50cc5992-53d8-45e7-8137-cb382d33faed" 
/dev/sda2: UUID="504fd4dd-7e36-41fe-9a42-3dc585cd97e2" TYPE="swap" PARTUUID="772c5ed3-ff0a-40e7-a6ac-54c1e45404cb" 
/dev/sda3: UUID="d1b46cf6-beaa-4aa5-9e4a-ad2fccffdfcd" TYPE="ext4" PARTUUID="8e7fe686-1925-43b3-811c-d06823b24bc0" 
/dev/sda4: UUID="e6e249c2-2d88-405c-9f43-d9206a3bea53" TYPE="ext4" PARTUUID="eb3ee550-4978-4e12-97e2-fd62c39fcf30" 
/dev/sda5: LABEL="DATA" UUID="3AF4D7FB5FDB4FEC" TYPE="ntfs" PARTUUID="60e23085-9e26-43d9-8607-d46ccc25caa4" 
/dev/sda6: LABEL="W8" UUID="70E9F3C818DF7AA0" TYPE="ntfs" PARTUUID="e24f306c-92d6-4ff4-8b0e-f5f7864b4a21" 

[root@max-arch max]# ls -ld /mnt/DATA/
drwxr-xr-x 2 root root 4096 Aug 14 18:10 /mnt/DATA/
[root@max-arch max]# ls -la /mnt/
total 12
drwxr-xr-x  3 root root 4096 Aug 14 18:10 .
drwxr-xr-x 18 root root 4096 Aug 14 18:18 ..
drwxr-xr-x  2 root root 4096 Aug 14 18:10 DATA
benjarobin
Maître du Kyudo
Messages : 16075
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [fstab] Partition NTFS montée automatiquement

Message par benjarobin »

Donc tu as la réponse à ta question. Il te faut démarrer sur le Windows et faire un arrêter normal et complet surtout pas de mise en veille prolongé...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Dohtem
Hankyu
Messages : 13
Inscription : sam. 09 août 2014, 11:51

Re: [fstab] Partition NTFS montée automatiquement

Message par Dohtem »

Oui et non. J'ai d'abord redémarrer sur ma partition windows et je me suis rendu compte que j'avais encore des mises à jour en suspend, je me suis donc dis que le problème venait de là.
Cependant, après avoir fini le processus de mises à jour, j'ai éteint correctement mon ordinateur (comme je le fais toujours), je suis retourné dans le bios pour mettre la priorité de démarrage sur linux mais j'ai toujours le même problème.
Je n'utilise jamais de mise à veille ou quoi que ce soit, j'éteins toujours en utilisant le bouton shut down de windows. Du coup je ne comprends pas pourquoi j'ai ce soucis. Est-ce que ça vient du moment ou je démarre mon ordinateur, le temps d'ouvrir le bios la partition windows commence à se charger ? Ca me parait quand même tiré par les cheveux.
benjarobin
Maître du Kyudo
Messages : 16075
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [fstab] Partition NTFS montée automatiquement

Message par benjarobin »

Sauf que le bouton d'extinction ne fait pas toujours un arrêt complet en fonction des versions de Windows et comment celui ci est paramétré.
Le mieux dans ton cas est d'éteindre en ligne de commande windows.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Dohtem
Hankyu
Messages : 13
Inscription : sam. 09 août 2014, 11:51

Re: [fstab] Partition NTFS montée automatiquement

Message par Dohtem »

Je me suis un peu renseigné sur W8 et effectivement il y a un mode qui s'appelle "fast boot" qui est activé d'origine dont je n'étais pas au courant. Il semblerait que même si ce mode est activé, on est capable de faire un full shutdown en passant par le menu WIN+X, si on passe par la charms bar on fera un "hybrid shutdown".
Autant te dire que j'ai essayé les deux et que dans les deux situations je n'ai pas été capable de monter ma partition sur arch. Du coup j'ai désactivé ce fastboot et j'ai éteint mon pc en ligne de commande. Et là magie, ma partition s'est montée, merci microsoft !

Merci de ton aide ;)
Répondre