[Uefi] installation dual boot windows 8 (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Chachatte
Daikyu
Messages : 61
Inscription : lun. 26 déc. 2011, 21:20

[Uefi] installation dual boot windows 8 (résolu)

Message par Chachatte » jeu. 06 nov. 2014, 13:32

Bonjour,
comme certain l ont vu je galere a installé archlinux en dual-boot. Je comprend pas tout dans le wiki.
Bon voila ce que j'ai fais:
J'ai déjà la partition uefi en /dev/sda1 je voulais installé la partition /boot/efi dedans mais apparement ce n'est pas la bonne facon de faire.

J'ai donc crée une partition de 200Mo efi avec cfdisk, puis mkfs.vfat -F32 /dev/sda9 que j'ai ensuite monté en /boot/efi (https://wiki.archlinux.fr/EFI_Boot_Stub)
Une autre partition en /dev/sda10 pour le / et une autre /dev/sda11 pour le /home
Un pacstrap /mnt base et un pacstrap /mnt gummiboot dialog
Mais lors de l'installation de gummiboot celui me sort:
File system /boot is not a fat efi system partition (esp) file system.
Dernière modification par Chachatte le dim. 23 nov. 2014, 18:41, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15565
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Uefi] installation dual boot windows 8

Message par benjarobin » jeu. 06 nov. 2014, 13:58

Je te conseil de refaire une lecture du Wiki...
Il faut que tu utilise /dev/sda1, l'ESP de Windows. Il ne faut pas créer de 2ième ESP, bien qu'en théorie cela peut fonctionner, jamais essayé...
Attention de ne pas effacer de fichier ou formater la partition /dev/sda1, car tu ne pourras plus démarrer Windows.

/dev/sda1 doit être monté dans /boot/efi dans le cas de Grub.

Si tu veux installer Gummiboot, je te conseil de lire cette page du Wiki Gummiboot
Attention cela diverge par rapport à la page fr EFI_Boot_Stub, en effet dans la page en anglais, /dev/sda1 doit être monté dans /boot/
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Chachatte
Daikyu
Messages : 61
Inscription : lun. 26 déc. 2011, 21:20

Re: [Uefi] installation dual boot windows 8

Message par Chachatte » jeu. 06 nov. 2014, 14:24

Je viens d'essayer en montant /dev/sda1 en /boot gummiboot me donne le meme message d'erreur. Avec grub pareil. Pourtant j'ai la vois bien monté avec lsblk.
Par contre quand je chroot je ne vois plus la partition boot juste la / et /home

benjarobin
Maître du Kyudo
Messages : 15565
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Uefi] installation dual boot windows 8

Message par benjarobin » jeu. 06 nov. 2014, 15:22

Bon reprenons, depuis le début.
Tu créer tes partitions, soit /, /home et éventuellement swap
On va dire pour la suite, (cela facilitera les explications) que / est /dev/sdb2, /home/ est /dev/sdb3, et la partition esp est /dev/sdb1

Attention je saute pas mal d'étape, merci de lire le Wiki pour ce qui manque...
Ceci est l'explication pour installer Grub

Code : Tout sélectionner

# Monte les partitions
mount /dev/sdb2 /mnt
mkdir -p /mnt/home /mnt/boot/efi
mount /dev/sdb3 /mnt/home
mount /dev/sdb1 /mnt/boot/efi

# Le contenu de /mnt/boot/efi doit contenir le sous dossier EFI.
# Si ce n'est pas le cas, tu as un souci...

# Tu fait l'installation de base
pacstrap /mnt base

# Tu génère le fstab
genfstab -U -p /mnt >> /mnt/etc/fstab

# Chrooter dans le nouveau système
arch-chroot /mnt

# Tu régénères l'initramfs
mkinitcpio -p linux

# Tu installes Grub
pacman -S grub
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch_grub --recheck
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Chachatte
Daikyu
Messages : 61
Inscription : lun. 26 déc. 2011, 21:20

Re: [Uefi] installation dual boot windows 8

Message par Chachatte » jeu. 06 nov. 2014, 15:34

J'avais une erreur avec genfstab qui me créer pas l'entrée avec /dev/sda1 /boot. Je m'en suis apercu en rédigeant le message d'avant.

Répondre