[Boot] Dual Screen AVANT démarrage de X. (Résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
inan
Hankyu
Messages : 14
Inscription : mar. 10 juil. 2012, 11:25

[Boot] Dual Screen AVANT démarrage de X. (Résolu)

Message par inan » ven. 18 sept. 2015, 06:18

Bonjour à tous.

Je tiens immédiatement à préciser que j'ai cherché de long en large sur le wiki (page "dualheads") pour ma question et je n'ai rien trouvé :(

J'expose mon problème :

Avant j'utilisais NOUVEAU, tout fonctionnait très bien et lorsque je passais grub au démarrage, j'avais ma sortie sur mes deux moniteurs (avant de lancer X). De là j'avais une petite ligne xrandr dans mon .xinitrc qui prennait le relai une fois X lancé.

Depuis que je suis passé au driver propriétaire, tout continue de bien fonctionne une fois X lancé, mais je n'ai plus mon terminal (post-grub ; pré-X) affiché sur mes deux écrans.

Vous allez me dire que ce n'est pas trop grave, sauf que j'ai une télé en HDMI et un écran (plus petit) de monitoring sur lequel toute la procédure de boot s'affiche et... J'ai des soucis de vue (bref), si jamais un jour j'ai un soucis, ça va vraiment me faire mal de dépanner tout le bouzin sur un petit écran...

Quelqu'un à une idée ? J'imagine que je vais devoir bidouiller dans grub pour ça ? C'est quand même con qu'avec NOUVEAU tout fonctionnait très bien. J'ai lu sur le forum que le driver propriétaire avait de meilleures performances ; c'est pour ça que j'ai changé :(

Ce serait déjà pas mal d'avoir le boot sur mon écran principal (même si la situation d'avant me convenait très bien ; càd d'avoir les deux écrans en "mirroir").

D'avance, merci à vous tous.

EDIT : Je précise que j'ai déjà été dans le BIOS afin de vérifier si il y avait une sortie vidéo "de préférence" et je n'ai rien trouvé.

Ma carte graphique est :

Code : Tout sélectionner

01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 760] (rev a1)
J'ai bien évidemment désinstallé NOUVEAU avant de procéder à l'installation de mes drivers propriétaires :

Code : Tout sélectionner

rm -rf /etc/X11/xorg*
mkdir /etc/X11/xorg.conf.d/
pacman -R xf86-video-nouveau
pacman -Syu nvidia-340xx nvidia-340xx-utils nvidia-340xx-libgl lib32-nvidia-340xx-utils lib32-nvidia-340xx-libgl
Dernière modification par inan le ven. 18 sept. 2015, 19:21, modifié 1 fois.
arch~awesome~zsh~urxvt | Intel i7-6700K / Nvidia GTX 1080 / Samsung SSD 960 EVO M.2 PCIe NVMe 250 Go

benjarobin
Maître du Kyudo
Messages : 15593
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Boot] Dual Screen AVANT démarrage de X.

Message par benjarobin » ven. 18 sept. 2015, 09:45

Bonjour,
Pourquoi as tu recopié cette procédure qui ne s'applique absolument pas à ton cas ? Il te faut le driver nvidia et non nvidia-340xx. De plus pourquoi supprimer la configuration de xorg comme un bourrin, cela marche mais tu perds la configuration de ton clavier ?
De plus c'est normal d'avoir une comportement différent entre nouveau et le propriétaire, en effet nouveau utilise KMS tandis que le second est incompatible avec KMS
Si tu ne veux pas jouer, nouveau peux être largement suffisant, tout dépend de ton besoin.
Peux tu donner l'ensemble des résolutions supportées pour chaque écran, je crains qu'il faille trouver une résolution commune entre les 2 écrans
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

inan
Hankyu
Messages : 14
Inscription : mar. 10 juil. 2012, 11:25

Re: [Boot] Dual Screen AVANT démarrage de X.

Message par inan » ven. 18 sept. 2015, 18:41

Salut !

Merci pour ta réponse.

Effectivement, j'ai copié une série de commande que j'avais vu sur le forum afin de passer de nouveau à Nvidia. Je viens de changer les packages et j'ai donc bien pris les packages "Nvidia" (les mêmes sans le -340xx-, quoi.)

Quand au contenu de /etc/X11/xorg.conf.d/ ; même si j'ai "bêtement" copié les commandes en question ; en regardant dans mes sauvegardes, je vois que je n'ai jamais rien eu dans ce dossier !

La configuration de mon clavier vient de /etc/vconsole.conf :

Code : Tout sélectionner

KEYMAP=be-latin1
FONT=lat9w-16
Et de cette ligne de mon .xinitrc :

Code : Tout sélectionner

setxkbmap -layout be -variant oss -option terminate:ctrl_alt_bksp
Je fais mal ?! :oops:

Quant à la résolution (commune) des mes écrans, ils supportent tous les deux 1920x1080.

Merci pour ta première réponse. Je suis content de pouvoir corriger mes erreurs.

EDIT : Oups, j'ai oublié de répondre à toutes tes demandes !

Non, actuellement je ne joue pas. Néanmoins, j'aime regarder des vidéos en full HD. Mais je ne désespère pas de rejouer à certains jeux auxquels je ne joue plus depuis que je suis sous Linux.

EDIT 2 : Finalement, je me dis que compte-tenu de mon utilisation, ainsi que de ma volonté de vouloir garder tout ça "le plus simple" possible ; j'ai réinstallé nouveau (confer la procédure sur le wiki) et tout est redevenu comme avant.

Désolé pour ton temps et merci pour tes réponses o/
arch~awesome~zsh~urxvt | Intel i7-6700K / Nvidia GTX 1080 / Samsung SSD 960 EVO M.2 PCIe NVMe 250 Go

Pim
Hankyu
Messages : 36
Inscription : dim. 18 oct. 2015, 23:16

Re: [Boot] Dual Screen AVANT démarrage de X. (Résolu)

Message par Pim » lun. 19 oct. 2015, 01:01

Bonjour.
Je découvre archlinux aussi et j'ai l'impression qu'ici la mode est de virer le driver nouveau.
Mais je ne sait pas pourquoi car sur par exemple Debian et Ubuntu on l'installe en priorité et il fonctionne.
Bon maintenant : je n'ai peut-être pas tout compris. mais bon les drivers proprios m'ont toujours emm. :roll: cassé les pieds
moi aussi.

Répondre