[crypttab, fstab] Monter partition LUKS + LVM au démarrage (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
ThOsam
Hankyu
Messages : 38
Inscription : jeu. 09 avr. 2015, 09:18

[crypttab, fstab] Monter partition LUKS + LVM au démarrage (résolu)

Message par ThOsam » sam. 07 mai 2016, 22:31

La SOLUTION se trouve en page 2, post 21 >> viewtopic.php?f=1&t=18160&start=20#p153051
TL;DR : le crypttab nécessite d'indiquer le nom de la partition chiffrée et pas son /dev/mapper puis son UUID pour bien être déchiffrée au démarrage.
- - - - - - - - - - - - - - - - - - - - - - - -

Bonjour,

Ayant quelques difficultés je viens demander des conseils ici.

Je cherche à monter au démarrage une partition chiffrée. Celle-ci est sur un second disque séparé du système, Chiffré avec LUKS puis LVM2 dessus.

1. En sortie de lsblk -f :

Code : Tout sélectionner

NAME                                          FSTYPE      LABEL              UUID                                   MOUNTPOINT
sda                                                                                                                 
├─sda1                                        ntfs        Réservé au système 0AFE92B1FE929493                       
├─sda2                                        ntfs                           86C899A6C89994D1                       
├─sda3                                        ext2        BOOT-MSI           24d93409-874b-4003-b26b-5ef872a58921   /boot
└─sda4                                        crypto_LUKS                    d8d291c0-03b4-4710-bdf7-80c1a797cea8   
  └─vgsys                                     LVM2_member                    8I0R9R-bLLR-2mTR-nfYy-yByk-tvCk-mLdae1 
    ├─vgsys-lvswap                            swap        SWAPLVM-MSI        58ae7159-e378-4c9b-906c-5ed2d9065fe6   [SWAP]
    ├─vgsys-lvroot                            ext4        ROOTLVM-MSI        b989c671-1d74-470e-ba8e-285aa6e035ac   /
    └─vgsys-lvhome                            ext4        HOMELVM-MSI        1151ea58-6af8-47cc-9308-9d849326969e   /home
sdb                                                                                                                 
└─sdb1                                        crypto_LUKS                    76c9e319-c059-4972-853a-214b8012f587   
  └─luks-76c9e319-c059-4972-853a-214b8012f587 LVM2_member                    GaSZvf-DpLs-zJM2-Bbzw-xNKn-wjqW-E1eNJc 
    └─vgdat-lvadata                           ext4        ADATALVM-MSI       77a996f4-12d1-4360-b5a3-b91f4085de61   /run/media/th/ADATALVM-MSI
sdd                                                                                                                 
└─sdd1                                        ntfs        SONY8G             4B514FC566DD29C7 
2. En sortie de blkid :

Code : Tout sélectionner

/dev/sda1: LABEL="RM-CM-)servM-CM-) au systM-CM-(me" UUID="0AFE92B1FE929493" TYPE="ntfs" PARTUUID="5e8ae7e0-01"
/dev/sda2: UUID="86C899A6C89994D1" TYPE="ntfs" PARTUUID="5e8ae7e0-02"
/dev/sda3: LABEL="BOOT-MSI" UUID="24d93409-874b-4003-b26b-5ef872a58921" TYPE="ext2" PARTUUID="5e8ae7e0-03"
/dev/sda4: UUID="d8d291c0-03b4-4710-bdf7-80c1a797cea8" TYPE="crypto_LUKS" PARTUUID="5e8ae7e0-04"
/dev/sdb1: UUID="76c9e319-c059-4972-853a-214b8012f587" TYPE="crypto_LUKS" PARTUUID="8d29c5b2-01"
/dev/mapper/vgsys: UUID="8I0R9R-bLLR-2mTR-nfYy-yByk-tvCk-mLdae1" TYPE="LVM2_member"
/dev/mapper/vgsys-lvswap: LABEL="SWAPLVM-MSI" UUID="58ae7159-e378-4c9b-906c-5ed2d9065fe6" TYPE="swap"
/dev/mapper/vgsys-lvroot: LABEL="ROOTLVM-MSI" UUID="b989c671-1d74-470e-ba8e-285aa6e035ac" TYPE="ext4"
/dev/mapper/vgsys-lvhome: LABEL="HOMELVM-MSI" UUID="1151ea58-6af8-47cc-9308-9d849326969e" TYPE="ext4"
/dev/mapper/luks-76c9e319-c059-4972-853a-214b8012f587: UUID="GaSZvf-DpLs-zJM2-Bbzw-xNKn-wjqW-E1eNJc" TYPE="LVM2_member"
/dev/mapper/vgdat-lvadata: LABEL="ADATALVM-MSI" UUID="77a996f4-12d1-4360-b5a3-b91f4085de61" TYPE="ext4"
/dev/sdd1: LABEL="SONY8G" UUID="4B514FC566DD29C7" TYPE="ntfs" PARTUUID="001dcee2-01"
3. Le fichier fstab (ce qui est commenté à la fin est la ligne concernée qui ne semble pas fonctionner) :

Code : Tout sélectionner

# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
# DEVICE DETAILS: /dev/mapper/vgsys-lvhome UUID=1151ea58-6af8-47cc-9308-9d849326969e LABEL=HOMELVM-MSI
# DEVICE DETAILS: /dev/mapper/vgsys-lvroot UUID=b989c671-1d74-470e-ba8e-285aa6e035ac LABEL=ROOTLVM-MSI
# DEVICE DETAILS: /dev/mapper/vgsys-lvswap UUID=58ae7159-e378-4c9b-906c-5ed2d9065fe6 LABEL=SWAPLVM-MSI
# DEVICE DETAILS: /dev/sda3 UUID=24d93409-874b-4003-b26b-5ef872a58921 LABEL=BOOT-MSI
##DEVICE DETAILS: /dev/mapper/vgdat-lvadata UUID=77a996f4-12d1-4360-b5a3-b91f4085de61 LABEL=ADATALVM-MSI
UUID=1151ea58-6af8-47cc-9308-9d849326969e /home ext4 defaults 0 1
UUID=24d93409-874b-4003-b26b-5ef872a58921 /boot ext2 defaults 0 1
UUID=58ae7159-e378-4c9b-906c-5ed2d9065fe6 swap swap defaults 0 0
UUID=b989c671-1d74-470e-ba8e-285aa6e035ac / ext4 defaults 0 1
#UUID=77a996f4-12d1-4360-b5a3-b91f4085de61 /adata ext4 defaults 0 2
4. Le fichier crypttab (la dernière ligne commentée est ma tentative qui n'a visiblement pas fonctionné)

Code : Tout sélectionner

# crypttab: mappings for encrypted partitions
#
# Each mapped device will be created in /dev/mapper, so your /etc/fstab
# should use the /dev/mapper/<name> paths for encrypted devices.
#
# The Arch specific syntax has been deprecated, see crypttab(5) for the
# new supported syntax.
#
# NOTE: Do not list your root (/) partition here, it must be set up
#       beforehand by the initramfs (/etc/mkinitcpio.conf).

# <name>       <device>                                     <password>              <options>
# home         UUID=b8ad5c18-f445-495d-9095-c9ec4f9d2f37    /etc/mypassword1
# data1        /dev/sda3                                    /etc/mypassword2
# data2        /dev/sda5                                    /etc/cryptfs.key
# swap         /dev/sdx4                                    /dev/urandom            swap,cipher=aes-cbc-essiv:sha256,size=256
# vol          /dev/sdb7                                    none

#vgdat-lvadata	UUID=77a996f4-12d1-4360-b5a3-b91f4085de61	none	luks
J'ai modifié le fichier fstab et crypttab en suivant les conseils donnés par la page https://wiki.archlinux.org/index.php/Dm ... _boot_time mais sans succès, j'ai du rater quelque chose. Au démarrage le système ne s'est pas lancé et j'ai eu un recovery shell via lequel j'ai pu supprimer mes modifications pour redémarrer correctement l'OS. Bref, j'attends vos conseils avant de re-casser quelque chose...
Dernière modification par ThOsam le jeu. 12 mai 2016, 19:42, modifié 2 fois.
Manjaro (xfce) ArchLinux (Gnome 3) | dm-crypt + LUKS + lvm2 + ext4 | i7 4970k OC + GTX970 OC + 16Gb RAM + SSD | HP ProBook 4330s

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par Xorg » sam. 07 mai 2016, 22:36

Tu n'as pas précisé, mais par rapport à ton essai sur le fichier crypttab, je me pose une question : est-ce que ta partition chiffrée a un mot de passe ?
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

ThOsam
Hankyu
Messages : 38
Inscription : jeu. 09 avr. 2015, 09:18

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par ThOsam » sam. 07 mai 2016, 22:39

Oui, elle en a un. J'ai effectivement oublié de le préciser. Et j'aimerais pouvoir ne pas avoir à la saisir à chaque démarrage, c'est quelque chose en rapport avec "keyfile" d'après le wiki mais je n'ai pas tout saisi...
Manjaro (xfce) ArchLinux (Gnome 3) | dm-crypt + LUKS + lvm2 + ext4 | i7 4970k OC + GTX970 OC + 16Gb RAM + SSD | HP ProBook 4330s

Sirilldu
archer
Messages : 135
Inscription : mer. 27 mars 2013, 19:45

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par Sirilldu » dim. 08 mai 2016, 08:38

Bonjour,
Pour le keyfile, suis les instructions de ce paragraphe : https://wiki.archlinux.org/index.php/Dm ... _initramfs
Ensuite dans le crypttab, tu décommentes la ligne et tu remplaces none par /crypto_keyfile.bin :

Code : Tout sélectionner

vgdat-lvadata   UUID=77a996f4-12d1-4360-b5a3-b91f4085de61   /crypto_keyfile.bin   luks
Décommente aussi la ligne dans le fstab et normalement c'est bon.
Arch 64 | KDE

ThOsam
Hankyu
Messages : 38
Inscription : jeu. 09 avr. 2015, 09:18

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par ThOsam » dim. 08 mai 2016, 22:52

Merci @Sirilldu

J'ai bien suivi les instructions (relativement claires et simples) données dans le paragraphe en lien.
Puis la modification du fichier fstab et crypttab.
Malheureusement cela ne semble pas avoir fonctionné je suis de nouveau dans l'impossibilité de démarrer correctement avec le message suivant : A start job is running for...ata.device [...] et un délai de 1min30 avant d'avoir l'emergency mode où est demandé mon mot de passe su. La même chose que j'ai rencontré au début de ce post.
Manjaro (xfce) ArchLinux (Gnome 3) | dm-crypt + LUKS + lvm2 + ext4 | i7 4970k OC + GTX970 OC + 16Gb RAM + SSD | HP ProBook 4330s

Avatar de l’utilisateur
RoyalPanda
archer de cavalerie
Messages : 193
Inscription : lun. 19 mai 2014, 09:08

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par RoyalPanda » lun. 09 mai 2016, 08:44

Petit problème :
vgdat-lvadata UUID=77a996f4-12d1-4360-b5a3-b91f4085de61 /crypto_keyfile.bin luks
L'UUID de cette partition et cette partition n'existe pas tant que la partition :

Code : Tout sélectionner

/dev/mapper/luks-76c9e319-c059-4972-853a-214b8012f587: UUID="GaSZvf-DpLs-zJM2-Bbzw-xNKn-wjqW-E1eNJc" TYPE="LVM2_member"
n'existe pas.

Je pense donc qu'il faut remplacer l'UUID de vgdat-lvadata dans /etc/crypttab par celui de /dev/mapper/luks....

Sirilldu
archer
Messages : 135
Inscription : mer. 27 mars 2013, 19:45

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par Sirilldu » lun. 09 mai 2016, 10:36

Je crois que ce n'est pas le bon UUID dans le crypttab, essaie avec celui de sdb1, soit : 76c9e319-c059-4972-853a-214b8012f587
Edit :
Désolé je n'avais pas vu ta réponse RoyalPanda. :oops:
Et pour l'UUID si GaSZvf-DpLs-zJM2-Bbzw-xNKn-wjqW-E1eNJc ne fonctionne pas alors essaie avec 76c9e319-c059-4972-853a-214b8012f587
Arch 64 | KDE

Backtoback
yeomen
Messages : 256
Inscription : jeu. 26 avr. 2012, 23:33
Contact :

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par Backtoback » lun. 09 mai 2016, 11:36

Bonjour,

J'ai moi même un projet similaire, mm si je n'utilise pas LVM2. J'espère cependant que mes infos pourront t'aider.

crypttab

Code : Tout sélectionner

# crypttab: mappings for encrypted partitions
# <name>       <device>                                     <password>              <options>
croot		UUID=UUID de la partition root			none		luks,timeout=20
cswap		/dev/disk/by-id/ata-ST1000LM014-1EJ164_W38172TZ-part2		/dev/urandom	swap,cipher=twofish-xts-plain64:sha512,size=512
chome		UUID=UUID de la partition home			none		luks,timeout=60
Ici on peut voir que j'ai 2 partitions chiffrées et mon swap.
croot et chome sont les mappers présent dans /dev/mapper/ créé avec cryptsetup (LUKS).

fstab

Code : Tout sélectionner

# /etc/fstab: static file system information
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
/dev/mapper/croot				/		ext4		rw,relatime,data=ordered	0 1
/dev/mapper/chome				/home		ext4		rw,relatime,data=ordered	0 2

# /dev/sda1
UUID=UUID de la partition boot	/boot     	ext2      	rw,relatime,stripe=4	0 2

/dev/mapper/cswap 				none		swap		sw		0 0
Ici je monte donc mes mappers sur les partitions souhaitées.
Pour ma part, je dois rentrer les mots de passe.
Par contre je vois pas l'intérêt de chiffrer ta partition home si c'est pour laisser le mot de passe en clair sur le même périphérique. Après il y a sûrement quelque chose qui m'échappe.

Backtoback
yeomen
Messages : 256
Inscription : jeu. 26 avr. 2012, 23:33
Contact :

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par Backtoback » lun. 09 mai 2016, 11:46

Je pense donc qu'il faut que tu modifies ton fstab :

Code : Tout sélectionner

/dev/mapper/vgdat-lvadata            /adata      ext4      defaults   0 2
et ton crypttab :

Code : Tout sélectionner

vgdat-lvadata   UUID=77a996f4-12d1-4360-b5a3-b91f4085de61   /etc/mypassword1   luks

Sirilldu
archer
Messages : 135
Inscription : mer. 27 mars 2013, 19:45

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par Sirilldu » lun. 09 mai 2016, 12:20

@Backtoback,
Thosam veut monter sa partition sans avoir à donner le mot de passe, il faut donc passer par un keyfile. Il doit juste modifier son UUID dans le crypttab
Arch 64 | KDE

Backtoback
yeomen
Messages : 256
Inscription : jeu. 26 avr. 2012, 23:33
Contact :

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par Backtoback » lun. 09 mai 2016, 12:24

C'est pour ca que j'ai précisé dans le crypttab, de rajouter le mot de passe /etc/mypassword1

ThOsam
Hankyu
Messages : 38
Inscription : jeu. 09 avr. 2015, 09:18

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par ThOsam » mar. 10 mai 2016, 21:54

[en cours de test]
J'ai rapidement essayé différentes modifications ce midi et là ce soir :
Je pense que le problème vient clairement du fichier crypttab (commenter la ligne en question permet un démarrage sans encombre... mais sans le disque monté, évidement), mais je n'arrive pas à identifier quoi.

Pour le moment rien ne fonctionne, je dois constamment rééditer /etc/crypttab et /etc/fstab au démarrage. Je cherche ce soir...
Manjaro (xfce) ArchLinux (Gnome 3) | dm-crypt + LUKS + lvm2 + ext4 | i7 4970k OC + GTX970 OC + 16Gb RAM + SSD | HP ProBook 4330s

ThOsam
Hankyu
Messages : 38
Inscription : jeu. 09 avr. 2015, 09:18

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par ThOsam » mar. 10 mai 2016, 23:38

[ajout après 1h40 de recherches]
La résolution de mon problème semble avancer.

En fait il semblerait que ce ne soit pas le crypttab qui soit en cause. J'ai bien relu dans tous les sens la page https://wiki.archlinux.org/index.php/Dm ... n#crypttab en suivant notamment la liste d'exemples proches de mon cas. Ainsi que le man. Et en fait la ligne vgdat-lvadata /dev/sdb1 /crypto_keyfile.bin passe sans problème. D'après la doc la précision "luks" n'est pas nécessaire, et lorsque j'enlève la keyfile j'ai bien la demande de saisie de mot de passe avant la poursuite du démarrage.
Et effectivement une fois le démarrage terminé, la partition luks du disque concerné est bien ouverte.

En revanche je ne parvient pas a trouver le bon paramètre pour le fstab.
Si je suis le man et plus particulièrement la page fstab sur le wiki (https://wiki.archlinux.org/index.php/fstab) j'ai plusieurs paramètres à indiquer :
1. file system : dans mon cas c'est /dev/mapper/vgdat-lvadata j'ai également testé l'UUID de vgdat-lvadata, sdb, j'ai aussi essayé son LABEL, sans résultat.
2. dir : là où est monté filesystem, soit /adata
3. type : ext4
4. options : defaults (devrais-je ne préciser d'autres, plus ?)
5. dump : ici 0
6. pass : 2 dans mon cas

Il me semble avoir bien suivi le man et le wiki : cependant j'ai essayé un moment avec LVM2_me à la place du type (ext4) et ... Le système démarre correctement, sauf que ma partition n'est pas montée sur /adata (mais où, si oui ?)
Bref, j'ai du mal à voir ce que j'aurais raté.

[edit] En souhaitant monter la partition à la main j'ai le message suivant, il y aurait un lien avec mon problème ?

Code : Tout sélectionner

# mount -t ext4 /dev/mapper/vgdat-lvadata /adata
mount: mauvais type de système de fichiers, option erronée, superbloc erroné
        sur /dev/mapper/vgdat-lvadata, page de code ou programme auxiliaire manquant, ou autre erreur

        Dans certains cas des renseignements utiles sont dans le journal
        système — essayez « dmesg | tail » ou quelque chose du genre.
Manjaro (xfce) ArchLinux (Gnome 3) | dm-crypt + LUKS + lvm2 + ext4 | i7 4970k OC + GTX970 OC + 16Gb RAM + SSD | HP ProBook 4330s

benjarobin
Maître du Kyudo
Messages : 15565
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par benjarobin » mer. 11 mai 2016, 11:32

Je débarque que maintenant, après avoir lu en biais les messages. Mais d'après ton premier message si tu as bien du LUCK puis par dessus du LVM alors dans ton crypttab tu dois avoir cette ligne:

Code : Tout sélectionner

vgdat-lvadata   UUID=76c9e319-c059-4972-853a-214b8012f587   /crypto_keyfile.bin   luks
Le montage manuel que tu indiques m'inquiète un peu... C'est comme si tu avais tout corrompu
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

ThOsam
Hankyu
Messages : 38
Inscription : jeu. 09 avr. 2015, 09:18

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par ThOsam » mer. 11 mai 2016, 17:53

Merci @benjarobin

Cependant ce n'est pas vraiment le crypttab qui me pose problème. Depuis mon message précédent que la ligne soit écrite comme ça :

Code : Tout sélectionner

vgdat-lvadata /dev/sdb1    /crypto_keyfile.bin
Ou comme ça cela semble ne pas changer le résultat.

Code : Tout sélectionner

vgdat-lvadata   UUID=76c9e319-c059-4972-853a-214b8012f587   /crypto_keyfile.bin   luks

Je commence à ne plus rien comprendre alors j'ai refait mon disque chiffré (je n'avais pas encore de données dessus et c'est un SSD séparé du reste), c'est long mais ça me semble important que je détaille tout pour que vous me fassiez remarquer mes erreurs ou mes incohérences :

1. Procédure pour chiffrer le disque LUKS, ajout LVM et montage manuel pour tester.
contexte : Disque SSD séparé avec une seule partition : /dev/sdb1

Code : Tout sélectionner

[mansi ~]# cryptsetup -v --debug -c aes-xts-plain64 -s 512 luksFormat /dev/sdb1 
# cryptsetup 1.7.0 processing "cryptsetup -v --debug -c aes-xts-plain64 -s 512 luksFormat /dev/sdb1"
# Running command luksFormat.
# Locking memory.
# Installing SIGINT/SIGTERM handler.
# Unblocking interruption on signal.

WARNING!
========
Cette action écrasera définitivement les données sur /dev/sdb1.

Are you sure? (Type uppercase yes): YES
# Allocating crypt device /dev/sdb1 context.
# Trying to open and read device /dev/sdb1 with direct-io.
# Initialising device-mapper backend library.
# Timeout set to 0 miliseconds.
# Iteration time set to 2000 miliseconds.
# Interactive passphrase entry requested.
Saisissez la phrase secrète : 
Vérifiez la phrase secrète : 
# Formatting device /dev/sdb1 as type LUKS1.
# Crypto backend (gcrypt 1.6.4) initialized in cryptsetup library version 1.7.0.
# Detected kernel Linux 4.1.15-1-MANJARO x86_64.
# Topology: IO (512/0), offset = 0; Required alignment is 1048576 bytes.
# Checking if cipher aes-xts-plain64 is usable.
# Using userspace crypto wrapper to access keyslot area.
# Generating LUKS header version 1 using hash sha256, aes, xts-plain64, MK 64 bytes
# KDF pbkdf2, hash sha256: 536630 iterations per second (512-bits key).
# Data offset 4096, UUID bf58ee54-0e7a-483b-a9ce-02e9611120e3, digest iterations 131000
# Updating LUKS header of size 1024 on device /dev/sdb1
# Key length 64, device size 1875382960 sectors, header size 4036 sectors.
# Reading LUKS header of size 1024 from device /dev/sdb1
# Key length 64, device size 1875382960 sectors, header size 4036 sectors.
# Adding new keyslot -1 using volume key.
# Calculating data for key slot 0
# KDF pbkdf2, hash sha256: 534987 iterations per second (512-bits key).
# Key slot 0 use 1044896 password iterations.
# Using hash sha256 for AF in key slot 0, 4000 stripes
# Updating key slot 0 [0x1000] area.
# Using userspace crypto wrapper to access keyslot area.
# Key slot 0 was enabled in LUKS header.
# Updating LUKS header of size 1024 on device /dev/sdb1
# Key length 64, device size 1875382960 sectors, header size 4036 sectors.
# Reading LUKS header of size 1024 from device /dev/sdb1
# Key length 64, device size 1875382960 sectors, header size 4036 sectors.
# Releasing crypt device /dev/sdb1 context.
# Releasing device-mapper backend.
# Unlocking memory.
Opération réussie.
[mansi ~]# cryptsetup luksOpen /dev/sdb1 cryptdat
Saisissez la phrase secrète pour /dev/sdb1 : 
[mansi ~]# pvcreate /dev/mapper/cryptdat 
  Physical volume "/dev/mapper/cryptdat" successfully created
[mansi ~]# vgcreate vgdat /dev/mapper/cryptdat 
  Volume group "vgdat" successfully created
[mansi ~]# lvcreate -l +100%FREE vgdat -n lvadata
  Logical volume "lvadata" created.
[mansi ~]# mkfs.ext4 /dev/mapper/vgdat-lvadata 
mke2fs 1.42.13 (17-May-2015)
En train de créer un système de fichiers avec 234421248 4k blocs et 58605568 i-noeuds.
UUID de système de fichiers=517e7bb9-e483-484a-9e6e-8977f36fe740
Superblocs de secours stockés sur les blocs : 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
	4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968, 
	102400000, 214990848

Allocation des tables de groupe : complété                        
Écriture des tables d'i-noeuds : complété                        
Création du journal (32768 blocs) : complété
Écriture des superblocs et de l'information de comptabilité du système de
fichiers : complété 
[mansi ~]# cryptsetup luksAddKey /dev/sdb1 /crypto_keyfile.bin 
Entrez une phrase de passe existante : 
[mansi ~]# mount -t ext4 /dev/mapper/vgdat-lvadata /adata/

2. Modification du fichier crypttab et fstab (similaire à ce que j'ai fait dans mes message plus haut)

Les UUID ayant changées, voici la sortie de lsblkid :

Code : Tout sélectionner

[mansi ~]# lsblk -f
NAME                                          FSTYPE      LABEL              UUID                                   MOUNTPOINT
sda                                                                                                                 
├─sda1                                        ntfs        Réservé au système 0AFE92B1FE929493                       
├─sda2                                        ntfs                           86C899A6C89994D1                       
├─sda3                                        ext2        BOOT-MSI           24d93409-874b-4003-b26b-5ef872a58921   /boot
└─sda4                                        crypto_LUKS                    d8d291c0-03b4-4710-bdf7-80c1a797cea8   
  └─vgsys                                     LVM2_member                    8I0R9R-bLLR-2mTR-nfYy-yByk-tvCk-mLdae1 
    ├─vgsys-lvswap                            swap        SWAPLVM-MSI        58ae7159-e378-4c9b-906c-5ed2d9065fe6   [SWAP]
    ├─vgsys-lvroot                            ext4        ROOTLVM-MSI        b989c671-1d74-470e-ba8e-285aa6e035ac   /
    └─vgsys-lvhome                            ext4        HOMELVM-MSI        1151ea58-6af8-47cc-9308-9d849326969e   /home
sdb                                                                                                                 
└─sdb1                                        crypto_LUKS                    bf58ee54-0e7a-483b-a9ce-02e9611120e3   
  └─luks-bf58ee54-0e7a-483b-a9ce-02e9611120e3 LVM2_member                    mVKuTq-vUnj-KT3F-gDUa-kyQQ-te4j-XPg7st 
    └─vgdat-lvadata                           ext4                           517e7bb9-e483-484a-9e6e-8977f36fe740   /adata
Le fichiers crypttab et fstab sont les mêmes, j'ai seulement changé l'UUID de la ligne en question.


Ce que j'en ressort c'est que même si le démarrage se passe bien (pas de recovery shell) sur le bureau la partition chiffrée apparaît toujours verrouillée (je dois la déverrouiller à la main et la monter à la main).

D'ailleurs si j'essaye de monter la partition en imaginant que celle-ci avait été déverrouillée au démarrage avec le crypttab, j'ai une erreur.

Code : Tout sélectionner

[mansi ~]# lsblk -f

[...]

sdb                                                                       
└─sdb1             crypto_         bf58ee54-0e7a-483b-a9ce-02e9611120e3   
[mansi ~]# mount -t ext4 /dev/mapper/vgdat-lvadata /adata/
mount: le périphérique spécial /dev/mapper/vgdat-lvadata n'existe pas

J'hésite à refaire une installation complète en incluant d'origine le disque chiffrée dans la procédure d'installation, ce serait sûrement plus rapide et plus simple qu'ici...
Manjaro (xfce) ArchLinux (Gnome 3) | dm-crypt + LUKS + lvm2 + ext4 | i7 4970k OC + GTX970 OC + 16Gb RAM + SSD | HP ProBook 4330s

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par Xorg » mer. 11 mai 2016, 18:24

ThOsam a écrit :D'ailleurs si j'essaye de monter la partition en imaginant que celle-ci avait été déverrouillée au démarrage avec le crypttab, j'ai une erreur.

Code : Tout sélectionner

[mansi ~]# lsblk -f

[...]

sdb                                                                       
└─sdb1             crypto_         bf58ee54-0e7a-483b-a9ce-02e9611120e3   
[mansi ~]# mount -t ext4 /dev/mapper/vgdat-lvadata /adata/
mount: le périphérique spécial /dev/mapper/vgdat-lvadata n'existe pas

J'hésite à refaire une installation complète en incluant d'origine le disque chiffrée dans la procédure d'installation, ce serait sûrement plus rapide et plus simple qu'ici...
Tu dis qu'elle a été déverrouillée au démarrage, pourtant si /dev/mapper/vgdat-lvadata n'existe pas, c'est sans doute qu'elle n'a pas été déverrouillée. Tu as quelque chose dans /dev/mapper ?

Peut-être que le service systemd-cryptsetup@vgdat-lvadata.service peut en dire plus ?

Réinstaller pour si peu... C'est baisser les armes trop facilement. :)
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Sirilldu
archer
Messages : 135
Inscription : mer. 27 mars 2013, 19:45

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par Sirilldu » mer. 11 mai 2016, 18:56

Ne faut-il pas faire un mkinitcpio -p linux après une modification du crypttab ?
Arch 64 | KDE

benjarobin
Maître du Kyudo
Messages : 15565
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par benjarobin » mer. 11 mai 2016, 20:02

Si, et il faut rajouter les hooks qui vont bien. Quel est donc le contenu de ton /etc/mkinitcpio.conf ?
Pour rappel il faut bien penser à régénérer l'initramfs, via mkinitcpio, après modification de certains fichiers de config

De plus, suite à ta nouvelle explication, bien que je n'ai jamais réalisé une telle chose, j'ai l'impression toujours que le contenu de ton crypttab est invalide.

Code : Tout sélectionner

cryptdat  UUID=bf58ee54-0e7a-483b-a9ce-02e9611120e3   /crypto_keyfile.bin   luks
Le nom dans /dev/mapper ne doit surtout pas être le nom du volume LVM (enfin je pense...)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

ThOsam
Hankyu
Messages : 38
Inscription : jeu. 09 avr. 2015, 09:18

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par ThOsam » mer. 11 mai 2016, 23:53

Merci à vous trois,

Voici le contenu de mon mkinitcpio.conf

Code : Tout sélectionner

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES="piix ide_disk reiserfs"
MODULES=""

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=""

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES="/crypto_keyfile.bin"

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS="base"
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS="base udev autodetect block filesystems"
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS="base udev block filesystems"
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS="base udev block mdadm encrypt filesystems"
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS="base udev block lvm2 filesystems"
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap encrypt lvm2 filesystems pcmcia resume fsck usr shutdown"

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=""
Effectivement je ne le régénère pas à chaque fois, mais après avoir fait l'ajout du FILES="/crypto_keyfile.bin" pour l'ajout du keyfile je ne vois pas trop pourquoi le relancer à chaque modifs du crypttab, en tout cas le wiki ne le précise pas (ou alors je suis passé à côté) https://wiki.archlinux.org/index.php/Dm ... _initramfs
Manjaro (xfce) ArchLinux (Gnome 3) | dm-crypt + LUKS + lvm2 + ext4 | i7 4970k OC + GTX970 OC + 16Gb RAM + SSD | HP ProBook 4330s

benjarobin
Maître du Kyudo
Messages : 15565
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [crypttab, fstab] Monter partition LUKS + LVM au démarrage

Message par benjarobin » jeu. 12 mai 2016, 00:49

Car le fichier crypttab est copié dans l'initramfs, non ?
Si tu n'as pas de partiton /usr séparée alors il est inutile d'avoir usr et shutdown
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre