Configuration langue / locale système

Questions et astuces concernant l'installation et la configuration d'archlinux
Spooky
Hankyu
Messages : 24
Inscription : jeu. 10 mars 2016, 19:38

Configuration langue / locale système

Message par Spooky »

Bonjour,

cela fait maintenant plusieurs mois que j'ai installé Arch sur mes deux PC (fixe et portable), j'avais déjà bien galèrer pour configurer les locales la première fois : J'avais du modifier le fichier '/etc/environment' pour que mon système sois vraiment en français partout. Je sais plus comment j'avais trouvé ça mais en tout cas c'est pas indiqué sur le wiki ...
Ca a toujours bien fonctionner jusqu'a aujourd'hui : la saisie automatique de KeyPass tape en clavier US ; Pour que ça fonctionne je doit lancer la commande 'setxkbmap fr'. Donc il y a encore un réglage qui n'est pas gardé au redémarrage. Est-ce que quelqu'un à une idée de la manip à effectuer pour pas à taper la commande à chaque fois ?

Merci d'avance :)
benjarobin
Maître du Kyudo
Messages : 16075
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: Configuration langue / locale système

Message par benjarobin »

Bonjour,
Ne pas confondre les locales et la disposition du clavier. Ce sont vraiment 2 choses totalement indépendantes, bien que géré par le même outil de systemd.
Pour le clavier tu peux utiliser

Code : Tout sélectionner

localectl set-x11-keymap LAYOUT [MODEL [VARIANT [OPTIONS]]]
Ceci générera le fichier de configuration de Xorg /etc/X11/xorg.conf.d/00-keyboard.conf
Les locales (la langue de l'interface) sont gérées par le fichier /etc/locale.conf, mais aussi optionnellement par le fichier /etc/environment
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Spooky
Hankyu
Messages : 24
Inscription : jeu. 10 mars 2016, 19:38

Re: Configuration langue / locale système

Message par Spooky »

J'ai lancer 'localectl set-x11-keymap fr' et redémarré, ça a encore reset ...
Avec sudo pareil.
J'ai remarqué un truc aussi, dans les paramètres de KeePassX, le champ du racourcis d'auto remplissage affichait bien les touches choisies mais en fait il avait enregistré les touche en US parce-que après un redémarrage, avant que je lance 'setxkbmap fr', le raccourcis fonctionnait, mais plus après.
Avatar de l’utilisateur
jc51
Chu Ko Nu
Messages : 317
Inscription : jeu. 08 déc. 2011, 16:37

Re: Configuration langue / locale système

Message par jc51 »

Spooky a écrit :J'ai lancer 'localectl set-x11-keymap fr' et redémarré, ça a encore reset ...
Avec sudo pareil.
J'ai remarqué un truc aussi, dans les paramètres de KeePassX, le champ du racourcis d'auto remplissage affichait bien les touches choisies mais en fait il avait enregistré les touche en US parce-que après un redémarrage, avant que je lance 'setxkbmap fr', le raccourcis fonctionnait, mais plus après.

as tu au moins tenu compte du commentaire de @benjarobin ? :D
ThinkPad T410, 8GO, ssd Samsung 860 evo Archlinux/Gnome
Spooky
Hankyu
Messages : 24
Inscription : jeu. 10 mars 2016, 19:38

Re: Configuration langue / locale système

Message par Spooky »

Oui.

00-keyboard.conf

Code : Tout sélectionner

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "fr"
EndSection
locale.conf

Code : Tout sélectionner

LANG=fr_FR.utf8
environment

Code : Tout sélectionner

LANG="fr_FR.UTF-8"
Quand je rédemarre, je doit lancer 'setxkbmap fr' sinon KeePassX tape en anglais.
Avatar de l’utilisateur
jc51
Chu Ko Nu
Messages : 317
Inscription : jeu. 08 déc. 2011, 16:37

Re: Configuration langue / locale système

Message par jc51 »

chez moi le fichier s'appelle

Code : Tout sélectionner

10-keyboard-layout.conf
et Identifier j'ai

Code : Tout sélectionner

 "Keyboard Layout"
ThinkPad T410, 8GO, ssd Samsung 860 evo Archlinux/Gnome
Avatar de l’utilisateur
jc51
Chu Ko Nu
Messages : 317
Inscription : jeu. 08 déc. 2011, 16:37

Re: Configuration langue / locale système

Message par jc51 »

et dans locale.conf c'est

Code : Tout sélectionner

LANG="fr_FR.UTF-8"
ThinkPad T410, 8GO, ssd Samsung 860 evo Archlinux/Gnome
benjarobin
Maître du Kyudo
Messages : 16075
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: Configuration langue / locale système

Message par benjarobin »

Ton fichier /etc/environment est invalide, l'utilisation de guillemet n'est pas autorisé dans ce fichier.
Mais comme indiqué ceci n'a strictement rien à voir avec la disposition du clavier !
Peux tu donner la sortie de :

Code : Tout sélectionner

grep -Evr "^ *$|^ *#" /etc/X11/xorg.conf*
Car cela me semble très étrange ce que tu donnes, ce n'est pas le fichier généré par systemd.
As tu un clavier sans fil ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Spooky
Hankyu
Messages : 24
Inscription : jeu. 10 mars 2016, 19:38

Re: Configuration langue / locale système

Message par Spooky »

Voila :

Code : Tout sélectionner

$ grep -Evr "^ *$|^ *#" /etc/X11/xorg.conf*
/etc/X11/xorg.conf.d/00-keyboard.conf:Section "InputClass"
/etc/X11/xorg.conf.d/00-keyboard.conf:        Identifier "system-keyboard"
/etc/X11/xorg.conf.d/00-keyboard.conf:        MatchIsKeyboard "on"
/etc/X11/xorg.conf.d/00-keyboard.conf:        Option "XkbLayout" "fr"
/etc/X11/xorg.conf.d/00-keyboard.conf:EndSection
Répondre