[GRUB] Besoin d'une signature unique [Résolu]

Questions et astuces concernant l'installation et la configuration d'archlinux
Saga_Fire
Hankyu
Messages : 13
Inscription : dim. 12 juin 2016, 19:34

[GRUB] Besoin d'une signature unique [Résolu]

Message par Saga_Fire » dim. 12 juin 2016, 21:05

Bonjour,

Je suis en train d'installer Arch sur une machine neuve Nuc6i3syh, ssd Samsung 950 pro et 8Go de ram.

J'ai choisi la table de partition suivante :
/dev/nvme0n1p1 en FAT32 pour le boot avec l'étiquette EF00
/dev/nvme0n1p2 en btrfs pour Arch qui est installé dans un subvolum 'ArchLinux'.
/dev/nvme0n1p3 en NTFS pour une future installation Windows avec l'étiquette win7.

L'installation s'est super bien passé, j'ai pu faire le chroot mais voilà, au moment de la dernière étape du grub-install, j'ai un problème de multi signature qui empêche le grub de se lancer au démarrage :

Code : Tout sélectionner

sh-4.3# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch_grub --recheck
Installing for x86_64-efi platform 
GUID Partition Table Header signature is wrong: 41615252 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645

**************************************
Warning! This MBR disk does not have a unique signature.
If this is not the first disk found found by EFI, you may not be able to boot from it without a unique signature. 
Run efibootmgr with the -w flag to write a unique signature to the disk.
**************************************

Installation finished. No error reported.
Bien sûr, je fais ce qu'il me dit en tapant 'efibootmgr -w'

Code : Tout sélectionner

sh-4.3# efibootmgr -w
Bootcurrent: 0009
Timeout: 1 seconds
Bootloader: 0001,0008,0009,0006,0003,0007,0000
Boot0000* Windows Boot Manager 
Boot0001* arch_grub 
Boot0003* LAN : IBA CL Slot 00FE v104
Boot0006* N1-Samsung SSD 950 PRO 256GB : PART 0 : Boot Drive
Boot0007* UEFI : Hard Drive : PART 0 : OS Bootloader 
Boot0008* USB : USB Flash DISK 1100 : PART 0 : Boot Drive 
Boot0009* UEFI : USB : USB Flash Disk 1100 : PART 0 : OS Bootloader
Et là, je ne sais plus quoi faire pour avoir une signature unique :cry:

Voilà, si besoin d'autres infos, n'hésitez pas!

Merci.
Dernière modification par Saga_Fire le jeu. 30 juin 2016, 02:39, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15941
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [GRUB] Besoin d'une signature unique

Message par benjarobin » dim. 12 juin 2016, 21:33

Comment as tu crée la table de partition GPT ? As tu bien effacé toute trace de la table de partition précédente ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Saga_Fire
Hankyu
Messages : 13
Inscription : dim. 12 juin 2016, 19:34

Re: [GRUB] Besoin d'une signature unique

Message par Saga_Fire » dim. 12 juin 2016, 21:47

Le ssd étant neuf, j'ai créé la table de partition directement sans rien faire au préalable.

Je l'ai créé avec Gparted sur une clé USB.

L'ayant formaté au moment de la création, je n'ai pas jugé utile de formater les partitions au moment de l'installation.

Que me suggères-tu à présent stp?

Saga_Fire
Hankyu
Messages : 13
Inscription : dim. 12 juin 2016, 19:34

Re: [GRUB] Besoin d'une signature unique

Message par Saga_Fire » dim. 12 juin 2016, 21:50

Pardon, au faite il n'y avait pas de table de partition avant le ssd, aucun système de fichiers et un point d'exclamation à côté du nom.

J'ai ainsi créé la table de partition.

Saga_Fire
Hankyu
Messages : 13
Inscription : dim. 12 juin 2016, 19:34

Re: [GRUB] Besoin d'une signature unique

Message par Saga_Fire » dim. 12 juin 2016, 23:32

Je vais recommencer l'installation en effaçant toutes traces des tables de partitions précédente.

Comment je fais svp?

Saga_Fire
Hankyu
Messages : 13
Inscription : dim. 12 juin 2016, 19:34

Re: [GRUB] Besoin d'une signature unique

Message par Saga_Fire » lun. 13 juin 2016, 04:22

J'ai effacé la table de partition avec gdisk en mode expert et détruit le GPT avec l'option 'z', et j'en ai recrée une avec le MBR protective.

J'ai ensuite fait mes partitions avec cgdisk.

Au moment du grub-install, je retombe sur le même type d'erreur de signature cité plus haut :(

Help me please :cry:

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [GRUB] Besoin d'une signature unique

Message par Xorg » lun. 13 juin 2016, 09:22

Est-ce que tu peux nous donner la sortie de la commande fdisk -l pour qu'on puisse vérifier ?

PS : Tu as une option pour éditer tes messages.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

benjarobin
Maître du Kyudo
Messages : 15941
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [GRUB] Besoin d'une signature unique

Message par benjarobin » lun. 13 juin 2016, 09:36

Peux tu donner aussi en plus la sortie en root depuis le liveCD de : gdisk -l /dev/nvme0n1 (si ton disque s'appelle bien ainsi) ainsi que la sortie de : blkid
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Saga_Fire
Hankyu
Messages : 13
Inscription : dim. 12 juin 2016, 19:34

Re: [GRUB] Besoin d'une signature unique

Message par Saga_Fire » lun. 13 juin 2016, 16:45

Désolé des multi-postes.

Alors, pour fdisk -l :

Code : Tout sélectionner

Disk /dev/nvme0n1: 238,5 GiB, 256060514304 bytes, 500118192 sectors 
Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes 
I/O size (minimum/optimal): 512 bytes / 512 bytes 
Disklabel type: gpt 
disk identifier: FF27451B-218C-4F2F-9A22-0BE69DFD87D4

Device                                Start              End
/dev/nvme0n1p1             2048       526335
/dev/nvme0n1p2        526336 440928255 
/dev/nvme0n1p3 440928256 500118158

      Sectors    Size Type
    5242498  256M EFI System 
440401920  210G Linux filesystem 
  59189903 28.2G Microsoft basic data 


Disk /dev/sda: 3.8 GiB, 4051697664 bytes, 7913472 sectors 
Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes 
I/O size (minimum/optimal): 512 bytes / 512 bytes 
Disklabel type: dos 
disk identifier: 0xc3072e18

Device       Boot Start    Sectors Size  Id Type 
/dev/sda1 *            56 7913471 3.8G  b W95 FAT32


Disk /dev/loop0: 323.1 MiB, 338796544 bytes, 661712 sectors 
Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes 
I/O size (minimum/optimal): 512 bytes / 512 bytes 
On aura compris que le sda est l'ISO et le loop0 est mon clavier en RF.

Pour gdisk -l /dev/nvme0n1:

Code : Tout sélectionner

GPT fdisk (gdisk) version 1.0.1

Partition table scan:
  MBR: protective
  BSD:  not present 
  AMP: not present 
  GPT:  present 
  
Found valid GPT with protective MBR; using GPT.
Disk /dev/nvme0n1: 500118192 sectors, 238.5 GiB
Logical sector size: 512 bytes 
Disk identifier (GUID) FF27451B-218C-4F2F-9A22-0BE69DFD87D4
Partition table holds up to 128 entries 
First usable sector is 34, last usable sector is 500118158
Partitions will be aligned on 2048-sector boundaries 
Total free space is 2014 sectors (1007.0 KiB)

Number Start (sector) End (sector)
    1                       2048          526335
    2                   526336   440928255
    3            440928256   500118158

Size               Code  Name 
256.0 MiB     EF00  boot
210.0 GiB      8300  linux 
28.2 GiB        0700  windows 
Et enfin, pour blkid:

Code : Tout sélectionner

/dev/nvme0n1p1: UUID="D4CF-3237" TYPE="vfat" PARTLABEL="boot" PARTUUID="113ec339-e3e1-4da1-880a-d51fc9c7816a"
/dev/nvme0n1p2: UUID="b99dc967-f6d9-4695-b444-99d481f457de" UUID_SUB="30351935-f016-4c37-ac6e-9924da080051" TYPE="btrfs" PARTLABEL="linux" PARTUUID="17242653-d565-47e0-a85e-ff2127d0f5d8"
/dev/nvme0n1p3: UUID="7C87675D78FC5305" TYPE="ntfs" PARTLABEL="windows" PARTUUID="54855913-292d-4345-91bf-52f1b0297201"
/dev/sda1: LABEL="MYLINUXLIVE" UUID="E4A0-0D9C" TYPE="vfat" PARTUUID="c3072e18-01"
/dev/loop0: TYPE="squashfs"
/dev/nvme0n1: PTUUID="ff27451b-218c-4f2f-9a22-0be69df87d4" PTTYPE="gpt"
En recopiant, deux choses m'ont interpellé:
_ /dev/nvme0n1p2 est le seul à avoir un UUID et un UUID_SUB
_ /dev/nvme0n1 à un GUID identique au PTUUID à la différence que le GUID est en majuscule et que le PTUID en minuscule.

Après je ne sais pas ce que valent ces deux remarques mdr :?

Édit: désolé si le code n'est pas très lisible :chinois:

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [GRUB] Besoin d'une signature unique

Message par Xorg » lun. 13 juin 2016, 18:22

Ça me paraît correct les résultats que tu nous as donné.
Il n'y a pas d'anomalies pour l'UUID de /dev/nvme0n1p1 et de /dev/nvme0n1p3, c'est juste que ce n'est pas le même type de système de fichiers, et elles sont toujours plus courtes pour le FAT32 et le NTFS que pour l'Ext4.

En fait, c'est juste un message d'avertissement. Est-ce que ça t'empêche de démarrer ?
Le cas échéant, fait un efibootmgr -w avant d'installer GRUB.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2054
Inscription : jeu. 15 mars 2012, 05:08

Re: [GRUB] Besoin d'une signature unique

Message par waitnsea » lun. 13 juin 2016, 18:37

Vu ça : le problème viendrait de Windows ?

Saga_Fire
Hankyu
Messages : 13
Inscription : dim. 12 juin 2016, 19:34

Re: [GRUB] Besoin d'une signature unique

Message par Saga_Fire » lun. 13 juin 2016, 20:24

@Xorg: Oui ça m'empêche de démarrer, l'avertissement dit bien que ça pourrait empêcher de le grub et même en faisant un

Code : Tout sélectionner

efibootmgr -w
avant installation de grub, j'ai toujours le même message au moment du grub-install.

@waitnsee: je veux bien mais la partition ntfs est vide. Ceci dit, je t'ai quand-même pris au mot en réinstallant une table de partition sans partition ntfs. Du coup, avant d'installer grub, j'ai fait un

Code : Tout sélectionner

efibootmgr -w
et à la fin, j'ai encore le même message au moment du grub-install :cry:

PS: j'ai voulu écrire "efibootmgr -w" comme Xorg mais j'ai pas réussi mdr :?

ÉDIT: D'ailleurs quand je fais "efibootmgr -w" ke vois pas pourquoi il y a :

Code : Tout sélectionner

Boot0000* Windows Boot Manager
alors que je n'ai pas Windows. Ça se trouve ça n'a rien avoir mdr :?

benjarobin
Maître du Kyudo
Messages : 15941
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [GRUB] Besoin d'une signature unique

Message par benjarobin » lun. 13 juin 2016, 20:56

Peux tu détailler quand tu dis que cela t’empêche de démarrer ? Vois tu Grub ? Qu'est ce qui s’affiche à l'écran ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [GRUB] Besoin d'une signature unique

Message par Xorg » lun. 13 juin 2016, 21:38

Saga_Fire a écrit :ÉDIT: D'ailleurs quand je fais "efibootmgr -w" ke vois pas pourquoi il y a :

Code : Tout sélectionner

Boot0000* Windows Boot Manager
alors que je n'ai pas Windows. Ça se trouve ça n'a rien avoir mdr :?
Peut-être une histoire de Secure Boot d'activé tout ça... Va dans le setup de l'UEFI, et désactive le Secure boot (pense à enregistrer avant de quitter).

Ensuite, tu devrais pouvoir supprimer cette entrée de boot avec efibootmgr -B -b 0000.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

benjarobin
Maître du Kyudo
Messages : 15941
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [GRUB] Besoin d'une signature unique

Message par benjarobin » lun. 13 juin 2016, 21:50

L'entrée de Windows n'a aucune importance (sur ma carte mère je ne peux pas la supprimer). L'important c'est que l'ordre de boot soit correct (Grub est bien en premier)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Saga_Fire
Hankyu
Messages : 13
Inscription : dim. 12 juin 2016, 19:34

Re: [GRUB] Besoin d'une signature unique

Message par Saga_Fire » lun. 13 juin 2016, 22:00

@benjamin: ça lance le Intel Boot Agent.

Code : Tout sélectionner

PXE-E53: no boot filename received 

PXE-M0F: Existing Intel Boot Agent. 
@Xorg: le secureboot est déjà désactivé et j'ai pu enlever l'entrée windows boot manager avec la commande que tu m'as donné mais j'ai toujours le même résultat au grub-install et je retombe sur le Intel Boot Agent au démarrage.

benjarobin
Maître du Kyudo
Messages : 15941
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [GRUB] Besoin d'une signature unique

Message par benjarobin » lun. 13 juin 2016, 22:06

Ce n'est donc pas Grub le problème ici, car l'application EFI de Grub n'est même pas lancé. Fouille les options de ton BIOS/EFI pour changer l'ordre de boot, car apparemment il essaye de démarrer depuis le réseau. Normalement tu devrait trouver un menu qui permet de sélectionner sur quoi tu veux démarrer. Ce menu peut être affiché via un raccourci oui depuis l’interface du "BIOS", cela dépend des modèles
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Saga_Fire
Hankyu
Messages : 13
Inscription : dim. 12 juin 2016, 19:34

Re: [GRUB] Besoin d'une signature unique

Message par Saga_Fire » lun. 13 juin 2016, 22:54

Alors quand je vais dans la boot menu, et que je sélectionne "UEFI : Hard Drive : PART 0 : OS Bootloader" ça revient au menu du Bootloader.

Dans le BIOS, l'entrée en premier est le Hard Drive. Ensuite c'est le réseau LAN.

J'aimerai signaler quelque chose puisqu'on est dans le BIOS.
J'ai le UEFI boot coché et le Legacy boot coché. Je me dis que peut-être c'est ça qui crée la double signature mais quand je désélectionne le Legacy boot, j'ai toujours le même résultat.
Peut-être dans ce cas je dois réinstaller le grub??

D'ailleurs c'est grave si le UEFI boot et le Legacy boot sont coché ?
Quel type de boot je dois privilégier?

EDIT: je rappelle que le pc est neuf sans OS. Je dois faire des réglages dans le BIOS avant ?

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [GRUB] Besoin d'une signature unique

Message par Xorg » lun. 13 juin 2016, 23:11

Ça revient au menu de quel bootloader ? GRUB ?

En fait les UEFI ne sont pas tout à fait pareii qu'un BIOS, la manière de booter n'est pas la même.
Un BIOS va lire le MBR des disques à la recherche d'un bootloader, alors que l'UEFI, lui, possède des entrées vers des fichiers exécutables (parfois avec l'extension .efi), qui sont stockés dans l'ESP.

Le mode Legacy est un genre de mode de compatibilité, ça démarre de la même manière qu'un BIOS (en UEFI pure, ce n'est pas possible).
Ça n'est pas dérangeant si la case "Legacy" est cochée. On te conseille d'opter pour le mode UEFI.

Donc si GRUB n'arrive pas à créer l'entrée de boot, tu peux la créer à la main. Tu as des exemples sur cette page.
Attention, le chemin que tu mets après l'option -l est absolu par rapport à l'ESP. Il faut que les fichiers soient présents dans l'ESP avant d’utiliser efibootmgr.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

otacon
Chu Ko Nu
Messages : 466
Inscription : sam. 07 sept. 2013, 19:22
Localisation : Limousin

Re: [GRUB] Besoin d'une signature unique

Message par otacon » mer. 15 juin 2016, 16:44

idée en passant : ta partition EFI a t elle les deux drapeaux : ESP et boot ?

Répondre