[Xorg] Xorg :0 -configure ne crée pas xorg.conf (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
reflets de vert
yeomen
Messages : 294
Inscription : mar. 23 mars 2010, 15:17
Localisation : Strasbourg
Contact :

[Xorg] Xorg :0 -configure ne crée pas xorg.conf (résolu)

Message par reflets de vert » mar. 01 nov. 2016, 13:41

Bonjour,

J'ai un vieux Dell latitude D410 que j'ai récupéré, et je suis en train d'installer archlinux dessus. Le souci que j'ai c'est pour configurer xorg.
Je n'arrive pas à créer un fichier xorg.conf.

Voici ce que me donne la commande Xorg

Code : Tout sélectionner

$ sudo Xorg :2 -configure
[sudo] Mot de passe de daniel : 

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.5.4-1-ARCH i686 
Current Operating System: Linux portablosaure 4.8.4-1-ARCH #1 SMP PREEMPT Sat Oct 22 18:45:32 CEST 2016 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=d4090f95-bcaa-4bb7-8b35-66eb34b8e413 rw quiet
Build Date: 19 July 2016  05:56:07PM
 
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.2.log", Time: Tue Nov  1 11:32:37 2016
List of video drivers:
	modesetting
	intel
(++) Using config file: "/root/xorg.conf.new"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.
  Configuration failed.
(EE) Server terminated with error (2). Closing log file.
Voici le fichier intel.conf que j'ai fait:

Code : Tout sélectionner

$ cat /etc/X11/xorg.conf.d/20-intel.conf 
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
EndSection
J'ai aussi modifié le fichier mkinitcpio.conf et fait

Code : Tout sélectionner

mkinitcpio -p linux
après cela.
Voici le fichier .conf:

Code : Tout sélectionner

$ cat /etc/mkinitcpio.conf 
# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES="piix ide_disk reiserfs"
MODULES="intel_agp i915"

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=""

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=""

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS="base"
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS="base udev autodetect block filesystems"
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS="base udev block filesystems"
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS="base udev block mdadm encrypt filesystems"
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS="base udev block lvm2 filesystems"
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block filesystems keyboard fsck"

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=""
Voici ce que me donne lsmod:

Code : Tout sélectionner

$ lsmod
Module                  Size  Used by
arc4                   16384  2
b43                   385024  0
bcma                   45056  1 b43
mac80211              598016  1 b43
joydev                 20480  0
cfg80211              442368  2 b43,mac80211
mousedev               20480  0
snd_intel8x0           32768  0
snd_intel8x0m          20480  0
iTCO_wdt               16384  0
gpio_ich               16384  0
snd_ac97_codec         98304  2 snd_intel8x0m,snd_intel8x0
ac97_bus               16384  1 snd_ac97_codec
iTCO_vendor_support    16384  1 iTCO_wdt
ppdev                  20480  0
snd_pcm                81920  3 snd_intel8x0m,snd_ac97_codec,snd_intel8x0
dell_laptop            20480  0
dell_smbios            16384  1 dell_laptop
rfkill                 20480  3 dell_laptop,cfg80211
snd_timer              28672  1 snd_pcm
snd                    57344  5 snd_intel8x0m,snd_ac97_codec,snd_timer,snd_intel8x0,snd_pcm
dcdbas                 16384  1 dell_smbios
dell_smm_hwmon         16384  0
psmouse               126976  0
pcspkr                 16384  0
soundcore              16384  1 snd
tg3                   155648  0
ptp                    20480  1 tg3
pps_core               20480  1 ptp
libphy                 40960  1 tg3
input_leds             16384  0
led_class              16384  3 b43,input_leds,dell_laptop
ssb                    57344  1 b43
yenta_socket           40960  0
pcmcia_rsrc            20480  1 yenta_socket
mmc_core              118784  2 b43,ssb
i2c_i801               24576  0
i2c_smbus              16384  1 i2c_i801
pcmcia                 49152  1 ssb
irda                  151552  0
lpc_ich                20480  0
pcmcia_core            20480  3 yenta_socket,pcmcia,pcmcia_rsrc
rng_core               16384  1 b43
parport_pc             28672  0
parport                40960  2 parport_pc,ppdev
shpchp                 32768  0
battery                16384  0
thermal                20480  0
evdev                  20480  10
mac_hid                16384  0
ac                     16384  0
acpi_cpufreq           20480  0
tpm_tis                16384  0
tpm_tis_core           20480  1 tpm_tis
tpm                    36864  2 tpm_tis,tpm_tis_core
sch_fq_codel           20480  6
ip_tables              20480  0
x_tables               20480  1 ip_tables
ext4                  495616  2
crc16                  16384  1 ext4
jbd2                   81920  1 ext4
fscrypto               24576  1 ext4
mbcache                16384  3 ext4
sd_mod                 36864  4
ata_generic            16384  0
pata_acpi              16384  0
serio_raw              16384  0
atkbd                  24576  0
libps2                 16384  2 atkbd,psmouse
ata_piix               32768  3
uhci_hcd               40960  0
libata                188416  3 ata_piix,ata_generic,pata_acpi
scsi_mod              139264  2 sd_mod,libata
ehci_pci               16384  0
ehci_hcd               65536  1 ehci_pci
usbcore               184320  3 ehci_hcd,uhci_hcd,ehci_pci
usb_common             16384  1 usbcore
i8042                  20480  1 dell_laptop
serio                  20480  6 serio_raw,atkbd,psmouse,i8042
i915                 1183744  2
video                  32768  2 dell_laptop,i915
button                 16384  1 i915
i2c_algo_bit           16384  1 i915
drm_kms_helper        114688  1 i915
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper
drm                   249856  4 i915,drm_kms_helper
intel_agp              20480  0
intel_gtt              20480  2 intel_agp,i915
agpgart                32768  3 intel_agp,intel_gtt,drm
Et voici le log de Xorg. startx démarre et j'ai configuré la connexion avec xdm-archlinux, qui fonctionne avec un .xinitrc que j'ai mis en place.

Code : Tout sélectionner

$ cat /var/log/Xorg.0.log
[    19.713] 
X.Org X Server 1.18.4
Release Date: 2016-07-19
[    19.713] X Protocol Version 11, Revision 0
[    19.713] Build Operating System: Linux 4.5.4-1-ARCH i686 
[    19.713] Current Operating System: Linux portablosaure 4.8.4-1-ARCH #1 SMP PREEMPT Sat Oct 22 18:45:32 CEST 2016 i686
[    19.714] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=d4090f95-bcaa-4bb7-8b35-66eb34b8e413 rw quiet
[    19.714] Build Date: 19 July 2016  05:56:07PM
[    19.714]  
[    19.714] Current version of pixman: 0.34.0
[    19.714] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    19.714] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    19.714] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov  1 09:55:50 2016
[    19.748] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    19.748] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    19.774] (==) No Layout section.  Using the first Screen section.
[    19.774] (==) No screen section available. Using defaults.
[    19.774] (**) |-->Screen "Default Screen Section" (0)
[    19.774] (**) |   |-->Monitor "<default monitor>"
[    19.792] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[    19.792] (**) |   |-->Device "Intel Graphics"
[    19.792] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    19.792] (==) Automatically adding devices
[    19.792] (==) Automatically enabling devices
[    19.792] (==) Automatically adding GPU devices
[    19.799] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    19.859] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    19.859] 	Entry deleted from font path.
[    19.859] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    19.859] 	Entry deleted from font path.
[    19.859] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    19.860] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    19.860] 	Entry deleted from font path.
[    19.860] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    19.860] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/OTF/
[    19.860] (==) ModulePath set to "/usr/lib/xorg/modules"
[    19.860] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    19.860] (II) Loader magic: 0x82a96c0
[    19.860] (II) Module ABI versions:
[    19.860] 	X.Org ANSI C Emulation: 0.4
[    19.860] 	X.Org Video Driver: 20.0
[    19.860] 	X.Org XInput driver : 22.1
[    19.860] 	X.Org Server Extension : 9.0
[    19.863] (--) using VT number 2

[    19.863] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    19.864] (II) xfree86: Adding drm device (/dev/dri/card0)
[    19.897] (--) PCI:*(0:0:2:0) 8086:2592:1028:018f rev 3, Mem @ 0xdff00000/524288, 0xc0000000/268435456, 0xdfec0000/262144, I/O @ 0x0000ec38/8, BIOS @ 0x????????/131072
[    19.897] (--) PCI: (0:0:2:1) 8086:2792:1028:018f rev 3, Mem @ 0xdff80000/524288
[    19.897] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    19.897] (II) LoadModule: "glx"
[    19.899] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    20.042] (II) Module glx: vendor="X.Org Foundation"
[    20.042] 	compiled for 1.18.4, module version = 1.0.0
[    20.042] 	ABI class: X.Org Server Extension, version 9.0
[    20.042] (==) AIGLX enabled
[    20.042] (II) LoadModule: "intel"
[    20.042] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    20.134] (II) Module intel: vendor="X.Org Foundation"
[    20.134] 	compiled for 1.18.4, module version = 2.99.917
[    20.134] 	Module class: X.Org Video Driver
[    20.134] 	ABI class: X.Org Video Driver, version 20.0
[    20.134] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    20.134] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    20.134] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    20.134] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    20.135] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[    20.135] (WW) xf86OpenConsole: setsid failed: Operation not permitted
[    20.162] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160711
[    20.162] (II) intel(0): SNA compiled from 2.99.917-722-g714052f
[    20.182] (--) intel(0): Integrated Graphics Chipset: Intel(R) 915GM
[    20.182] (--) intel(0): CPU: x86, sse2; using a maximum of 1 threads
[    20.182] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    20.182] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    20.182] (==) intel(0): RGB weight 888
[    20.182] (==) intel(0): Default visual is TrueColor
[    20.183] (II) intel(0): Output LVDS1 has no monitor section
[    20.184] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output LVDS1
[    20.184] (II) intel(0): Enabled output LVDS1
[    20.184] (II) intel(0): Output VGA1 has no monitor section
[    20.184] (II) intel(0): Enabled output VGA1
[    20.184] (II) intel(0): Output DVI1 has no monitor section
[    20.184] (II) intel(0): Enabled output DVI1
[    20.184] (II) intel(0): Output TV1 has no monitor section
[    20.185] (II) intel(0): Enabled output TV1
[    20.185] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[    20.185] (II) intel(0): Output VIRTUAL1 has no monitor section
[    20.185] (II) intel(0): Enabled output VIRTUAL1
[    20.185] (--) intel(0): Output LVDS1 using initial mode 1024x768 on pipe 1
[    20.185] (==) intel(0): TearFree disabled
[    20.185] (==) intel(0): DPI set to (96, 96)
[    20.185] (II) Loading sub module "dri2"
[    20.185] (II) LoadModule: "dri2"
[    20.185] (II) Module "dri2" already built-in
[    20.185] (II) Loading sub module "present"
[    20.185] (II) LoadModule: "present"
[    20.185] (II) Module "present" already built-in
[    20.186] (==) Depth 24 pixmap format is 32 bpp
[    20.222] (II) intel(0): SNA initialized with Alviso (gen3) backend
[    20.223] (==) intel(0): Backing store enabled
[    20.223] (==) intel(0): Silken mouse enabled
[    20.224] (II) intel(0): HW Cursor enabled
[    20.224] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    20.225] (==) intel(0): DPMS enabled
[    20.226] (==) intel(0): Display hotplug detection enabled
[    20.248] (II) intel(0): [DRI2] Setup complete
[    20.248] (II) intel(0): [DRI2]   DRI driver: i915
[    20.248] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[    20.248] (II) intel(0): direct rendering: DRI2 enabled
[    20.248] (II) intel(0): hardware support for Present enabled
[    20.248] (--) RandR disabled
[    20.561] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    20.561] (II) AIGLX: enabled GLX_ARB_create_context
[    20.561] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    20.561] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[    20.561] (II) AIGLX: enabled GLX_INTEL_swap_event
[    20.561] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    20.561] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[    20.561] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[    20.561] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[    20.561] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    20.561] (II) AIGLX: Loaded and initialized i915
[    20.561] (II) GLX: Initialized DRI2 GL provider for screen 0
[    20.583] (II) intel(0): switch to mode 1024x768@60.0 on LVDS1 using pipe 1, position (0, 0), rotation normal, reflection none
[    20.584] (II) intel(0): Setting screen physical size to 270 x 203
[    20.941] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[    20.941] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[    20.941] (II) LoadModule: "libinput"
[    20.942] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    21.003] (II) Module libinput: vendor="X.Org Foundation"
[    21.003] 	compiled for 1.18.4, module version = 0.22.0
[    21.003] 	Module class: X.Org XInput Driver
[    21.003] 	ABI class: X.Org XInput driver, version 22.1
[    21.003] (II) Using input driver 'libinput' for 'Video Bus'
[    21.003] (**) Video Bus: always reports core events
[    21.003] (**) Option "Device" "/dev/input/event3"
[    21.003] (**) Option "_source" "server/udev"
[    21.005] (II) input device 'Video Bus', /dev/input/event3 is tagged by udev as: Keyboard
[    21.005] (II) input device 'Video Bus', /dev/input/event3 is a keyboard
[    21.013] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input3/event3"
[    21.013] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 6)
[    21.014] (II) input device 'Video Bus', /dev/input/event3 is tagged by udev as: Keyboard
[    21.014] (II) input device 'Video Bus', /dev/input/event3 is a keyboard
[    21.015] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    21.015] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    21.015] (II) Using input driver 'libinput' for 'Power Button'
[    21.015] (**) Power Button: always reports core events
[    21.015] (**) Option "Device" "/dev/input/event1"
[    21.015] (**) Option "_source" "server/udev"
[    21.016] (II) input device 'Power Button', /dev/input/event1 is tagged by udev as: Keyboard
[    21.016] (II) input device 'Power Button', /dev/input/event1 is a keyboard
[    21.026] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1/event1"
[    21.026] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    21.028] (II) input device 'Power Button', /dev/input/event1 is tagged by udev as: Keyboard
[    21.028] (II) input device 'Power Button', /dev/input/event1 is a keyboard
[    21.029] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[    21.029] (II) No input driver specified, ignoring this device.
[    21.029] (II) This device may have been added with another device file.
[    21.030] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
[    21.030] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[    21.030] (II) Using input driver 'libinput' for 'Sleep Button'
[    21.030] (**) Sleep Button: always reports core events
[    21.030] (**) Option "Device" "/dev/input/event2"
[    21.030] (**) Option "_source" "server/udev"
[    21.031] (II) input device 'Sleep Button', /dev/input/event2 is tagged by udev as: Keyboard
[    21.031] (II) input device 'Sleep Button', /dev/input/event2 is a keyboard
[    21.040] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2/event2"
[    21.040] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[    21.041] (II) input device 'Sleep Button', /dev/input/event2 is tagged by udev as: Keyboard
[    21.041] (II) input device 'Sleep Button', /dev/input/event2 is a keyboard
[    21.042] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event4)
[    21.042] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[    21.042] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[    21.042] (**) AT Translated Set 2 keyboard: always reports core events
[    21.042] (**) Option "Device" "/dev/input/event4"
[    21.042] (**) Option "_source" "server/udev"
[    21.043] (II) input device 'AT Translated Set 2 keyboard', /dev/input/event4 is tagged by udev as: Keyboard
[    21.043] (II) input device 'AT Translated Set 2 keyboard', /dev/input/event4 is a keyboard
[    21.063] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input4/event4"
[    21.063] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[    21.065] (II) input device 'AT Translated Set 2 keyboard', /dev/input/event4 is tagged by udev as: Keyboard
[    21.065] (II) input device 'AT Translated Set 2 keyboard', /dev/input/event4 is a keyboard
[    21.066] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/event7)
[    21.066] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "libinput touchpad catchall"
[    21.066] (II) Using input driver 'libinput' for 'AlpsPS/2 ALPS DualPoint TouchPad'
[    21.066] (**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
[    21.066] (**) Option "Device" "/dev/input/event7"
[    21.066] (**) Option "_source" "server/udev"
[    21.067] (II) input device 'AlpsPS/2 ALPS DualPoint TouchPad', /dev/input/event7 is tagged by udev as: Touchpad
[    21.067] (II) AlpsPS/2 ALPS DualPoint TouchPad: no resolution or size hints, assuming a size of 69x50mm
[    21.067] (II) input device 'AlpsPS/2 ALPS DualPoint TouchPad', /dev/input/event7 is a touchpad
[    21.086] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input7/event7"
[    21.087] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS DualPoint TouchPad" (type: TOUCHPAD, id 10)
[    21.087] (**) Option "AccelerationScheme" "none"
[    21.087] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) selected scheme none/0
[    21.087] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration factor: 2.000
[    21.087] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration threshold: 4
[    21.088] (II) input device 'AlpsPS/2 ALPS DualPoint TouchPad', /dev/input/event7 is tagged by udev as: Touchpad
[    21.088] (II) AlpsPS/2 ALPS DualPoint TouchPad: no resolution or size hints, assuming a size of 69x50mm
[    21.088] (II) input device 'AlpsPS/2 ALPS DualPoint TouchPad', /dev/input/event7 is a touchpad
[    21.089] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/mouse1)
[    21.089] (II) No input driver specified, ignoring this device.
[    21.089] (II) This device may have been added with another device file.
[    21.091] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint Stick (/dev/input/event6)
[    21.091] (**) AlpsPS/2 ALPS DualPoint Stick: Applying InputClass "libinput pointer catchall"
[    21.091] (II) Using input driver 'libinput' for 'AlpsPS/2 ALPS DualPoint Stick'
[    21.091] (**) AlpsPS/2 ALPS DualPoint Stick: always reports core events
[    21.091] (**) Option "Device" "/dev/input/event6"
[    21.091] (**) Option "_source" "server/udev"
[    21.092] (II) input device 'AlpsPS/2 ALPS DualPoint Stick', /dev/input/event6 is tagged by udev as: Mouse Pointingstick
[    21.092] (II) input device 'AlpsPS/2 ALPS DualPoint Stick', /dev/input/event6 is a pointer caps
[    21.110] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input8/event6"
[    21.110] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS DualPoint Stick" (type: MOUSE, id 11)
[    21.110] (**) Option "AccelerationScheme" "none"
[    21.110] (**) AlpsPS/2 ALPS DualPoint Stick: (accel) selected scheme none/0
[    21.110] (**) AlpsPS/2 ALPS DualPoint Stick: (accel) acceleration factor: 2.000
[    21.110] (**) AlpsPS/2 ALPS DualPoint Stick: (accel) acceleration threshold: 4
[    21.111] (II) input device 'AlpsPS/2 ALPS DualPoint Stick', /dev/input/event6 is tagged by udev as: Mouse Pointingstick
[    21.111] (II) input device 'AlpsPS/2 ALPS DualPoint Stick', /dev/input/event6 is a pointer caps
[    21.112] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint Stick (/dev/input/mouse0)
[    21.112] (II) No input driver specified, ignoring this device.
[    21.112] (II) This device may have been added with another device file.
[    21.113] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
[    21.114] (II) No input driver specified, ignoring this device.
[    21.114] (II) This device may have been added with another device file.
[    22.186] (II) intel(0): EDID vendor "SEC", prod id 19032
[    22.186] (II) intel(0): Printing DDC gathered Modelines:
[    22.186] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz eP)
J'ai installé xf86-video-intel bien sûr. Je me demande s'il n'y a pas deux composants dans l'ordi qui gèrent l'affichage. Dans lspci il y a comme deux choses qui renvoient à l'affichage, dont un seul noté VGA:

Code : Tout sélectionner

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
01:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
02:01.0 CardBus bridge: Texas Instruments PCI6515 Cardbus Controller
02:01.5 Communication controller: Texas Instruments PCI6515 SmartCard Controller
02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
Voilà, j'espère que je n'ai rien oublié!
Dernière modification par reflets de vert le mar. 01 nov. 2016, 19:19, modifié 1 fois.
J'utilise console-tdm, dwm, …
(bon moi aussi j'écris en bépo - même si ça se voit pas)

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Xorg] Xorg :0 -configure ne crée pas xorg.conf

Message par benjarobin » mar. 01 nov. 2016, 14:54

Bonjour,
Cela tombe bien cela fait des années maintenant qu'il ne faut pas créer de fichier xorg.conf (c'est marqué dans le Wiki)...
Bref, quel est le souci ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
reflets de vert
yeomen
Messages : 294
Inscription : mar. 23 mars 2010, 15:17
Localisation : Strasbourg
Contact :

Re: [Xorg] Xorg :0 -configure ne crée pas xorg.conf

Message par reflets de vert » mar. 01 nov. 2016, 18:18

Bon j'ai plutôt suivi bêtement le wiki, en lisant le début mais pas la suite.
Il y a quand même cette partie du wiki sur Xorg: https://wiki.archlinux.org/index.php/Xo ... _xorg.conf

Le souci c'est que la résolution ne va pas, et qu'il n'a pas généré de 10-monitor.conf automatiquement, comme c'est écrit. Pourquoi, je me demande.

Je dois le faire moi-même? Je continue à regarder, merci!
J'utilise console-tdm, dwm, …
(bon moi aussi j'écris en bépo - même si ça se voit pas)

Avatar de l’utilisateur
reflets de vert
yeomen
Messages : 294
Inscription : mar. 23 mars 2010, 15:17
Localisation : Strasbourg
Contact :

Re: [Xorg] Xorg :0 -configure ne crée pas xorg.conf

Message par reflets de vert » mar. 01 nov. 2016, 19:17

Bon j'ai mis un 10-monitor.conf de ce type:

Code : Tout sélectionner

$ cat /etc/X11/xorg.conf.d/10-monitor.conf 
Section "Monitor"
	Identifier  "Monitor0"
EndSection

Section "Device"
	Identifier  "Device0"
	Driver      "intel"
EndSection

Section "Screen
	Identifier   "Screen0"
	Device       "Device0"
	Monitor      "Monitor0"
	DefaultDepth 16 #seize ou vingt-quatre
	SubSection   "Display"
	   Depth     16
	   Modes     "1024x768"
	EndSubSection
EndSection
Je sais pas si c'est la bonne manière de faire ça, je mets résolu, mais voilà au cas où il y aurait quelque chose à dire…!
J'utilise console-tdm, dwm, …
(bon moi aussi j'écris en bépo - même si ça se voit pas)

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Xorg] Xorg :0 -configure ne crée pas xorg.conf (résolu)

Message par benjarobin » mar. 01 nov. 2016, 19:40

La partie que tu cites du wiki ne devrait jamais être suivit (ou presque jamais), c'est de la configuration 100% manuelle.
Bref, ce que tu as fait c'est la bonne manière, par contre pour "Depth" pourquoi avoir mit 16 et non 24 ???

Quand tu dis que la résolution ne vas pas, c'est à dire, il a utilisé quelle résolution ? Car le log montre bien que la résolution de ton écran devrait être de 1024x768
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
reflets de vert
yeomen
Messages : 294
Inscription : mar. 23 mars 2010, 15:17
Localisation : Strasbourg
Contact :

Re: [Xorg] Xorg :0 -configure ne crée pas xorg.conf (résolu)

Message par reflets de vert » mar. 01 nov. 2016, 22:42

Ben alors je ne comprends vraiment pas! Le 10-monitor.conf a changé l'affichage pourtant!

Peut-être que ça n'a pas concerné la résolution! En tout cas au début j'avais des soucis sur les polices qui étaient pixélisées et des cadres qui débordaient de l'écran!

Ok je mets 24.
J'utilise console-tdm, dwm, …
(bon moi aussi j'écris en bépo - même si ça se voit pas)

Répondre