[Install] Question part ESP - /mnt/ect/fstab

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

[Install] Question part ESP - /mnt/ect/fstab

Message par Hokseed »

Bonjour, je decide de reinstaller arch linux proprement mais cette fois en UEFI !
Je me pose cependant une question ; pendant l'install mon fichier /ect/fstab est vide (normal j'imagine vu que j'ai tout monter dans /mnt en suivant le wiki) et dans /mnt/ect/fstab je retrouve mon /, mon /home et mon swap.
Dois-je ajouter une ligne correspondant au /boot dans ce fstab ? Dois-je egalement ecrire dans /ect/fstab ? (je suis en dualboot et ma partition esp est en vfat).

Et une petite deuxieme question : le wiki indique de decommenter locale.gen, un petit less pour me rendre compte que le fichier est a 100% rempli de commentaire j'ai donc simplement fait

Code : Tout sélectionner

echo "" > locale.gen
est ce correct ?

Merci a ceux qui prendront le temps de m'eclairer :D
Fanch
archer
Messages : 140
Inscription : lun. 01 déc. 2008, 21:16
Contact :

Re: [Install] Question part ESP - /mnt/ect/fstab

Message par Fanch »

Salut,

Pour la localisation du fstab, ca depend si tu es en chroot ou pas, mais en pratique effectivement ton system installé devrais être dans /mnt

Pour /boot, je ne sais pas

Pour locale.gen tu devrais au moins rajouter :
fr_FR.UTF-8 UTF-8
fr_FR ISO-8859-1
fr_FR@euro ISO-8859-15
"The three principal virtues of a programmer are Laziness, Impatience, and Hubris." -> man perl
Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

Re: [Install] Question part ESP - /mnt/ect/fstab

Message par Hokseed »

Merci de ta reponse !
Je suis effectivement en chroot donc pas de probleme a ce niveau la. J'ai egalement ajouter ce que tu m'as indiquer dans mon locale.gen.
Donc il me reste plus qu'a savoir si je dois modifier mon /mnt/ect/fstab pour rajouter ma ligne du /boot (je l'ai fait mais dans le doute ^^)
Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2069
Inscription : jeu. 15 mars 2012, 05:08

Re: [Install] Question part ESP - /mnt/ect/fstab

Message par waitnsea »

Hokseed a écrit :Donc il me reste plus qu'a savoir si je dois modifier mon /mnt/ect/fstab pour rajouter ma ligne du /boot (je l'ai fait mais dans le doute ^^)
Bonjour,
Réfère-toi au Wiki : juste avant de chrooter pour finir la configuration, tu dois exécuter la commande # genfstab -U /mnt >> /mnt/etc/fstab qui ajoutera au fstab tous les points montés dans /mnt : la racine /, le /home, la swap si tu en as créée une, et la partition esp montée sur /boot/efi/.
Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

Re: [Install] Question part ESP - /mnt/ect/fstab

Message par Hokseed »

ouep je l'ai fait mais vu que je suis en dual boot la partition esp etait deja créer donc j'ai rajouter une ligne correspondant dans fstab. Quoiqu'il en soit j'ai ternminer l'install j'ai finis par umount -R /mnt et jai reboot. Malheureusement c'est windows qui a demarré ! Un petit tour dans le bios et je vois bien que c'est ARCH qui est devant et qui n'a apparemment pas pu se lancer :?
Je précise que j'ai utilisé EFI Boot Stub qui m'a été vendu comme un avantage de l'UEFI... Sauf si vous avez des idées je vais retourner sur GRUB a moins que le soucis ne vienne pas de la. Bref je suis un peu perdu excusez-moi :D
Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

Re: [Install] Question part ESP - /mnt/ect/fstab

Message par Hokseed »

Petite précision quand je desacrive dans le UEFI le CMS, le FastBoot et le SecureBoot, j'ai une erreur :
"American Megatrends
...ma config...
The VGA card is not supported by UEFI driver.
CSM (Compatibility Support Module) settings have been changed for better compatibility.
For further adjustments, press [F1] to enter bios setup
If no adjustments needed, press [F2] to confirm the current settings and enter OS directly.
Press F1 to Run SETUP
Press F2 to Continue"

F1 : je rentre dans le bios et il ma reactiver le CMS et remis Windaube en first boot
F2 : boot sur windows

Si vous savez quoi faire je suis preneur :D
benjarobin
Maître du Kyudo
Messages : 16020
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Install] Question part ESP - /mnt/ect/fstab

Message par benjarobin »

Si tu veux un multiboot, tu ne dois pas utiliser EFI Boot Stub, car tu n'auras pas de menu, à part celui de ta carte mère qui est souvent inutilisable...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

Re: [Install] Question part ESP - /mnt/ect/fstab

Message par Hokseed »

C'est ce que je viens de remarquer ^^
T'as une astuce pour le virer ou j'ai juste besoin de me remettre sur mon liveUSB et d'installer GRUB ?
Merci d'avance
benjarobin
Maître du Kyudo
Messages : 16020
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Install] Question part ESP - /mnt/ect/fstab

Message par benjarobin »

Pour nettoyer les entrées dans la carte mère, utilise efibootmgr, voir son man
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

Re: [Install] Question part ESP - /mnt/ect/fstab

Message par Hokseed »

Ça marche je fais ça ce soir en rentrant du sport et je reposterais si j'ai du nouveau. Merci en tous cas
Répondre