[pacman] problème avec libcrypto, mise à jour impossible (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
reflets de vert
yeomen
Messages : 294
Inscription : mar. 23 mars 2010, 15:17
Localisation : Strasbourg
Contact :

[pacman] problème avec libcrypto, mise à jour impossible (résolu)

Message par reflets de vert » sam. 29 avr. 2017, 00:07

Bonjour,

J'ai fait la bêtise de mettre à jour les miroirs et pas les programmes, en faisant un

Code : Tout sélectionner

pacman -Syu
et en répondant non, puis en installant des programmes…

J'en avais entendu parler, mais j'avais depuis longtemps oublié les détails…

Quand je fais pacman voici ce que ça dit:

Code : Tout sélectionner

pacman -Q 
pacman: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory
J'ai essayé les symlinks dans /usr/lib (je pense en réalité que j'y comprends rien)
Et de faire pacman -r pour réinstaller openssl et pacman.

Ça ne marche pas.
Dernière modification par reflets de vert le mer. 10 mai 2017, 18:30, modifié 1 fois.
J'utilise console-tdm, dwm, …
(bon moi aussi j'écris en bépo - même si ça se voit pas)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10578
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [pacman] problème avec libcrypto, mise à jour impossible

Message par FoolEcho » sam. 29 avr. 2017, 09:23

Salut,

Le plus simple, vu qu'on ne sait pas exactement ce que tu as fait ou pas, est de passer par l'iso d'installation pour mettre à jour ton système (et de supprimer ce fameux lien symbolique que tu n'as pas su créer correctement). Monter les partitions comme tu le feras sur une nouvelle installation puis utilisation de pacstrap (au moins pour pacman mais base serait peut-être préférable). Ensuite tu pourras chrooter dans ton Arch pour t'assurer d'avoir retrouvé pacman et finir la mise à jour.

Rappel: Arch ne supporte pas les mises à jour partielles. :copain:
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
reflets de vert
yeomen
Messages : 294
Inscription : mar. 23 mars 2010, 15:17
Localisation : Strasbourg
Contact :

Re: [pacman] problème avec libcrypto, mise à jour impossible

Message par reflets de vert » mer. 10 mai 2017, 18:28

Merci,
c'est ce que j'ai fait!

Par contre j'ai fait des conneries en oubliant de monter bien tout ce qu'il faut avant de faire arch-chroot… (pas très habitué à ça).

Donc j'ai fait ça pour que ça marche:

Code : Tout sélectionner

mount /dev/sda2 /mnt
mount /dev/sda1 /mnt/boot
mount /dev/sda4 /mnt/home
pacstrap /mnt openssl-1.0
arch-chroot /mnt
pacman -Syyu
exit
umount /mnt/home
umount /mnt/boot
umount /mnt
J'utilise console-tdm, dwm, …
(bon moi aussi j'écris en bépo - même si ça se voit pas)

Répondre