[Connexion automatique] impossible (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
carafife
Hankyu
Messages : 30
Inscription : lun. 05 févr. 2018, 21:59

[Connexion automatique] impossible (résolu)

Message par carafife » ven. 09 févr. 2018, 18:50

Bonjour à tous,
J'ai parcouru la doc concernant les utilisateurs mais n'ai pas trouvé de réponse à mon problème. Dans gnome, j'ouvre les préférences "Utilisateurs" et après déverrouillage j'active la connexion automatique de l'utilisateur. Je ne trouve aucun bouton de validation sauf "Ajout d'utilisateur". Est-ce parce que je n'ai qu'un utilisateur que le système n'enregistre pas mon choix?
Dernière modification par carafife le sam. 10 févr. 2018, 16:37, modifié 1 fois.
Antergos - Kernel: 4.15.1-2-ARCH x86_64 - Gnome 3.28 - Thinkpad X230 8Gb - Intel Core i5-3320M - Graphic HD 4000 - Audio: Series/C216 Family High Def. Audio Controller - ssd 240Gb

Avatar de l’utilisateur
onyx67
Elfe
Messages : 735
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [Connexion automatique] impossible

Message par onyx67 » ven. 09 févr. 2018, 20:24

Si ton gestionnaire de connexion est GDM, voir ici
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

carafife
Hankyu
Messages : 30
Inscription : lun. 05 févr. 2018, 21:59

Re: [Connexion automatique] impossible

Message par carafife » ven. 09 févr. 2018, 21:22

Merci pour ton suivi!

Mon gestionnaire est Lightdm. Je me suis rendu sur la page wiki : https://wiki.archlinux.fr/LightDM

Je me suis rendu compte que je n'étais pas configuré en autologin. Je m'y suis rajouté y compris au group. Après vérification cela semble bon:

Code : Tout sélectionner

[carafife@Carafife ~]$ cat /etc/group | grep autologin
autologin:x:619:carafife
[carafife@Carafife ~]$ 
J'ai donc maintenant une connexion auto qui fonctionne... :bravo:
Malgré cela, ça ne marche toujours pas en mode graphique. Le bouton connexion auto est grisé malgré la connexion auto et lorsque je l'active il n'est pas sauvegardé. J'aurais quand même bien aimé pouvoir le faire facilement depuis les paramètres... :evil:
Une idée?
Antergos - Kernel: 4.15.1-2-ARCH x86_64 - Gnome 3.28 - Thinkpad X230 8Gb - Intel Core i5-3320M - Graphic HD 4000 - Audio: Series/C216 Family High Def. Audio Controller - ssd 240Gb

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Connexion automatique] impossible

Message par Xorg » ven. 09 févr. 2018, 21:53

Tu ne peux pas configurer LightDM depuis les paramètres de Gnome. Ces paramètres influent sur GDM.
Il faudrait que tu remplaces LightDM par GDM sinon.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

carafife
Hankyu
Messages : 30
Inscription : lun. 05 févr. 2018, 21:59

Re: [Connexion automatique] impossible

Message par carafife » sam. 10 févr. 2018, 16:14

Tu ne peux pas configurer LightDM depuis les paramètres de Gnome
Voilà qui explique tout! :D Bon j'y vois plus clair. Je viens encore d'apprendre des trucs... (c'est tout ce que je cherchais en venant vers Arch)

Du coup, je trouverais plus logique d'harmoniser mon système.

1- Y aurait t-il un risque de casser mon système en installant GDM?
2- J'installe des paquets en particulier?
3- Je dois désinstaller LightDm?

Peut-être faudrait-il que j'ouvre un autre post :oops:
Antergos - Kernel: 4.15.1-2-ARCH x86_64 - Gnome 3.28 - Thinkpad X230 8Gb - Intel Core i5-3320M - Graphic HD 4000 - Audio: Series/C216 Family High Def. Audio Controller - ssd 240Gb

Avatar de l’utilisateur
onyx67
Elfe
Messages : 735
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [Connexion automatique] impossible

Message par onyx67 » sam. 10 févr. 2018, 16:23

1: non.
2 + 3: installer GDM , désactiver le .service LightDm et activer celui de GDM; reboot.
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

carafife
Hankyu
Messages : 30
Inscription : lun. 05 févr. 2018, 21:59

Re: [Connexion automatique] impossible

Message par carafife » sam. 10 févr. 2018, 16:30

Cool! Merci pour ton suivi :wink:

C'est parti...
Antergos - Kernel: 4.15.1-2-ARCH x86_64 - Gnome 3.28 - Thinkpad X230 8Gb - Intel Core i5-3320M - Graphic HD 4000 - Audio: Series/C216 Family High Def. Audio Controller - ssd 240Gb

carafife
Hankyu
Messages : 30
Inscription : lun. 05 févr. 2018, 21:59

Re: [Résolu] [Connexion automatique] impossible

Message par carafife » sam. 10 févr. 2018, 16:37

Une lettre à la poste! Tout fonctionne parfaitement maintenant :bravo:

Merci encore pour le suivi :wink:
Antergos - Kernel: 4.15.1-2-ARCH x86_64 - Gnome 3.28 - Thinkpad X230 8Gb - Intel Core i5-3320M - Graphic HD 4000 - Audio: Series/C216 Family High Def. Audio Controller - ssd 240Gb

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Connexion automatique] impossible

Message par Xorg » sam. 10 févr. 2018, 18:39

carafife a écrit :
sam. 10 févr. 2018, 16:14
3- Je dois désinstaller LightDm?
Tu n'es pas obligé, car si le service est désactivé, LightDM ne sera plus actif. En revanche, ça sera un paquet inutilisé sur ton système, et donc il va occuper de l'espace disque pour rien.
Si tu sais que tu ne vas pas t'en resservir (par exemple si GDM te convient), tu peux effectivement le désinstaller. :)
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

carafife
Hankyu
Messages : 30
Inscription : lun. 05 févr. 2018, 21:59

Re: [Résolu] [Connexion automatique] impossible

Message par carafife » dim. 11 févr. 2018, 12:06

noté! :wink:
Antergos - Kernel: 4.15.1-2-ARCH x86_64 - Gnome 3.28 - Thinkpad X230 8Gb - Intel Core i5-3320M - Graphic HD 4000 - Audio: Series/C216 Family High Def. Audio Controller - ssd 240Gb

Répondre