[Freeze aléatoire] Bug usbmuxd et/ou de libimobiledevice (iPhone tethering)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
Yuno Gasai
newbie
Messages : 4
Inscription : mar. 27 mars 2018, 10:49
Localisation : Surgères (17)

[Freeze aléatoire] Bug usbmuxd et/ou de libimobiledevice (iPhone tethering)

Message par Yuno Gasai » mar. 27 mars 2018, 12:18

Bonjour, bonsoir,

J'ai récemment acheté un laptop Asus X542UA-DM585T pour du quotidien et travail sur lequel j'ai installé Arch en temps que première experience GNU/Linux en dur (j'avais déjà tâté un peu le terrain avec divers distros en machines virtuelle mais Arch est mon experience préférée), tout fonctionne plutôt bien mais j'ai un soucis de freezes qui surviennent aléatoirement, la machine peut très bien fonctionner en IDLE pendant des heures sans crasher (téléchargement Steam par exemple) comme je peux aussi lancer une activité et avoir un freeze.
Pour donner une idée de ce que je faisait quand c'est apparu la première fois je regardais une vidéo sur YouTube sur firefox en plein écran, ça m'est aussi arrivé en lançant une machine virtuelle dans VirtualBox, une autre fois ou je naviguait sur Internet en écoutant de la musique.
J'ai voulu savoir ce qu'il c'était passé, j'ai donc essayé de faire une session courte pour voir ce que journalctl pouvais me dire (et avoir un rapport complet de la session), j'ai donc trouvé

Code : Tout sélectionner

mars 27 09:54:47 Yuno-PC kwin_x11[696]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 25254, resource id: 60817550, major code: 15 (QueryTree), minor code: 0
et en cherchant sur Internet j'ai trouvé ceci https://www.reddit.com/r/archlinux/comm ... s_driving/ disant que ce n'était pas grave (c'est la toute dernière ligne affichée par le journal avant le reboot), j'ai donc regardé les autres erreur et j'ai trouvé

Code : Tout sélectionner

mars 27 09:54:30 Yuno-PC plasmashell[712]: kf5.kpackage: No metadata file in the package, expected it at: "/home/yuno/Images/Fonds d'écran/"
sur lequel je n'ai rien trouvé et étant donné qu'il pointe mes fonds d'écrans je pense que c'est simplement une erreur de lecture de l'image.

J'ai copié et sauvegardé l'intégralité du log de cette session, je peux la poster si vous voulez.

Environnement de bureau : KDE Plasma 5.12.3
Thème : Brise sombre

Cordialement :D

Yuno
Dernière modification par Yuno Gasai le ven. 06 avr. 2018, 09:32, modifié 1 fois.

Avatar de l’utilisateur
Yuno Gasai
newbie
Messages : 4
Inscription : mar. 27 mars 2018, 10:49
Localisation : Surgères (17)

Re: [Freeze aléatoire] "QXcbConnection: XCB error: 3"

Message par Yuno Gasai » sam. 31 mars 2018, 10:40

Petite mise à jour à propos de mon problème, j'ai peut-être trouvé une résolution à mon problème, j'avais utilisé la mise à l'échelle de l'affichage sur 1.4 (1080p natif donc texte trop petit à mon goût), je l'ai remis par défaut et j'ai compensé en utilisant une taille de police et des éléments graphiques plus gros, je suspecte également un problème lorsque je partage la connexion de mon iPhone en USB (5s iOS 9.3.5), actuellement ma machine à l'air stable (2 jours de suite sans freeze) mais j'ignore ce qui pouvait causer mon problème, je vais donc faire des test et voir si c'est mon iPhone qui posait problème (en Wi-Fi ça fonctionne correctement) où si c'était les paramètres graphiques que j'avais, je vous partagerais mes résultats. :chinois:

Cordialement

Yuno

Avatar de l’utilisateur
Yuno Gasai
newbie
Messages : 4
Inscription : mar. 27 mars 2018, 10:49
Localisation : Surgères (17)

Re: [Freeze aléatoire] Bug usbmuxd et/ou de libimobiledevice (iPhone tethering)

Message par Yuno Gasai » sam. 31 mars 2018, 16:05

Me revoilà, après quelques test j'en conclu que mon problème viens de mon partage de connexion USB avec mon iPhone.
Je lance une vidéo en partage de connexion, au bout de 10-15 min je freeze, avec la même procédure en Wi-Fi tout fonctionne correctement, la vidéo à tourné 2h sans soucis.
Est-ce que c'est un bug de usbmuxd et/ou de libimobiledevice ou un problème de configuration de ma part?

Cordialement

Yuno
Dernière modification par Yuno Gasai le ven. 06 avr. 2018, 09:34, modifié 1 fois.

Avatar de l’utilisateur
Yuno Gasai
newbie
Messages : 4
Inscription : mar. 27 mars 2018, 10:49
Localisation : Surgères (17)

Re: [Freeze aléatoire] Bug usbmuxd et/ou de libimobiledevice (iPhone tethering)

Message par Yuno Gasai » ven. 06 avr. 2018, 09:30

Bonjour, bonsoir,

Alors après une semaine d'utilisation sans aucun freeze (sans brancher mon téléphone paumé) je considère donc que c'est un bug de usbmuxd et/ou de libimobiledevice, je vais donc rapporter mon problème sur le Github des deux paquets et je considère mon problème (pour le moment) résolu, cependant je ne ferme pas mon sujet tout de suite, il me servira à vous donner des nouvelles.

Cordialement

Yuno

Répondre