[sddm/KDE] écran noir

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
philou24
Daikyu
Messages : 63
Inscription : dim. 09 nov. 2008, 22:06

[sddm/KDE] écran noir

Message par philou24 » mar. 01 mai 2018, 15:59

Bonjour,

Je viens de faire une mise à jour sur l'ordi de mon fils que je n'avais pas vu depuis mars.
Et là : écran noir lors du lancement de sddm (il y a quand même la flèche de la souris).
Un peu surprenant : en me connectant sous son compte en console je peux lancer "startx" qui m'ouvre icewm (je vous écris de là).
Du coup j'ai essayé de lancer lxdm : ça fonctionne, je peux ouvrir icewm, lxde, xfce mais pas kde (écran noir).

Donc le serveur X semble fonctionner mais il y un truc qui plante avec sddm/kde.

Tout est donc à jour.
Le matériel : NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile]
Les drivers : en béta compilés depuis aur (extra/nvidia 390.48-11 ne me permet pas de lancer startx)

Ca fait 3h que je cherche et je n'avance pas...

Quelques élements en vrac :

Code : Tout sélectionner

# pacman -Q | grep nvidia
lib32-opencl-nvidia-beta 396.18-1
nvidia-beta 396.18-1
nvidia-egl-wayland-beta 396.18-1
nvidia-libgl-beta 396.18-1
nvidia-utils-beta 396.18-1

# sddm --test-mode
Abandon (core dumped)

# journalctl -b | grep sddm
mai 01 15:35:17 ben_moi sddm[603]: Initializing...
mai 01 15:35:17 ben_moi sddm[603]: Logind interface found
mai 01 15:35:17 ben_moi sddm[603]: Starting...
mai 01 15:35:17 ben_moi sddm[603]: Adding new display on vt 1 ...
mai 01 15:35:17 ben_moi sddm[603]: Loading theme configuration from ""
mai 01 15:35:17 ben_moi sddm[603]: Display server starting...
mai 01 15:35:17 ben_moi sddm[603]: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{ffd30fc7-f431-4599-aebe-1a6a673fb8b2} -background none -noreset -displayfd 17 -seat seat0 vt1
mai 01 15:35:18 ben_moi sddm[603]: Setting default cursor
mai 01 15:35:18 ben_moi sddm[603]: Running display setup script  "/usr/share/sddm/scripts/Xsetup"
mai 01 15:35:18 ben_moi sddm[603]: Display server started.
mai 01 15:35:18 ben_moi sddm[603]: Socket server starting...
mai 01 15:35:18 ben_moi sddm[603]: Socket server started.
mai 01 15:35:18 ben_moi sddm[603]: Loading theme configuration from ""
mai 01 15:35:18 ben_moi sddm[603]: Greeter starting...
mai 01 15:35:18 ben_moi sddm[603]: Adding cookie to "/var/run/sddm/{ffd30fc7-f431-4599-aebe-1a6a673fb8b2}"
mai 01 15:35:18 ben_moi sddm-helper[617]: [PAM] Starting...
mai 01 15:35:18 ben_moi sddm-helper[617]: [PAM] Authenticating...
mai 01 15:35:18 ben_moi sddm-helper[617]: [PAM] returning.
mai 01 15:35:18 ben_moi sddm-helper[617]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
mai 01 15:35:18 ben_moi systemd[1]: Created slice User Slice of sddm.
mai 01 15:35:18 ben_moi systemd-logind[394]: New session c3 of user sddm.
mai 01 15:35:18 ben_moi systemd[1]: Started Session c3 of user sddm.
mai 01 15:35:18 ben_moi systemd[619]: pam_unix(systemd-user:session): session opened for user sddm by (uid=0)
mai 01 15:35:18 ben_moi sddm[603]: Greeter session started successfully
mai 01 15:35:18 ben_moi sddm-greeter[626]: High-DPI autoscaling not Enabled
mai 01 15:35:18 ben_moi sddm-greeter[626]: Loading theme configuration from "qrc:/theme/theme.conf"
mai 01 15:35:18 ben_moi sddm-greeter[626]: Reading from "/usr/share/xsessions/icewm-session.desktop"
mai 01 15:35:18 ben_moi sddm-greeter[626]: Reading from "/usr/share/xsessions/LXDE.desktop"
mai 01 15:35:18 ben_moi sddm-greeter[626]: Reading from "/usr/share/xsessions/openbox-kde.desktop"
mai 01 15:35:18 ben_moi sddm-greeter[626]: Reading from "/usr/share/xsessions/openbox.desktop"
mai 01 15:35:18 ben_moi sddm-greeter[626]: Reading from "/usr/share/xsessions/plasma.desktop"
mai 01 15:35:18 ben_moi sddm-greeter[626]: Reading from "/usr/share/xsessions/xfce.desktop"
mai 01 15:35:18 ben_moi sddm-greeter[626]: inotify_add_watch("/usr/share/wayland-sessions") failed: "No such file or directory"
mai 01 15:35:18 ben_moi sddm-greeter[626]: Connected to the daemon.
mai 01 15:35:18 ben_moi sddm[603]: Message received from greeter: Connect
mai 01 15:35:18 ben_moi sddm-greeter[626]: Loading qrc:/theme/Main.qml...
mai 01 15:35:18 ben_moi sddm-greeter[626]: libpng warning: iCCP: known incorrect sRGB profile
mai 01 15:35:18 ben_moi sddm-greeter[626]: Adding view for "eDP1" QRect(0,0 1920x1080)
mai 01 15:35:18 ben_moi sddm-greeter[626]: Message received from daemon: Capabilities
mai 01 15:35:18 ben_moi sddm-greeter[626]: Message received from daemon: HostName


Concernant les lignes du journal :

Code : Tout sélectionner

inotify_add_watch("/usr/share/wayland-sessions") failed: "No such file or directory"
...
libpng warning: iCCP: known incorrect sRGB profile
j'ai la même chose sur mes autres ordi et pas de problèmes.

Si vous avez une idée...
Merci d'avance.

Avatar de l’utilisateur
papajoke
Elfe
Messages : 535
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [sddm/KDE] écran noir

Message par papajoke » mar. 01 mai 2018, 16:34

bonjour,
il faudrait regarder du coté de sddm.conf et .pacnew (de mémoire il y a eu pas mal de changements il y a 1..2 mois - nouveaux répertoires?)
Tu lances kde avec wayland ?
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

philou24
Daikyu
Messages : 63
Inscription : dim. 09 nov. 2008, 22:06

Re: [sddm/KDE] écran noir

Message par philou24 » mar. 01 mai 2018, 16:57

merci pour cette réponse.
J'avais vérifié: pas de sddm.conf.pacnew
Je viens de vérifier et mettre à jour les autres mais rien qui puisse améliorer la situation...

Oui, gros oubli : je n'utilise pas wayland (je m'étais posé la question mais je n'ai pas le paquet plasma-wayland-session d'installé, normalement nécessaire).

Sont quand même installés:

Code : Tout sélectionner

# pacman -Q | grep wayland
kwayland 5.45.0-1
kwayland-integration 5.12.4-1
lib32-wayland 1.14.0-1
nvidia-egl-wayland-beta 396.18-1
wayland 1.14.0-1
wayland-protocols 1.13-1
Ils sont en dépendance avec d'autres paquets, je peux supprimer : nvidia-egl-wayland-beta et lib32-wayland mais le problème reste le même...

edit: je viens d'essayer avec wayland : pareil, écran noir avec flèche de la souris

Code : Tout sélectionner

pacman -S plasma-wayland-session qt5-wayland xorg-server-xwayland

Avatar de l’utilisateur
papajoke
Elfe
Messages : 535
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [sddm/KDE] écran noir

Message par papajoke » mar. 01 mai 2018, 19:18

je viens de regarder le wiki, justement maintenant il n'y a plus le /etc/sddm.conf
c'est de cela que je te parlais dans "un changement de répertoires"
-------------------
écran noir ne veux pas dire que kde n'est pas lancé - tu as la même chose avec startx ? c'est peut-être la config plasma de ton $HOME...
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

philou24
Daikyu
Messages : 63
Inscription : dim. 09 nov. 2008, 22:06

Re: [sddm/KDE] écran noir

Message par philou24 » mar. 01 mai 2018, 20:57

Je viens de vérifier en supprimant mon /etc/sddm.conf puis en créant /etc/sddm.conf.d/sddm.conf mais cela ne change rien.

Le problème vient sûrement d'ailleurs puisque je ne peux pas lancer plasma (kde) avec lxdm (qui fonctionne et lance icewm, xfce, ...). J'aurais plutôt pensé à un problème de serveur graphique spécifique à sddm et kde ou un autre truc commun que je n'arrive pas à identifier.

jimarch
archer
Messages : 112
Inscription : mer. 26 déc. 2012, 20:38
Localisation : La Roche sur Yon - 85000

Re: [sddm/KDE] écran noir

Message par jimarch » mar. 01 mai 2018, 23:41

Bjr !
J'ai eu le même problème il y a quelque temps !
Voir la discussion ici sur le forum : viewtopic.php?f=1&t=19834

Pour moi, en supprimant le fichier ~/.local/share/kactivitymanagerd/resources/database
ou mieux, tout le répertoire "resources", tout est rentré dans l'ordre

Il n'y a pas de risque à supprimer ces fichiers ou répertoire.
Ils sont recréés automatiquement lors d'une nouvelle ouverture de session KDE
Tu perds seulement qq réglages si tu es en mode multi-activités sous KDE

Cdt
| Kde 4 | Notebook Clevo W740SU | Plateforme Intel Haswell avec Intel Core i7-4750HQ | Intel Iris Pro graphics 5200

benjarobin
Maître du Kyudo
Messages : 15406
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [sddm/KDE] écran noir

Message par benjarobin » mer. 02 mai 2018, 00:01

Je ne suis pas sûre de comprendre si c'est sddm ou KDE le problème ? Ce sont 2 choses complètement indépendantes.
Vois tu l'interface de login ? Ou le problème survient après le login depuis sddm ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

philou24
Daikyu
Messages : 63
Inscription : dim. 09 nov. 2008, 22:06

Re: [sddm/KDE] écran noir

Message par philou24 » mer. 02 mai 2018, 10:06

jimarch : merci pour cette réponse. Je ne suis pas chez moi, j'essaierai ce soir.

benjarobin :
  • pour sddm : écran noir,avec la flèche de la souris (mais lxdm fonctionne et permet de lancer icewm ou autre sauf kde/plasma)
  • pour kde : écran noir (sans démarrage possible par lxdm)

philou24
Daikyu
Messages : 63
Inscription : dim. 09 nov. 2008, 22:06

Re: [sddm/KDE] écran noir

Message par philou24 » mer. 02 mai 2018, 23:15

Bon, idem en supprimant .local et .kde4 (je suis un peu radical mais...je ne sais plus quoi faire)

En lançant sddm j'ai un écran noir avec un curseur qui bouge.
A ce moment là, avec "top" en console, j'ai "sddm-greeter" de lancé mais qui consomme 100% du cpu...

Au fait, au début, j'ai cru que pour une carte nvidia gtx 1050M le driver nvidia devait fonctionner mais j'ai été obligé de compiler les driver à partir d'aur, en béta, sinon je n'ai aucun affichage, même avec un "startx". C'est normal ?
Quel driver utilisez-vous si vous avez la même carte graphique ?

benjarobin
Maître du Kyudo
Messages : 15406
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [sddm/KDE] écran noir

Message par benjarobin » jeu. 03 mai 2018, 08:27

Non ce n'est absolument pas normal de devoir faire ceci....
Tu dois juste avoir les paquets nvidia, nvidia-settings, nvidia-utils.
Par contre il est ultra important d'utiliser le kernel officiel et d'être intégralement à jour
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Shade
Hankyu
Messages : 28
Inscription : sam. 31 mars 2018, 19:26

Re: [sddm/KDE] écran noir

Message par Shade » jeu. 03 mai 2018, 10:22

Bonjour,

Jsuis ptet completement hors sujet, mais ça me rappelle un problème que j'avais avec un ecran noir au demarrage, non cliquable droit, mais quand même fonctionnel. T'as essayé de voir si le fichier 10-monitor.conf est present dans /etc/X11/xorg.conf.d/ ? https://wiki.archlinux.org/index.php/Xo ... r_settings

Ptet qu'Xorg arrive pas a charger la resolution ?
Ryzen 5 2600@3.4Ghz | Asus B450-F | gtx960 4G | 16go ram @3000Mhz | Arch 4.19-1 - KDE

Répondre