[configuration] clavier / openbox (RESOLU)

Questions et astuces concernant l'installation et la configuration d'archlinux
hazote
Hankyu
Messages : 44
Inscription : dim. 22 juil. 2012, 23:38

[configuration] clavier / openbox (RESOLU)

Message par hazote » dim. 27 mai 2018, 14:40

Bonjour,
je viens d'installer arch sur mon nouveau dell inspiron 7577 (openbox)
lorsque je suis sur une console sous openbox, la touche alt-gr fonctionne comme "entrée", les flèches elles ne fonctionnent pas .

/etc/X11/xorg.conf.d/10-evdev.conf

Code : Tout sélectionner

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "fr"
        Option "XkbVariant" "latin9"
EndSection
que faire ?
Dernière modification par hazote le lun. 28 mai 2018, 21:44, modifié 2 fois.

Avatar de l’utilisateur
albireo
Chu Ko Nu
Messages : 421
Inscription : ven. 15 sept. 2006, 15:47
Localisation : vallée de la save en Occitanie

Re: [configuration] clavier / openbox

Message par albireo » dim. 27 mai 2018, 19:27

supprime ce fichier : etc/X11/xorg.conf.d/10-evdev.conf
et dans un terminal lance cette commande : localectl set-x11-keymap fr
Utilisateur ArchLinux depuis 2004
Arch 64/gnome sur ASUS H87M-E C2 + i5 3.2GHz + 8Go + 1To + écran 22"
Arch 64/openbox sur LDLC MERCURE ML3-4-S1 -> DAC Micromega -> ampli Onkyo -> enceintes Focal :D

hazote
Hankyu
Messages : 44
Inscription : dim. 22 juil. 2012, 23:38

Re: [configuration] clavier / openbox

Message par hazote » dim. 27 mai 2018, 21:07

albireo a écrit :
dim. 27 mai 2018, 19:27
supprime ce fichier : etc/X11/xorg.conf.d/10-evdev.conf
et dans un terminal lance cette commande : localectl set-x11-keymap fr
change rien
j'ai l'impression que c'est un problème de confrontation entre mon terminal (le systeme ?) qui est en anglais, et mon clavier en fr

ps: en tty aucuns soucis ...
correction sous openbox, en clavier us ca me donne le meme resultat

AlexxC
Hankyu
Messages : 28
Inscription : dim. 14 sept. 2014, 09:49

Re: [configuration] clavier / openbox

Message par AlexxC » lun. 28 mai 2018, 08:15

Salut.
Et avec un petit /etc/vconsole.conf qui contiendrai :

KEYMAP=fr-latin9
FONT=lat9w-16

Avatar de l’utilisateur
albireo
Chu Ko Nu
Messages : 421
Inscription : ven. 15 sept. 2006, 15:47
Localisation : vallée de la save en Occitanie

Re: [configuration] clavier / openbox

Message par albireo » lun. 28 mai 2018, 11:10

moi dans /etc/X11/xorg.conf.d je n'ai que le fichier 00-keyboard.conf qui contient ceci :
# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "fr"
EndSection
et que donne la commande dans un terminal X

Code : Tout sélectionner

setxkbmap fr
donnes aussi le resultat de

Code : Tout sélectionner

localectl status
Utilisateur ArchLinux depuis 2004
Arch 64/gnome sur ASUS H87M-E C2 + i5 3.2GHz + 8Go + 1To + écran 22"
Arch 64/openbox sur LDLC MERCURE ML3-4-S1 -> DAC Micromega -> ampli Onkyo -> enceintes Focal :D

hazote
Hankyu
Messages : 44
Inscription : dim. 22 juil. 2012, 23:38

Re: [configuration] clavier / openbox

Message par hazote » lun. 28 mai 2018, 13:10

AlexxC a écrit :
lun. 28 mai 2018, 08:15
Salut.
Et avec un petit /etc/vconsole.conf qui contiendrai :

KEYMAP=fr-latin9
FONT=lat9w-16
ne change rien
albireo a écrit :
lun. 28 mai 2018, 11:10
moi dans /etc/X11/xorg.conf.d je n'ai que le fichier 00-keyboard.conf qui contient ceci :
# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "fr"
EndSection
et que donne la commande dans un terminal X

Code : Tout sélectionner

setxkbmap fr
donnes aussi le resultat de

Code : Tout sélectionner

localectl status

Code : Tout sélectionner

setxkbmap fr
deja essayé, idem

Code : Tout sélectionner

localectl status
System Locale: LANG=fr_FR.utf8
			LANGUAGE=fr
			VC keymap: n/a
			X11 Model: fr-oss
			X11 Varaint: pc105
			X11 Options: latin9

avi3000
Chu Ko Nu
Messages : 344
Inscription : dim. 19 juin 2011, 18:53
Localisation : dans le neuf trois

Re: [configuration] clavier / openbox

Message par avi3000 » lun. 28 mai 2018, 16:06

hazote a écrit :
lun. 28 mai 2018, 13:10
AlexxC a écrit :
lun. 28 mai 2018, 08:15
Salut.
Et avec un petit /etc/vconsole.conf qui contiendrai :
KEYMAP=fr-latin9
FONT=lat9w-16
ne change rien
Le fichier /etc/vconsole.conf est pris en compte dans l'initrd.
Donc un mkinitcpio est obligatoire pour la prise en compte.
hazote a écrit :
lun. 28 mai 2018, 13:10

Code : Tout sélectionner

localectl status
System Locale: LANG=fr_FR.utf8
			LANGUAGE=fr
			VC keymap: n/a
			X11 Model: fr-oss
			X11 Varaint: pc105
			X11 Options: latin9
Après le mkinitcpio, tu devrais avoir VC keymap: fr-latin9

Tout ceci est indiqué dans le wiki d'installation français.

hazote
Hankyu
Messages : 44
Inscription : dim. 22 juil. 2012, 23:38

Re: [configuration] clavier / openbox

Message par hazote » lun. 28 mai 2018, 18:45

mon clavier fonctionne tres bien en tty, je prefere toucher seulement a X11

pour plus de precisions:
actuelement ALT-GR me renvoi ENTREE
SUPPR ne fonctionne pas
les fleches ne fonctionnent pas
insert ne semble pas fonctionner

edit: solution :

Code : Tout sélectionner

setxkbmap -print -verbose 10
me donnait:

Code : Tout sélectionner

....
rules: xorg
...
j'ai supprimé
/etc/X11/xorg.conf.d/10-evdev.conf
/etc/X11/xorg.conf.d/00-keyboard.conf

Code : Tout sélectionner

pacaur -S xkeyboard-config


fais un

Code : Tout sélectionner

 setxkbmap -model pc105 -layout fr -variant oss_latin9
remplacé dans /usr/share/X11/xorg.conf.d/10-evdev.conf

Code : Tout sélectionner

section "InputClass":
...
Option "XkbRules"  "xorg"
...
par

Code : Tout sélectionner

Option "XkbRules"  "evdev"
relancé la session et tout fonctionne !

Répondre