[Autostart] StartX (Résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
SupKurtJ
Chu Ko Nu
Messages : 309
Inscription : mer. 27 mai 2015, 09:37

[Autostart] StartX (Résolu)

Message par SupKurtJ » mer. 18 juil. 2018, 11:25

Bonjour,

Pour le fun j'aimerai me passer d'un gestionnaire de connexion.

Je voudrais juste avoir confirmation pour savoir si ma procédure est correct.

L'objectif est de lancer i3wm après m’être logué sur le tty.

Du coup je pense faire ceci :

~/.bash_profile

Code : Tout sélectionner

[[ $(tty) == '/dev/tty1' ]] && startx
~/.xinitrc

Code : Tout sélectionner

exec i3
Je pense que c'est bon et qu'on peut pas faire plus simple.

Merci pour votre retour.
Dernière édition par SupKurtJ le mer. 18 juil. 2018, 13:49, édité 1 fois.
Arch Linux x86_64
Intel Core i7-3770K @3.9GHz | nVidia GeForce 970 GTX | Asus Xonar D2/PM
▹ 16Go DDR3 @1600Mhz | SSD 750Go | SSD 275Go

Sup⋅Kurt⋅J

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15241
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Autostart] StartX

Message par benjarobin » mer. 18 juil. 2018, 13:27

Bonjour, oui cela me semble la bonne procédure... Un problème avec ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
SupKurtJ
Chu Ko Nu
Messages : 309
Inscription : mer. 27 mai 2015, 09:37

Re: [Autostart] StartX

Message par SupKurtJ » mer. 18 juil. 2018, 13:48

Non, aucun soucis.
Je voulais juste avoir confirmation qu'il n'existait pas autre chose de plus "simple".

Merci pour ta réponse en tout cas.
Arch Linux x86_64
Intel Core i7-3770K @3.9GHz | nVidia GeForce 970 GTX | Asus Xonar D2/PM
▹ 16Go DDR3 @1600Mhz | SSD 750Go | SSD 275Go

Sup⋅Kurt⋅J

Répondre