[Partitionnement] Montage et attribution des droits (RESOLU)

Questions et astuces concernant l'installation et la configuration d'archlinux
avi3000
Chu Ko Nu
Messages : 338
Inscription : dim. 19 juin 2011, 18:53
Localisation : dans le neuf trois

Re: [Partitionnement] Montage et attribution des droits

Message par avi3000 » lun. 23 juil. 2018, 17:20

eggregor a écrit :
lun. 23 juil. 2018, 17:13

Code : Tout sélectionner

# /dev/sdb1 LABEL=album
UUID="c28e548a-6ce0-4313-b228-cec863180939     /media/album     ext4            rw,relatime,discard,data-ordered      0 2
Les paris sont engagés, je lance le reboot en croisant les doigts.
1 milliard d'euros que ça ne fonctionne pas.
Lis attentivement les réponses et TON CODE.
D'ailleurs dans son propre fichier qu'a aimablement copié Waitensea, il utilise PARTUUID.
Je suis sûr que Mouette-Hennesy a mis les bons PARTUUID dans son fstab.
Tu n'as pas posté les PARTUUID de tes partitions, donc impossible de suivre ce que tu fais.

eggregor
archer
Messages : 140
Inscription : ven. 25 févr. 2011, 11:52

Re: [Partitionnement] Montage et attribution des droits

Message par eggregor » lun. 23 juil. 2018, 18:07

C'est vrai çà, je croyais que blkid avait été transmis, voilà la chose :

Code : Tout sélectionner

$ blkid
/dev/sda1: LABEL="BOOT" UUID="A8A2-A72C" TYPE="vfat" PARTLABEL="/boot/esp" PARTUUID="9e61ebca-eebd-4001-9ab0-0a91a8620fe8"
/dev/sda2: LABEL="/archlinux" UUID="81e1d6a6-e7a4-40af-9071-b6c30875b9d4" TYPE="ext4" PARTUUID="23a7d1b9-e630-4ab3-b089-c2b6bc7993a5"
/dev/sda3: LABEL="/home/archlinux" UUID="9e3c3f97-70ce-41e4-9c21-2bea530ee7e4" TYPE="ext4" PARTUUID="d19a2ae5-c049-411d-a902-997cbc5d0b08"
/dev/sdb1: LABEL="album" UUID="02914b62-7f1d-490b-bea3-5a21dbb19ec9" TYPE="ext4" PARTUUID="d6df9ed0-01"
/dev/sdb2: LABEL="backup" UUID="dae7e4f9-c1a9-43ff-b504-da2991a9f610" TYPE="ext4" PARTUUID="d6df9ed0-02"
Je rigole, parce qu'entre deux j'ai refait une nouvelle table de partition de /dev/sdb avec seulement deux partitions.

Code : Tout sélectionner

Je précise pour que tu dises pas que je suis un vrai rigolo qui ne sait pas faire un copié/collé.
A observer la taille vraiment réduite des PARTUUID par rapport au premier jet.

Si on pouvait être simplement concret sans se lancer dans un combat de coquelets inutile :

Quelles commandes exécuter pour que je puisse utiliser mes partitions et enfin copier mon stock de photos sur cette machine.
L'idéal d'ailleurs serait que tous les occupants habituels de la maison puissent y accéder librement, parce que je ne suis plus tout jeune et pas éternel.

Merci de tes efforts en tout cas.

avi3000
Chu Ko Nu
Messages : 338
Inscription : dim. 19 juin 2011, 18:53
Localisation : dans le neuf trois

Re: [Partitionnement] Montage et attribution des droits

Message par avi3000 » lun. 23 juil. 2018, 18:20

et le contenu du fstab correspondant ?
plus
/bin/ls -l /dev/disk/by-uuid/

Si tu modifies ton système entre 2 messages, ça va être compliqué de s'y retrouver.

eggregor
archer
Messages : 140
Inscription : ven. 25 févr. 2011, 11:52

Re: [Partitionnement] Montage et attribution des droits

Message par eggregor » lun. 23 juil. 2018, 18:42

On rentre dans le dur cette fois, c'est bien.

Code : Tout sélectionner

cat /etc/fstab
# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>
# /dev/sda2 LABEL=/archlinux
UUID=81e1d6a6-e7a4-40af-9071-b6c30875b9d4	/         	ext4      	rw,relatime,data=ordered	0 1

# /dev/sda3 LABEL=/home/archlinux
UUID=9e3c3f97-70ce-41e4-9c21-2bea530ee7e4	/home     	ext4      	rw,relatime,data=ordered	0 2

# /dev/sda1 LABEL=BOOT
UUID=A8A2-A72C      	/boot/efi 	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro	0 2
Je n'ai tenté aucune modification.
Au fait est-ce que ça marcherait de faire comme à l'installation un "genfstab -U -p >> /etc/fstab ?

Code : Tout sélectionner

 /bin/ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 23 juil. 17:50 02914b62-7f1d-490b-bea3-5a21dbb19ec9 -> ../../sdb1
lrwxrwxrwx 1 root root 10 23 juil. 17:50 81e1d6a6-e7a4-40af-9071-b6c30875b9d4 -> ../../sda2
lrwxrwxrwx 1 root root 10 23 juil. 17:50 9e3c3f97-70ce-41e4-9c21-2bea530ee7e4 -> ../../sda3
lrwxrwxrwx 1 root root 10 23 juil. 17:50 A8A2-A72C -> ../../sda1
lrwxrwxrwx 1 root root 10 23 juil. 17:50 dae7e4f9-c1a9-43ff-b504-da2991a9f610 -> ../../sdb2
J'ai changé le partitionnement parce que j'y pensais depuis un certain temps, même si ça n'apporte rien.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1944
Inscription : jeu. 15 mars 2012, 05:08

Re: [Partitionnement] Montage et attribution des droits

Message par waitnsea » lun. 23 juil. 2018, 19:28

eggregor a écrit :
lun. 23 juil. 2018, 17:06
D'ailleurs dans son propre fichier qu'a aimablement copié Waitensea, il utilise PARTUUID.

Code : Tout sélectionner

sudo blkid 
te donnera pour chaque disque l'UUID et la PARTUUID, et ce ne sera pas le même chiffre
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

eggregor
archer
Messages : 140
Inscription : ven. 25 févr. 2011, 11:52

Re: [Partitionnement] Montage et attribution des droits

Message par eggregor » lun. 23 juil. 2018, 19:51

Je suis bien d'accord que UUId et PARTUUID sont deux chiffres différents.

Et le wiki dit bien qu'on peut utiliser l'un ou l'autre.

Mon problème reste: comment faire pour que ce barrage des droits soit règlé ?

Pour le moment en dehors des généralités je n'ai pas avancé d'un pouce.
A demain peut-être ?

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15198
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Partitionnement] Montage et attribution des droits

Message par benjarobin » lun. 23 juil. 2018, 19:56

Ajoute ceci dans ton /etc/fstab

Code : Tout sélectionner

# /dev/sdb1 LABEL=album
UUID=02914b62-7f1d-490b-bea3-5a21dbb19ec9     /media/album     ext4            rw,relatime,discard,data-ordered      0 2
Tu dois créer un groupe de partage, tu peux le nommer public. Ou tu peux utiliser le groupe users qui existe déjà, dans ce cas remplace public par users par la suite

Code : Tout sélectionner

groupadd public
Puis tu dois ajouter tous les utilisateurs pouvant accéder à ce partage au groupe:

Code : Tout sélectionner

usermod -aG public nom-de-l-utilisateur
Puis réalise les commandes suivantes (en root):

Code : Tout sélectionner

mkdir -p /media/album
mount -a
chown root:public /media/album
chmod -R ug+rw /media/album
chmod g+s /media/album
setfacl -dm u::rwx,g::rwx,o::r /media/album
Tu n'as ensuite plus qu'à redémarrer
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

eggregor
archer
Messages : 140
Inscription : ven. 25 févr. 2011, 11:52

Re: [Partitionnement] Montage et attribution des droits

Message par eggregor » mar. 24 juil. 2018, 08:49

Merci benjarobin, on retrouve la patte du Maître du Kyudo, c'est clair et je suis sûr que ça va me sauver.
Je repasse donc après les opérations.

EDIT :

Code : Tout sélectionner

# mkdir -p /media/album
# mount -a
mount: /media/album : mauvais type de système de fichiers, option erronée, superbloc erroné sur /dev/sdb1, page de code ou programme auxiliaire manquant, ou autre erreur.
Dès lors le clic sur l'icone "album" qui apparaît sur le bureau (et dans thunar), renvoie un message d'erreur Impossible de monter "album",
tandis que l'icone "backup" pour lequel je n'ai pas recréé de point de montage, se monte toujours par clic droit + monter le volume sur /run/media/eggregor/backup/, qui s'est mis en place automùatiquement.

Je tente un rmdir /media/album, qui redonne la réponse suivante à mount -a

Code : Tout sélectionner

Impossible de monter "album"
Error mounting system-managed device /dev/sdb1: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error
EDIT2 :
Ballot, il manque la ligne

Code : Tout sélectionner

mount -t ext4 /dev/sdb1 /media/album
Et tout baigne, la suite passe sans erreur, ça va être l'heure de vérité => REBOOT

EDIT3 :
Acte 1 -> blocage du lancement, je dois dépasser mes compétences et chercher => c'est l'option "data ordered" qui est cause du problème.
Je la supprime en tty et # systemctl reboot, fait effectivement démarrer la machine.

Essai aussitôt d'une copie de fichier photos depuis une clé usb et c'est parfait !!!

Merci benjarobin, une fois de plus tu m'as sauvé de la noyade avec des commandes qu'on ne trouve pas facilement.
Je vais appliquer la méthode à la partition backup en me gardant l'accès exclusif.

Répondre