Page 1 sur 1

[fin installation] besoin d'aide [Résolu]

Publié : jeu. 04 oct. 2018, 16:49
par Luzu
Bonjour à tous,

J'ai réussi à installer archlinux Plasma, bureau minimal.
Cependant, je me rends compte qu'il me manque des choses comme :
- octopi et ou yaourt ?,
- l'icone de networkmanager dans le systray, du son et j'ai pas de son,
- le dépot AUR ??
- je ne peux pas ouvrir des .conf. je fais sudo kate /etc/pacman.conf, erreur,
Si quelqu'un voulait bien me guider et m'aider à résoudre ces soucis.
Merci beaucoup

Re: [fin installation] besoin d'aide

Publié : jeu. 04 oct. 2018, 17:42
par floflo77890
Salut,

alors les 3/4 des chose que tu demandes sont dans le wiki. Concernant le AUR tu pourras installer des paquets depuis ce dépôts via yaourt. Pour le gestionnaire de son tu as alsamixer mais il te faut l'installer, pareille une page dans le wiki te dis comment faire. Pour la dernière partie de message sans message d'erreur on ne pourras pas t'aider correctement.

Pour yaourt : yaourt
pour alsamixer : alsa
pour networkmanager utilise le GTK : networkmanager

Il faut savoir qu' une installation d' arch est minimaliste, en gros tu installes une base mais tu construis toi même ton système. Si tu veux du son il te faut un gestionnaire de son, dans ce cas le wiki est vraiment bien renseigné. Pour être honnête quand tu mentionnes yaourt et AUR si tu avais juste ouvert la page principal du wiki tu aurais tout de suite vu qu'ils étaient mentionnés dessus, et surtout la phrase
Yaourt qui permet également de gérer le dépôt AUR
.

Ps: une autre façon d'installer yaourt consiste à modifier le /etc/pacman.conf (avec nano ou vi vu que kate ne fonctionne pas) et d'y ajouter ceci :

Code : Tout sélectionner

[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/$arch
puis de lancer un pacman -Sy yaourt.

Re: [fin installation] besoin d'aide

Publié : jeu. 04 oct. 2018, 18:36
par FoolEcho
floflo77890 a écrit :
jeu. 04 oct. 2018, 17:42
Ps: une autre façon d'installer yaourt consiste à modifier le /etc/pacman.conf (avec nano ou vi vu que kate ne fonctionne pas) et d'y ajouter ceci :

Code : Tout sélectionner

[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/$arch
puis de lancer un pacman -Sy yaourt.
Plus maintenant car les mises à jour de package-query étaient souvent problématiques. https://wiki.archlinux.fr/Yaourt#Installation

Re: [fin installation] besoin d'aide

Publié : jeu. 04 oct. 2018, 18:40
par papajoke
bonjour et bienvenue,

- grillé: tout helper aur s'installe au moins pour la première fois comme indiqué dans le wiki à base de git et makepkg
- kate: ne supporte pas sudo mais il a une action automatique polkit pour sauvegarder - mais si tu es sous archlinux c'est que tu es un aficionados de la console , autant utiliser nano ou vi ...

Re: [fin installation] besoin d'aide

Publié : jeu. 04 oct. 2018, 20:43
par floflo77890
@FoolEcho : c'est bien ce que je pensais j'avais le petit doute mais je ne sais pas pourquoi j'était persuadé que cela était encore possible. Je vais modifier mon message. Après la méthode indiqué dans le wiki n'est pas difficile à comprendre il suffit de la suivre et le tour est joué.

Re: [fin installation] besoin d'aide

Publié : dim. 07 oct. 2018, 08:24
par Luzu
Bonjour et merci pour vos réponses et les liens,

J'ai réussi à régler la majorité des mes soucis grâce à vous.
Je me suis attaqué à l'installation de octopi de cette manière (sans les tirets) :

Code : Tout sélectionner

- yaourt -G octopi
- cd octopi/
- makepkg -s
Mais j'ai une erreur :

Code : Tout sélectionner

erreur : impossible de trouver la cible : alpm_octopi_utils
==> ERREUR : « pacman » n’a pas pu installer les dépendances manquantes.
J'ai donc bêtement fait :

Code : Tout sélectionner

sudo pacman -S alpm_octopi_utils
Mais j'ai une erreur :

Code : Tout sélectionner

erreur : impossible de trouver la cible : alpm_octopi_utils
Puis tapé :

Code : Tout sélectionner

sudo pacman -S alpm-octopi-utils
erreur : impossible de trouver la cible : alpm-octopi-utils
vala est installé.

J'ai ensuite trouvé et télécharger le paquet alpm_octopi_utils.zip que j'ai décompressé.
Là je suis bloqué, car je ne sais pas comment ou quoi faire pour l'installer.
Quelle est la commande ?

Merci pour votre patience avec mon lent cerveau.

Re: [fin installation] besoin d'aide

Publié : dim. 07 oct. 2018, 09:08
par FoolEcho
Luzu a écrit :
dim. 07 oct. 2018, 08:24
J'ai réussi à régler la majorité des mes soucis grâce à vous.
Je me suis attaqué à l'installation de octopi de cette manière (sans les tirets) :

Code : Tout sélectionner

- yaourt -G octopi
- cd octopi/
- makepkg -s
De cette manière il manque les dépendances venant d'AUR.
Tu as yaourt d'installé, donc juste à faire:

Code : Tout sélectionner

yaourt -S octopi

Re: [fin installation] besoin d'aide

Publié : dim. 07 oct. 2018, 09:18
par Luzu
FoolEcho a écrit :
dim. 07 oct. 2018, 09:08

De cette manière il manque les dépendances venant d'AUR.
Tu as yaourt d'installé, donc juste à faire:

Code : Tout sélectionner

yaourt -S octopi
J'ai fait, mais erreur :

Code : Tout sélectionner

yaourt -S octopi

==> Téléchargement du PKGBUILD de octopi depuis AUR...
x .SRCINFO
x PKGBUILD
x enable-kstatus.patch
x octopi-repoeditor.desktop
windy commented on 2018-06-10 09:04                      

kikadf commented on 2018-06-10 09:46                     

allevil669 commented on 2018-06-13 17:03                         

kikadf commented on 2018-06-13 17:53                     

egrupled commented on 2018-07-10 16:19                   

octopi 0.9.0-1  (2018-09-25 13:46)
( Paquet non supporté : peut être dangereux ! )   [b]ATTENTION cette ligne clignote[/b]  
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> 

Re: [fin installation] besoin d'aide

Publié : dim. 07 oct. 2018, 11:01
par onyx67
Il n'y a aucune erreur, tu aura toujours ce message d'avertissement lorsque tu installes un paquet aur avec yaourt. Ensuite, la question posée est si tu veux édité le PKGBUILD, tu fais non (à moins que tu veuilles faire des modif particulières) et poursuit l'installation en répondant aux questions.

Re: [fin installation] besoin d'aide

Publié : dim. 07 oct. 2018, 11:28
par Luzu
onyx67 a écrit :
dim. 07 oct. 2018, 11:01
Il n'y a aucune erreur, tu aura toujours ce message d'avertissement lorsque tu installes un paquet aur avec yaourt. Ensuite, la question posée est si tu veux édité le PKGBUILD, tu fais non (à moins que tu veuilles faire des modif particulières) et poursuit l'installation en répondant aux questions.
Et bien, ça fonctionne, grand merci.
J'ai appris un truc nouveau.