[boot] Systemd-boot ne trouve pas iud[résolu]

Questions et astuces concernant l'installation et la configuration d'archlinux
celp
Hankyu
Messages : 14
Inscription : mar. 14 août 2018, 11:57

[boot] Systemd-boot ne trouve pas iud[résolu]

Message par celp » mer. 24 oct. 2018, 10:16

Bonjour,

Je n'arrive pas à booter depuis que j'ai changer de grub à systemd-boot

je me suis basé sur les urls (guide) suivant :

https://wiki.archlinux.org/index.php/Systemd-boot
https://wiki.archlinux.org/index.php/EF ... _partition

Mon systeme ne trouve pas la partition raçine par contre j'arrive à booter sur le systeme uefi.

voici les commandes tapés.
* J'ai suivi ce conseil "mount ESP to /boot."
* bootctl --path=esp install
* a etait creer /boot/loader/loader.conf
* a était boot/loader/entries/arch.conf avec iud

et la je bloque.

J'ai essayé avec archanywhere ça fonctionne donc ça vient pas d'un firmware mais le soucis c'est qu'il utilise par le truc du /boot. donc je ne comprend pas.
Et le wiki https://wiki.archlinux.fr/ESP#Montage_de_l.27ESP me semble pas à jour.

Pouvez vous m'aider.
Dernière modification par celp le mer. 24 oct. 2018, 13:54, modifié 1 fois.

celp
Hankyu
Messages : 14
Inscription : mar. 14 août 2018, 11:57

Re: [boot] Systemd-boot ne trouve pas iud

Message par celp » mer. 24 oct. 2018, 13:53

Résolu.
j'ai confondu systemd-boot avec efibootmgr

tout est ok

benjarobin
Maître du Kyudo
Messages : 15537
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [boot] Systemd-boot ne trouve pas iud

Message par benjarobin » mer. 24 oct. 2018, 13:58

Bonjour,
Depuis un liveCd peux tu donner le contenu de :

Code : Tout sélectionner

gdisk -l /dev/sda
blkid
Sans la partition ESP de monté, le contenu du dossier boot, et avec la partition ESP de monté le contenu de ce même dossier ?
Le contenu de ..esp../loader/entries/arch.conf
Donc en supposant que sda1 est la partition ESP, et sda2 est la partition racine, il faut donner la sortie de :

Code : Tout sélectionner

mount /dev/sda2 /mnt
ls -l /mnt/boot
cat /mnt/boot/loader/entries/arch.conf
mount /dev/sda1 /mnt/boot
ls -l /mnt/boot
cat /mnt/boot/loader/entries/arch.conf
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre