[Xorg] failed to start load kernel module

Questions et astuces concernant l'installation et la configuration d'archlinux
-fab1en-
Daikyu
Messages : 78
Inscription : lun. 27 févr. 2017, 16:45

[Xorg] failed to start load kernel module

Message par -fab1en- » sam. 26 janv. 2019, 17:04

Bonjour,

pacman -Syu VirtualBox a mis un peu de désordre dans mon PC .

systemd-modules-load.service échouait. Supprimer virtualbox a réglé le problème.

Mais Xorg ne démarre pas : NVIDIA failed to start load kernel module.

J'ai googeler autant que possible.

Je pense avoir trouvé un truc:

Code : Tout sélectionner

find /lib/modules/ -type f | pacman -Qoq - | sort -u
....ne me donne rien, la sortie est : aucun fichier ne contient /home/user

J'au tout réinstallé, kernel, headers (les), rien n'y fait.

Et là je ne sais plus quoi faire.

Je voudrais bien un coup de pouce, s'il vous plait :D
Dernière modification par -fab1en- le sam. 26 janv. 2019, 18:32, modifié 1 fois.

avi3000
Chu Ko Nu
Messages : 344
Inscription : dim. 19 juin 2011, 18:53
Localisation : dans le neuf trois

Re: [Xorg] failed to start load kernel module

Message par avi3000 » sam. 26 janv. 2019, 18:20

Bonsoir

2 erreurs de saisie sur la fin de ligne

-fab1en-
Daikyu
Messages : 78
Inscription : lun. 27 févr. 2017, 16:45

Re: [Xorg] NVIDIA: failed to initialize the NVIDIA kernel module

Message par -fab1en- » mar. 29 janv. 2019, 09:20

J'avais rédigé ce post de mémoire, du coup des erreurs s'y sont glissées.

j'ai corrigé le titre et je corrige la sorite de

Code : Tout sélectionner

 $ find /lib/modules/ -type f | pacman -Qoq - | sort -u

erreur: aucun paquet ne contient /home/user
J'ai des lignes comme celle-là dans

Code : Tout sélectionner

$ journalctl
nvidia disagrees about version of symbol module_layout
j'ai le kernel 4.19.17-1-lts et le driver nvidia-lts 1:415.27-1

Je vais essayer ca :
https://bbs.archlinux.org/viewtopic.php?id=240520

Répondre