Page 1 sur 2

[UEFI] le système ne démarre pas [Résolu]

Publié : lun. 28 janv. 2019, 22:03
par sukolyn
Bonjour,

UEFI, encore un de plus. ;)

j'ai suivi le wiki pour installer ArchLinux sur un Dell OptiPlex790 en UEFI, mais sans succès pour l'instant !

si je ne demande rien au PC, il me dit qu'il ne trouve pas de médias "démarrable" (No bootable devices), et si je lui indique via F12 de démarrer en UEFI, il reste sur un écran noir. :(

je vous passe les informations qui me semblent pertinentes pour vous permettre de m'aider à résoudre ce problème.
le partitionnement :

Code : Tout sélectionner

# gdisk -l /dev/sda # /!\ extrait
Partition table scan:
  MBR: protective
  GPT: present
Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048         1050623   512.0 MiB   EF00  EFI System
   2         1050624        13633535   6.0 GiB     8200  Linux swap
   3        13633536      3519069838   1.6 TiB     8300  Linux filesystem
le montage des partitions :

Code : Tout sélectionner

# mount -t ext4,vfat
/dev/sda3 on /mnt type ext4 (rw,relatime)
/dev/sda1 on /mnt/efi type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
les informations EFI :

Code : Tout sélectionner

# efibootmgr -v
BootCurrent: 0008
Timeout: 1 seconds
BootOrder: 0000,0004,0003,0005,0007,0002,0008
Boot0000  Diskette Drive        BBS(Floppy,,0x0)
Boot0001* Onboard NIC   BBS(Network,,0x0)
Boot0002* archlinux_on_uefi     HD(1,GPT,2f0c4c3e-1015-4505-8705-caadd65b0f7d,0x800,0x100000)/File(\EFI\archlinux_on_uefi\grubx64.efi)                                                                                                                                   
Boot0003* USB Storage Device    BBS(USB,,0x0)USB Storage Device.
Boot0004* CD/DVD/CD-RW Drive    BBS(CDROM,,0x0)P1: HL-DT-ST DVD+/-RW GH70N   .
Boot0005  Onboard NIC   BBS(Network,,0x0)
Boot0007* P0: ST4000VN000-1H4168        BBS(HD,,0x0)P0: ST4000VN000-1H4168        .
Boot0008  UEFI: INT13(USB,0x80) PciRoot(0x0)/Pci(0x1d,0x0)/VenHw(aa7ba38a-dabf-40c3-8d18-b55b39609ef7,8001000000005553422020202020ffffffffffffffffffffffffffffffffffffffffffffffff)/HD(1,MBR,0xd7a8182,0xa4,0x20000)
les attributs du disque :

Code : Tout sélectionner

# blkid /dev/sda* 
/dev/sda: PTUUID="48589d0c-6ddf-4073-be8b-8d575ce60715" PTTYPE="gpt"
/dev/sda1: LABEL_FATBOOT="EFI" LABEL="EFI" UUID="11B3-F298" TYPE="vfat" PARTLABEL="EFI System" PARTUUID="2f0c4c3e-1015-4505-8705-caadd65b0f7d"
/dev/sda2: UUID="a363f44f-7f04-4521-8dfa-1cb922dd8926" TYPE="swap" PARTLABEL="Linux swap" PARTUUID="9363037e-0f99-4815-bbb9-db3377dcb973"
/dev/sda3: LABEL="racine" UUID="0d4dc1d7-cf19-44cf-ad84-3cb1a9c546e7" TYPE="ext4" PARTLABEL="Linux filesystem" PARTUUID="4339952b-2df3-45fb-a855-75bfc8c34a4b"
et enfin, la commande d'installation du chargeur de démarrage :

Code : Tout sélectionner

# grub-install --no-floppy --recheck  --target=x86_64-efi --bootloader-id=archlinux_on_uefi --efi-directory=/efi
vous voyez quelque chose qui m'échappe ?
vous avez besoin d'autres informations pour confirmer une hypothèse ?

Re: [UEFI] le système ne démarre pas

Publié : mar. 29 janv. 2019, 01:30
par benjarobin
Bonjour,
Sur le papier cela devrait fonctionner (bug du firmware de la carte mère ?).
As tu bien désactivé le secure boot ?
Essaye de copier "\EFI\archlinux_on_uefi\grubx64.efi" dans "\EFI\BOOT\BOOTx64.EFI"

Re: [UEFI] le système ne démarre pas

Publié : mar. 29 janv. 2019, 16:22
par RoyalPanda
Bonjour,

Ou juste renommer le grubx64.efi vers bootx64.efi. Certain firmware n'honore pas le nom de fichier, mais les dossiers si :)

Re: [UEFI] le système ne démarre pas

Publié : mar. 29 janv. 2019, 20:14
par sukolyn
merci pour vos réponses.

j'ai fait une installation de Debian 9.0 en UEFI. elle a bien démarré.

Code : Tout sélectionner

root@debian:~# ls -R /boot/efi/
/boot/efi/:
EFI

/boot/efi/EFI:
debian

/boot/efi/EFI/debian:
grubx64.efi
je ne trouve pas d'option "secure boot".

Re: [UEFI] le système ne démarre pas

Publié : mar. 29 janv. 2019, 21:23
par JuanicoV
Salut,

J'utilise pas Uefi mais c'est normal de monter la partition EFI directement dans le répertoire /efi?

Code : Tout sélectionner

/dev/sda1 on /mnt/efi type vfat 
ça ne devrait pas être dans /mnt/boot/efi

bref t'es sur d'avoir fait le bon montage de partition lors de l’installation et la configuration de grub?

Re: [UEFI] le système ne démarre pas

Publié : mar. 29 janv. 2019, 21:58
par sukolyn
tant que l'efi-directory est cohérent, ça devrait ne pas poser de problème.

EDIT: j'ai renommé grubx64.efi vers bootx64.efi, sans effet.

EDIT2:
je ne sais pas quoi faire.
je me plante quelque part, puisque l'installation fonctionne avec Debian...
mais où ?

je vous affiche les commandes que j'utilise :

Code : Tout sélectionner

swapSize=$(LC_NUMERIC=C free --si -h | sed -n '/^Mem:/s/Mem:[[:blank:]]\+\([^[:blank:]]*\).*/\1/p')
sw=$((swap=${swapSize%%[[:punct:][:alpha:]]*},swap<6?swap*2:swap))${swapSize: -1}

parted -s -a optimal /dev/$selDisk \
mklabel gpt \
mkpart primary 0% 550M \
mkpart primary 550M $sw \
mkpart primary $sw 100% \
set 1 esp on \
print

mkfs.fat -F32 -n 'EFI' /dev/${selDisk}$((++partNb))
mkswap /dev/${selDisk}$((++partNb))
swapon /dev/${selDisk}$partNb
mkfs.ext4 -F -L 'root' /dev/${selDisk}$((++partNb))

mount /dev/${selDisk}$((partNb--)) /mnt
mkdir -p /mnt/{efi,home}
mount /dev/${selDisk}$((--partNb)) /mnt/efi
puis dans le chroot :

Code : Tout sélectionner

mkinitcpio -p linux # je viens de voir que ce n'est pas utile parce que fait plus tôt par pacstrap

sed -i 's/#\(GRUB_TERMINAL.*\)/\1/' /etc/default/grub
grub-mkconfig -o /boot/grub/grub.cfg
grub-install --target=x86_64-efi --efi-directory=/efi --bootloader-id=grub_uefi --no-floppy --recheck

Re: [UEFI] le système ne démarre pas

Publié : mer. 30 janv. 2019, 19:30
par JuanicoV
Je ne sais pas si cela à un impact mais tu configures grub-mkconfig avant de l'installer grub-install.

Re: [UEFI] le système ne démarre pas

Publié : mer. 30 janv. 2019, 19:54
par sukolyn
ça ne pose pas de problème pour une installation legacy.

par acquis de conscience, j'ai inversé, mais ça ne change rien.

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 14:13
par celp
Bonjour

Pour ma part j'ai installé en efi hier sur une nouvelle machine.

la partition efi se monte dans /boot
J'ai suivi cette documentation https://wiki.archlinux.org/index.php/EFISTUB.

ça a marché du premier coup.

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 14:47
par benjarobin
Le point de montage de la partition ESP n'a aucune importance pour un bon fonctionnement de Grub.
Après le bon démarrage du kernel, si c'est mal fait cela peut poser problème. Sauf qu'ici si je comprends bien Grub ne se lance même pas...

Et je pense que c'est bine un problème de secureboot... Il y a forcément une option dans le firmware/BIOS de la carte mère

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 15:24
par celp
Ha ok
je ne me sert pas de grub.
Je boot directement.

Il y a une video https://www.youtube.com/watch?reload=9&v=LCHIJPrD04w
elle explique comment désactiver le secure boot

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 16:15
par sukolyn
benjarobin a écrit :ci si je comprends bien Grub ne se lance même pas
exactement. j'ai le POST, puis l'écran reste "noir".
benjarobin a écrit :Et je pense que c'est bien un problème de secureboot...
mais Debian démarrerait quand même ?

je vais tester EFISTUB, et je reviens...

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 16:21
par celp
si c'est efistub je peut t'aider. je l'ai fais hier.

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 17:35
par benjarobin
Debian utilise très certainement un bootloader signé, qui passe le secureboot.
Le CD d'installation d'Arch possède de mémoire un bootloader signé, qui passe le secureboot.

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 17:44
par sukolyn
j'ai installé en suivant le wiki.

il y a un "mieux" : je n'atterris plus sur l'écran "No boot devices...", mais l'écran reste noir, et la combinaison de touches pour redémarrer (Ctrl-Alt-Suppr) est sans effet.

quant au secure boot, il n'y a pas d'option; dans le setup, on passe de Security à Performance. pas de "secure boot". :/

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 20:03
par laurent85
Bonjour,
Vérifie l'état de SB avec :

Code : Tout sélectionner

bootctl status

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 20:32
par sukolyn
ah, c'est intéressant :

Code : Tout sélectionner

[root@archiso /]# bootctl status
systemd-boot not installed in ESP.
No default/fallback boot loader installed in ESP.
System:
     Firmware: UEFI 2.00 (American Megatrends 4.632)
  Secure Boot: disabled
   Setup Mode: user

Current Boot Loader:
      Product: systemd-boot 239
     Features: ✗ Boot counting
               ✓ Menu timeout control
               ✗ One-shot menu timeout control
               ✓ Default entry control
               ✓ One-shot entry control
          ESP: n/a
         File: └─/EFI/BOOT/loader.efi

Available Boot Loaders on ESP:
          ESP: /boot (/dev/disk/by-partuuid/9972d935-6f48-406c-b2de-0df5f1c6ca38)

Boot Loaders Listed in EFI Variables:
        Title: Arch Linux
           ID: 0x0000
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/9972d935-6f48-406c-b2de-0df5f1c6ca38
         File: └─/vmlinuz-linux

        Title: Arch Linux
           ID: 0x0002
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/9972d935-6f48-406c-b2de-0df5f1c6ca38
         File: └─/vmlinuz-linux

0 entries, no entry could be determined as default.
le SecureBoot est donc bien désactivé.

pour info, voici la commande que j'ai utilisée :

Code : Tout sélectionner

[root@archiso /]# eval $(blkid -o export /dev/sda1)
[root@archiso /]# echo $PARTUUID 
9972d935-6f48-406c-b2de-0df5f1c6ca38
# efibootmgr --disk /dev/sda --part 1 --create --label "Arch Linux" --loader /vmlinuz-linux --unicode 'root=PARTUUID='"$PARTUUID"' rw initrd=\initramfs-linux.img' --verbose
je me suis trompé ?

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 21:20
par laurent85
Je ne sais pas mais je vérifierais la disponibilité d'une mise à jour du bios.

J'essaierais aussi de démarrer sur une clé usb rEFInd, et si ça marche de l'utiliser comme gestionnaire de démarrage. Installé en mode "fallback" en lieu et place de bootx64.efi il peut charger le menu grub ou directement lancer le système. Si ça t'intéresse je t'expliquerai.
http://www.rodsbooks.com/refind/getting.html

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 21:44
par sukolyn
bon, on avance.
j'ai installé refind-efi, et exécuté le script

Code : Tout sélectionner

refind-install --usedefault /dev/sda1
.
le joli écran de rEFInd s'affiche, et... patatra (j'ai dû oublié quelque chose)

Code : Tout sélectionner

ERROR: device '' not found.
"blabla"
you're now being dropped into an emergency shell.
sh: blablabla

Re: [UEFI] le système ne démarre pas

Publié : jeu. 31 janv. 2019, 22:19
par laurent85
Pour avancer installe grub comme tu l'avais fait au début, tu verras la config pour lancer le système directement depuis rEFInd plus tard. Ensuite redémarre, si grub ne se charge toujours pas c'est rEFInd qui prendra la main mais tu devrais pouvoir charger le menu grub depuis rEFInd, et là ça doit marcher.