Page 1 sur 1

[Mise à Jour] Cryptomator ne démarre plus

Publié : mar. 02 avr. 2019, 13:34
par bowmore
Bonjour à toutes et tous,

Suite à une mise à jour , je me suis rendu compte que cryptomator ne démarre plus.
Pour ceux qui ne connaissent pas, cryptomator est un système qui chiffre nos données avant de les stocker dans un service cloud.
Comme cryptomator est multiplateformes, je peux récupérer mes données de n'importe où, avec n'importe quel PC. Bien pratique.
Bref...

Si je lance cryptomator dans un terminal, voici le retour:

Code : Tout sélectionner

$ cryptomator
13:28:02.804 [main] DEBUG org.cryptomator.common.Environment - user.language: fr
13:28:02.810 [main] DEBUG org.cryptomator.common.Environment - user.region: null
13:28:02.810 [main] DEBUG org.cryptomator.common.Environment - logback.configurationFile: null
13:28:02.810 [main] DEBUG org.cryptomator.common.Environment - cryptomator.settingsPath: ~/.config/Cryptomator/settings.json:~/.Cryptomator/settings.json
13:28:02.810 [main] DEBUG org.cryptomator.common.Environment - cryptomator.ipcPortPath: ~/.config/Cryptomator/ipcPort.bin:~/.Cryptomator/ipcPort.bin
13:28:02.810 [main] DEBUG org.cryptomator.common.Environment - cryptomator.keychainPath: null
13:28:02.810 [main] DEBUG org.cryptomator.common.Environment - cryptomator.logDir: ~/.local/share/Cryptomator/logs
13:28:02.810 [main] DEBUG org.cryptomator.common.Environment - cryptomator.mountPointsDir: ~/.local/share/Cryptomator/mnt
13:28:03.161 [main] DEBUG org.cryptomator.common.settings.SettingsProvider - Attempting to load settings from /home/bowmore/.config/Cryptomator/settings.json
13:28:03.167 [main] DEBUG org.cryptomator.common.settings.SettingsProvider - Attempting to load settings from /home/bowmore/.Cryptomator/settings.json
13:28:03.293 [main] INFO org.cryptomator.common.settings.SettingsProvider - Settings loaded from /home/bowmore/.Cryptomator/settings.json

(cryptomator:5986): Gtk-WARNING **: 13:28:04.138: Theme parsing error: gtk.css:151:54: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.138: Theme parsing error: gtk.css:173:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.138: Theme parsing error: gtk.css:179:71: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.138: Theme parsing error: gtk.css:183:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.139: Theme parsing error: gtk.css:188:58: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.139: Theme parsing error: gtk.css:196:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.139: Theme parsing error: gtk.css:201:58: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.139: Theme parsing error: gtk.css:209:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.139: Theme parsing error: gtk.css:214:58: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.139: Theme parsing error: gtk.css:225:74: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.139: Theme parsing error: gtk.css:232:58: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.139: Theme parsing error: gtk.css:235:75: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.141: Theme parsing error: gtk.css:1050:66: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.141: Theme parsing error: gtk.css:1064:71: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.141: Theme parsing error: gtk.css:1073:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.141: Theme parsing error: gtk.css:1079:73: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.141: Theme parsing error: gtk.css:1090:73: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.141: Theme parsing error: gtk.css:1093:58: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.141: Theme parsing error: gtk.css:1100:73: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.142: Theme parsing error: gtk.css:1103:58: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.143: Theme parsing error: gtk.css:1326:71: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.143: Theme parsing error: gtk.css:1333:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.143: Theme parsing error: gtk.css:1337:73: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.143: Theme parsing error: gtk.css:1454:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.143: Theme parsing error: gtk.css:1458:58: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.143: Theme parsing error: gtk.css:1461:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.144: Theme parsing error: gtk.css:1857:9: Not using units is deprecated. Assuming 'px'.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.144: Theme parsing error: gtk.css:1857:9: Expected a string.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.146: Theme parsing error: gtk.css:2624:53: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.146: Theme parsing error: gtk.css:2654:51: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.146: Theme parsing error: gtk.css:2657:53: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.146: Theme parsing error: gtk.css:2662:53: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.146: Theme parsing error: gtk.css:2662:87: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.147: Theme parsing error: gtk.css:2907:8: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.147: Theme parsing error: gtk.css:2907:17: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(cryptomator:5986): Gtk-WARNING **: 13:28:04.148: Theme parsing error: gtk.css:3182:54: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.148: Theme parsing error: gtk.css:3496:71: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.148: Theme parsing error: gtk.css:3503:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.148: Theme parsing error: gtk.css:3506:73: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.148: Theme parsing error: gtk.css:3514:52: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3586:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3593:71: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3597:54: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3608:54: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3801:8: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3801:20: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3821:54: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3832:8: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3832:22: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3835:8: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3835:28: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3838:8: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3838:22: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3855:12: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3855:12: Expected a string.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3861:14: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.149: Theme parsing error: gtk.css:3861:14: Expected a string.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3867:16: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3867:16: Expected a string.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3872:14: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3872:14: Expected a string.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3939:12: Expected a string.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3941:16: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3941:16: Expected a string.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3987:12: not a number

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3987:12: Expected a string.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3990:66: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.150: Theme parsing error: gtk.css:3993:66: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.151: Theme parsing error: gtk.css:4156:72: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.151: Theme parsing error: gtk.css:4163:56: Using one color stop with linear-gradient() is deprecated.

(cryptomator:5986): Gtk-WARNING **: 13:28:04.151: Theme parsing error: gtk.css:4166:73: Using one color stop with linear-gradient() is deprecated.
13:28:04.259 [main] INFO org.cryptomator.launcher.FileOpenRequestHandler - Unable to setOpenFileHandler, probably not supported on this OS.
13:28:04.287 [main] INFO  org.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.4.6 on Linux 5.0.5-arch1-1-ARCH (amd64)
13:28:04.631 [main] INFO  o.c.launcher.IpcProtocolImpl - Received launch args: 
13:28:04.648 [main] DEBUG org.cryptomator.logging.DebugMode - Debug mode enabled

(cryptomator:5986): Gdk-CRITICAL **: 13:28:05.171: gdk_x11_display_set_window_scale: assertion 'GDK_IS_X11_DISPLAY (display)' failed
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007ffa32d8b7db, pid=5986, tid=6025
#
# JRE version: OpenJDK Runtime Environment (11.0.2+9) (build 11.0.2+9)
# Java VM: OpenJDK 64-Bit Server VM (11.0.2+9, mixed mode, tiered, compressed oops, g1 gc, linux-amd64)
# Problematic frame:
# C  [libX11.so.6+0x2b7db]
#
# Core dump will be written. Default location: Core dumps may be processed with "/usr/lib/systemd/systemd-coredump %P %u %g %s %t %c %h %e" (or dumping to /tmp/.mount_cryptoPXMknU/app/core.5986)
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid5986.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Abandon (core dumped)
A priori, il y a plusieurs problèmes, mais celui qui semble le plus gènant est lié à Java, ou openJDK.
Mais là, je sèche...

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : mar. 02 avr. 2019, 20:17
par benjarobin
Bonjour,
Le premier lien de la recherche du message d'erreur me donne : https://bugs.openjdk.java.net/browse/JDK-8215104

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : mer. 03 avr. 2019, 08:52
par bowmore
Bonjour,

Oui, j'ai vu aussi cette page, mais franchement, pour moi, c'est du chinois traduit en anglais... :?
J'ai vu aussi cette discussion sur Github => https://github.com/javafxports/openjdk- ... -417030981, mais je ne comprends pas ce qu'il faut faire pour résoudre le problème... :?:

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : lun. 08 avr. 2019, 14:32
par bowmore
Toujours au même point malgré quelques tentatives hasardeuses... :(

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : lun. 08 avr. 2019, 18:33
par yostral
Je ne peux malheureusement pas t'aider. Mais juste pour info, chez moi ça fonctionne toujours très bien. Donc peut-être un problème/une modif dans ta config java ? Tu es sous X ou Wayland ?

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : mer. 10 avr. 2019, 10:08
par bowmore
J'ai Wayland installé. Version wayland 1.17.0-1 normalement à jour.

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : mer. 10 avr. 2019, 18:52
par yostral
Essaye peut-être alors avec une session sous X, pour voir.

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : ven. 12 avr. 2019, 10:39
par bowmore
Bon là, j’atteins mes limites.
Je ne sais pas comment choisir entre X et Wayland.
Je ne sais même pas lequel est utilisé... :pastaper:

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : ven. 12 avr. 2019, 15:36
par CoudUr
En principe tu dois pouvoir choisir entre Wayland ou X11 depuis ton gestionnaire de démarrage (sddm, gdm, lightdm etc ...)
Pour déterminer lequel tu utilises, depuis un terminal tu peux faire un simple:

Code : Tout sélectionner

$ echo $XDG_SESSION_TYPE
x11
ou bien si cette variable n'est pas présente :

Code : Tout sélectionner

$ loginctl show-session "$(loginctl | grep "$(whoami)" | awk '{print $1}')"  -p Type
Type=x11
Dans les deux cas le retour de la commande attendu est soit x11 ou wayland... évidemment :wink:

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : lun. 15 avr. 2019, 08:27
par bowmore

Code : Tout sélectionner

$ echo $XDG_SESSION_TYPE
wayland

Code : Tout sélectionner

$ loginctl show-session "$(loginctl | grep "$(whoami)" | awk '{print $1}')"  -p Type
Type=wayland
On va dire que c'est Wayland qui est utilisé... :-?

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : lun. 15 avr. 2019, 08:54
par bowmore
Après avoir installé gdm3setup, et décoché "Activer Wayland",
et après un redémarrage, j'ai bien basculé sur X:

Code : Tout sélectionner

$ echo $XDG_SESSION_TYPE
x11
.

Et là, bingo, Cryptomator se lance sans problème.

Donc c'est bien lié à Wayland.
Mais je ne pige toujours pas quoi y faire...

Re: [Mise à Jour] Cryptomator ne démarre plus

Publié : lun. 15 avr. 2019, 10:29
par benjarobin
C'est pourtant tout expliqué dans le rapport de bug...
Tu as plusieurs solutions :
- Utiliser Xorg (Ce que tu viens de faire)
- Utiliser Gtk2 au lieu de Gtk3
- Forcer Gtk3 à utiliser le backend X11 en définissant la variable d'environnement : GDK_BACKEND=x11