[boot] perdu explication

Questions et astuces concernant l'installation et la configuration d'archlinux
AchilleFraisse
Elfe
Messages : 580
Inscription : dim. 27 avr. 2014, 09:32

[boot] perdu explication

Message par AchilleFraisse » mer. 16 oct. 2019, 12:16

bonjour
j'ai enleve mon disque dur interne linux pour mettre un windows.
ensuite j'ai remis mon linux et comme par hasard, le boot dans mon bios avait disparu. je ne pouvais plus du tout booter dessus, je ne voyais plus le grub de mon disque.
du coup j'ai remis une cle install archlinux, j'ai booter dessus, jai monté mes partitions /dev/sda{1,2,3,4} dans /mnt, j'ai chroot dans /mnt puis j'ai tapé :

Code : Tout sélectionner

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch_grub --recheck
grub-mkconfig -o /boot/grub/grub.cfg[/boot]
puis ca fonctionnait de nouveau
pourquoi ?
en faite pourquoi le fait d'enlever et de remettre le disque a faire disparaitre grub ou mon boot ?
je croyais que tout etait stocké sur le disque dur, non ?

laurent85
Elfe
Messages : 646
Inscription : mar. 16 oct. 2018, 21:05

Re: [boot] perdu explication

Message par laurent85 » mer. 16 oct. 2019, 15:06

Bonjour,
Les chargeurs sont stockés sur le disque dur dans la partition efi. Par contre la liste des chargeurs (le répertoire si tu préfères) est stocké dans la nvram de la carte mère. Si tu retires le disque le firmware uefi ne détecte plus le disque et supprime les entrées de son répertoire. Enfin c'est ce que j'en déduis, en fait les firmware uefi des fabricants sont tous différents, leur comportement aussi.

La seule solution pour qu'un système soit toujours "chargeable" quelque soit la situation est d'installer le chargeur dans le répertoire "BOOT" de la partition efi, c'est le secours, le firmware uefi lancera celui là s'il ne sait pas quoi faire.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso

Répondre