[clavier] Variante oss pour les caractères tapés avec AltGr (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1132
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

[clavier] Variante oss pour les caractères tapés avec AltGr (résolu)

Message par karhu » lun. 18 nov. 2019, 15:45

Bonjour
J'ai fini par réussir à avoir mon clavier reconnu en français, par le TTY, Xorg et même lightDM. Tout allait bien jusqu'à je veuille écrire le mot oeuf en utilisant la touche AltGr + o pour inclure le e dans le o. J'ai obtenu un superbe : ô. De même pour toues les autres combinaisons avec AltGr.
Pensant que c'était une question de configuration avec Xorg j'ai testé dans un TTY. Horreur !
Dans le TTY seules les touches situées sur la ligne numérique fonctionnent avec AltGr. De plus ces mêmes touches se comporte bizarrement en utilisation normale, par exemple : la touche 2 donne un { au lieu d'un é, la 7 un } au lieu d'un è, la 9 un / et la 0 un @ !!!!!
Quel est ce :insultes: de clavier, fr mais quelle variante ? Et où peut il bien être défini ?
Quelques fichiers de configuration : vconsole.conf

Code : Tout sélectionner

cat /etc/vconsole.conf 
KEYMAP=fr
FONT=
FONT_MAP=
mes locales

Code : Tout sélectionner

locale -a
C
POSIX
fr_FR
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
fr_FR@euro
french
LANG=fr_FR.UTF-8
et enfin pour Xorg

Code : Tout sélectionner

localectl
   System Locale: LANG=fr_FR.UTF-8
                  LC_COLLATE=C
       VC Keymap: fr
      X11 Layout: n/a
avec en plus une mauvaise lecture du fichier 10-keyboard-layout.conf

Code : Tout sélectionner

#
# Keyboard configuration
#
Section "InputClass"
	Identifier	"Keyboard Layout"
	MatchIsKeyboard "yes"
	MatchDevicePath "/dev/input/event*"
	Option		"XkbLayout" "fr"
#	Option		"XkbVariant" "latin9"
	Option		"XkbVariant" "oss"
et ce qu'il a compris

Code : Tout sélectionner

setxkbmap -query
rules:      evdev
model:      pc105
layout:     fr
variant:    latin9
options:    terminate:ctrl_alt_bksp
Dernière information mon clavier est un Logitech G910, reconnu comme tel par Xorg, mais rassurez vous avec un clavier classique le résultat est le même.
Dernière modification par karhu le sam. 23 nov. 2019, 13:22, modifié 3 fois.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

avi3000
Chu Ko Nu
Messages : 386
Inscription : dim. 19 juin 2011, 18:53
Localisation : dans le neuf trois

Re: [clavier] Reconnaissance de caractères tapés

Message par avi3000 » lun. 18 nov. 2019, 17:11

En tty tu oublies tout ce qui est xorg.conf et compagnie, ainsi que setxkbmap

Il faut faire du loadkeys.
crée le fichier ~/mon_keymap

Code : Tout sélectionner

compose 'o' 'e' to U+0153
compose '\' 'e' to U+20AC
dans le tty en root :

Code : Tout sélectionner

loadkeys /chemin/vers/mon_keymap
tu reviens en user dans le même terminal

Code : Tout sélectionner

Impression écran, o, e 
Impression écran, \, e
affiche œ€ ( la touche impression écran / printscr est la touche compose par défaut )

Ca fonctionne également dans tous les terminaux ouverts avant ou après le loadkeys
et voila

Si ça ne fonctionne pas, essaye avec mon vconsole.conf

Code : Tout sélectionner

KEYMAP="fr-pc"
CONSOLEFONT="lat9v-16"
CONSOLEMAP="8859-15"
FONT="lat9v-12"
FONT_MAP="8859-15"
USECOLOR="yes"

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1132
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [clavier] Reconnaissance de caractères tapés

Message par karhu » lun. 18 nov. 2019, 17:29

Merci pour ta réponse @avi3000, seulement je n'utilise pratiquement plus le TTY, sauf problèmes dans la session graphique, et surtout ce n'est pas aisé de faire du traitement de texte en mode TTY. :D
Je n'avais pas préciser, mais ce problème est apparu sur ma nouvelle installation (suite à un crash du disque dur) et que cela fonctionnait très bien avant.
À force d'installer ou de ré-installer tu entres (hélas) dans une routine de certitudes ajouté à l'énervement de ne pas avoir fait de sauvegarde récente .........
et plouf. :oops:
En fait je suis surtout intéressé par un peu d'aide pour la session graphique.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1132
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [clavier] Variante oss pour les caractères tapés avec AltGr

Message par karhu » sam. 23 nov. 2019, 10:44

Re-bonjour
Je viens de modifier le titre de ma demande afin d'être plus explicite.
Comment faire comprendre à Xorg que je veux (souhaite pour ne pas le froisser) la variante du clavier : oss.
Dans mon fichier 10-keyboard-layout.conf j'ai bien : Option "XkbVariant" "oss", alors pourquoi ne veut il pas en tenir compte.
D'ailleurs c'est comme la touche compose définie dans /etc/X11/xorg.conf.d/10-keyboard-layout.conf : Option "XkbOptions" "compose:menu", il s'en fout. J'ai vérifié suite à la réponse de @avi3000.
En fait j'ai l'impression qu'il ne lit pas les fichiers de configuration contenus dans /etc/X11/xorg.conf.d, ou qu'il n'en tient pas compte, ou qu'ils sont écrasés.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

benjarobin
Maître du Kyudo
Messages : 15901
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [clavier] Variante oss pour les caractères tapés avec AltGr

Message par benjarobin » sam. 23 nov. 2019, 11:27

Tu n'as pas d'autres fichiers de configuration par hasard ?
Quel est le contenu de /etc/X11/xorg.conf.d, ?

Je te conseille de le supprimer, et de le recréer avec localectl (voir son man)

Code : Tout sélectionner

localectl --no-convert set-x11-keymap fr "" oss
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

laurent85
Elfe
Messages : 585
Inscription : mar. 16 oct. 2018, 21:05

Re: [clavier] Variante oss pour les caractères tapés avec AltGr

Message par laurent85 » sam. 23 nov. 2019, 11:46

Bonjour,
J'ai fait un test avec :

Code : Tout sélectionner

sudo localectl set-x11-keymap fr pc105 oss_latin9
Ça marche j'obtiens bien le œ, vérifie dans la configuration de ton bureau que c'est la configuration système du clavier qui est utilisée et pas une configuration personnelle pour le bureau, il y a une case à cocher ou décocher suivant le type de bureau, sinon ça prend le dessus sur la configuration x11.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1132
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [clavier] Variante oss pour les caractères tapés avec AltGr

Message par karhu » sam. 23 nov. 2019, 13:22

@benjarobin j'avais essayé avec localectl et le fichier créé avait un indice de 00-, donc il était écrasé par celui d'indice 10- :oops: je ne l'avais pas supprimé.
@laurent85 c'est tellement simple ta réponse (je suis doué quand même), que j'ai malgré tout vérifié ma configuration XFCE. :mrgreen:
La honte est donc tombé sur moi, j'avais (ou un esprit malveillant avait) défini le clavier comme Français (variante obsolète).
En mettant Français (variante) seulement, ça marche.
Merci de m'avoir rappelé les bases de la recherche de faute : commencer par vérifier ce que l'on a réellement fait et non pas rester sur la certitude que l'on a certainement bien fait. L'inattention dû à l'habitude étant souvent source d'erreurs difficiles à trouver si on ne met pas en doute sa réalisation.
Quinze jours à chercher, est ce que cela me servira de leçon pour ma prochaine installation ? La question est ouverte.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

laurent85
Elfe
Messages : 585
Inscription : mar. 16 oct. 2018, 21:05

Re: [clavier] Variante oss pour les caractères tapés avec AltGr (résolu)

Message par laurent85 » sam. 23 nov. 2019, 14:08

Ça m'arrive encore de pas voir la solution devant mon nez :lol:
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

Répondre