[Syslinux] Error device (Résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
Qwaser
Hankyu
Messages : 38
Inscription : jeu. 23 févr. 2017, 13:29

Re: [Syslinux] Error device (Résolu)

Message par Qwaser »

Oui je comprends bien les limitations de Syslinux. Disons que j'ai appris Archlinux avec lui et je trouvais sa mise en place relativement simple.

J'ai vraiment l'impression que les serveurs d'OVH n'arrivent à démarrer que si l'ESP est monté dans un dossier situé dans /boot et non directement monté dans /boot lui-même... Pourquoi je n'en sais rien ! Je vais refaire un essais en ce sens toujours en visant l'EFISTUB !

Sinon je resterais sur la seule configuration fonctionnelle :
* L'ESP est monté dans /boot/efi
* Syslinux (je n'utilise que lui) est le bootloader et ses fichiers dans /boot/efi/EFI/syslinux
* Les fichiers du kernel placés dans /boot/efi/EFI
* Pas d'utilisation du microcode Intel
MSI GE63 RAIDER RGB 8RE
  • archOS (Archlinux + KDE avec thème Arc + LUKS + BTRFS)
  • Intel Core i7-8750H 12C @ 2.20GHz
  • 2x8 Go de RAM DDR4 @ 2400MHz
  • iGPU Intel UHD 630 + GPU Nvidia GTX 1060
  • SSD PCIe NVMe 512 Go (OS + MMORPG) + HDD SATA 1 To (Jeux)
  • Dalle IPS 1920x1080 120Hz
Ordinateur fixe personnalisé
  • archOS (Archlinux + KDE avec thème Arc + LUKS + BTRFS) -> En cours
  • Intel Core i7-4790K 4C @ 4.00GHz
  • 2x8 Go de RAM DDR3 @ 2400MHz
  • GPU Nvidia GTX 980
  • SSD SATA 1 To
  • Double écrans IPS 2560×1440 60Hz
benjarobin
Maître du Kyudo
Messages : 15971
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Syslinux] Error device (Résolu)

Message par benjarobin »

Je t'assure que le point de montage de la partition ESP n'a aucune importance pour le boot, uniquement pour la mise à jour du kernel.

La partition ESP est montée après que le PC est démarré (par systemd).

Je te conseil de relire mes derniers messages.

Tu as forcément fait une mauvaise manipulation !
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
Qwaser
Hankyu
Messages : 38
Inscription : jeu. 23 févr. 2017, 13:29

Re: [Syslinux] Error device (Résolu)

Message par Qwaser »

Je te crois sur parole benjarobin et ce d'autant que j'ai pu le vérifier avec mon NAS et ma machine virtuelle comme dit précédemment. La preuve en image, l'ESP est dans /boot directement :
Image

Voici comment j'installe ma machine virtuelle Archlinux : https://privatebin.net/?30fdf26e719de6f ... hPi8GJ7Gv5
MSI GE63 RAIDER RGB 8RE
  • archOS (Archlinux + KDE avec thème Arc + LUKS + BTRFS)
  • Intel Core i7-8750H 12C @ 2.20GHz
  • 2x8 Go de RAM DDR4 @ 2400MHz
  • iGPU Intel UHD 630 + GPU Nvidia GTX 1060
  • SSD PCIe NVMe 512 Go (OS + MMORPG) + HDD SATA 1 To (Jeux)
  • Dalle IPS 1920x1080 120Hz
Ordinateur fixe personnalisé
  • archOS (Archlinux + KDE avec thème Arc + LUKS + BTRFS) -> En cours
  • Intel Core i7-4790K 4C @ 4.00GHz
  • 2x8 Go de RAM DDR3 @ 2400MHz
  • GPU Nvidia GTX 980
  • SSD SATA 1 To
  • Double écrans IPS 2560×1440 60Hz
Répondre