[ auto-login ] sur Xfce ne fonctionne pas ( RESOLU )

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

[ auto-login ] sur Xfce ne fonctionne pas ( RESOLU )

Message par mine » mar. 21 janv. 2020, 13:57

0Bonjour les amis ,

dans le fichier ( /etc/lightdm/lightdm.conf ) :
J'ai decommenter ces deux lignes-ci :
dans la section :
[SeatDefaults]

autologin-user=user_name
autologin-user-timeout=0

et fait ces deux deux commandes

sudo groupadd -r autologin
sudo gpasswd -a user_name autologin


-------------------------
au reboot .. --> l’auto-login ne fonctionne pas :oops:
Dernière modification par mine le mar. 21 janv. 2020, 16:30, modifié 2 fois.

laurent85
Chu Ko Nu
Messages : 445
Inscription : mar. 16 oct. 2018, 21:05

Re: [l’auto-login] sur Xfce ne fonctionne pas

Message par laurent85 » mar. 21 janv. 2020, 14:40

Bonjour,
Il manque autologin-session=xfce
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

Re: [l’auto-login] sur Xfce ne fonctionne pas

Message par mine » mar. 21 janv. 2020, 14:52

dans la section [Seat:*]

a la ligne
# autologin-session=


j'ai decommenter cette ligne et ajjouter -> xfce

autologin-session=xfce

et enregistrer et redemarrer

l'auto-login ne fonctionne pas ;-(

laurent85
Chu Ko Nu
Messages : 445
Inscription : mar. 16 oct. 2018, 21:05

Re: [l’auto-login] sur Xfce ne fonctionne pas

Message par laurent85 » mar. 21 janv. 2020, 15:07

Donne les retours de:

Code : Tout sélectionner

id
grep -v '^#' /etc/lightdm/lightdm.conf
loginctl session-status | head
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

Re: [l’auto-login] sur Xfce ne fonctionne pas

Message par mine » mar. 21 janv. 2020, 15:14

~ $ id
uid=1000(mine) gid=985(users) groups=985(users),970(autologin),999(adm)
~ $ grep -v '^#' /etc/lightdm/lightdm.conf
[LightDM]
run-directory=/run/lightdm

[Seat:*]
session-wrapper=/etc/lightdm/Xsession
autologin-user=mine
autologin-user-timeout=0
autologin-session=xfce

[XDMCPServer]

[VNCServer]
~ $ loginctl session-status | head
1 - mine (1000)
Since: Tue 2020-01-21 09:57:13 AST; 13min ago
Leader: 390 (lxdm-session)
Seat: seat0; vc1
TTY: tty1
Service: lxdm; type x11; class user
State: active
Unit: session-1.scope
├─ 390 /usr/lib/lxdm/lxdm-session
├─ 399 xfce4-session
~ $

mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

Re: [l’auto-login] sur Xfce ne fonctionne pas

Message par mine » mar. 21 janv. 2020, 15:32

Je viens de decommenter ces deux lignes-ci

pam-service=lightdm
pam-autologin-service=lightdm-autologin

et rebooter

et cela ne fonctionne pas plus ;-(

laurent85
Chu Ko Nu
Messages : 445
Inscription : mar. 16 oct. 2018, 21:05

Re: [l’auto-login] sur Xfce ne fonctionne pas

Message par laurent85 » mar. 21 janv. 2020, 15:34

mine a écrit :
mar. 21 janv. 2020, 15:14
[VNCServer]
~ $ loginctl session-status | head
1 - mine (1000)
Since: Tue 2020-01-21 09:57:13 AST; 13min ago
Leader: 390 (lxdm-session)
Seat: seat0; vc1
TTY: tty1
Service: lxdm; type x11; class user
State: active
Unit: session-1.scope
├─ 390 /usr/lib/lxdm/lxdm-session
├─ 399 xfce4-session
~ $
lxdm et lxdm-session ??? Tu mélanges tout avec lightdm et xfce.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

Re: [l’auto-login] sur Xfce ne fonctionne pas

Message par mine » mar. 21 janv. 2020, 15:39

Que dois-je faire pour remedier a cela ?

mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

Re: [l’auto-login] sur Xfce ne fonctionne pas

Message par mine » mar. 21 janv. 2020, 15:55

Oh boy !!

je viens de suprimer llxdm

et redemarrer

j'arrive en tty .. ;-(

heureusement que j'ai d'autre distro en dual-boot ..

je reviens un peu plus tard ;-)

laurent85
Chu Ko Nu
Messages : 445
Inscription : mar. 16 oct. 2018, 21:05

Re: [l’auto-login] sur Xfce ne fonctionne pas

Message par laurent85 » mar. 21 janv. 2020, 15:55

Déjà annule les modifications pam.
Installe xfce si c'est pas fait.
Et pour utiliser lightdm comme gestionnaire de connexion :

Code : Tout sélectionner

sudo systemctl disable lxdm
sudo systemctl enable lightdm
Redémarre
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

Re: [l’auto-login] sur Xfce ne fonctionne pas

Message par mine » mar. 21 janv. 2020, 16:25

Wow !!

Un gros Merci a toi , mon bon ami ..

Probleme resolu grace a toi .. Merci encore ..

laurent85
Chu Ko Nu
Messages : 445
Inscription : mar. 16 oct. 2018, 21:05

Re: [ auto-login ] sur Xfce ne fonctionne pas ( RESOLU )

Message par laurent85 » mar. 21 janv. 2020, 16:32

Cool bonne fin de journée à toi
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

Répondre