[ visudo ] ne fonctionne pas .. ( Resolu )

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

[ visudo ] ne fonctionne pas .. ( Resolu )

Message par mine » mar. 21 janv. 2020, 18:27

Bonjour les amis ,

~ $ sudo visudo
[sudo] password for mine:
visudo: no editor found (editor path = /usr/bin/vi)
~ $
Dernière modification par mine le mar. 21 janv. 2020, 19:20, modifié 1 fois.

bobo
Elfe
Messages : 589
Inscription : mar. 08 avr. 2014, 22:47

Re: [ visudo ] ne fonctionne pas

Message par bobo » mar. 21 janv. 2020, 18:57

Chez moi ça fonctionne

Code : Tout sélectionner

18:54 bobo@ ~% sudo visudo
[sudo] Mot de passe de bobo : 
visudo: /etc/sudoers.tmp n'a pas été modifié
18:55 bobo@ ~% echo $EDITOR
vim
18:55 bobo@ ~% grep EDITOR .bashrc
export EDITOR="vim"
Tu peux changer la variable d'environnement $EDITOR dans ton .bashrc pour pointer sur vim. Ou installer vi
dwm — BÉPO — vim — “more is less !”

mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

Re: [ visudo ] ne fonctionne pas

Message par mine » mar. 21 janv. 2020, 19:20

J'ai installer ( VI )

Un gros merci ..

Resolu

bobo
Elfe
Messages : 589
Inscription : mar. 08 avr. 2014, 22:47

Re: [ visudo ] ne fonctionne pas .. ( Resolu )

Message par bobo » mar. 21 janv. 2020, 19:48

content d'avoir pu aider… je ne me souvenais même plus à quoi ça sert visudo :mrgreen:

J'ai fait un essai export EDITOR=nano et export EDITOR=vi, et ça lance visudo toujours avec vim : la variable $EDITOR dans mon .bashrc ne semble pas vraiment être prise en compte dans le cas de visudo. Si j'en crois mes commentaires dans mon .bashrc, il s'agit d'un héritage de ma période Zenwalk (~2008-09, ça ne me rajeunit pas).
dwm — BÉPO — vim — “more is less !”

bobo
Elfe
Messages : 589
Inscription : mar. 08 avr. 2014, 22:47

Re: [ visudo ] ne fonctionne pas .. ( Resolu )

Message par bobo » mar. 21 janv. 2020, 19:57

Ça pourrait être rigolo de trouver ça dans les sources… j'ai essayé en vitesse, mais là je m'aperçois que je suis en limite de compétence
dwm — BÉPO — vim — “more is less !”

mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

Re: [ visudo ] ne fonctionne pas .. ( Resolu )

Message par mine » mar. 21 janv. 2020, 19:59

visudo ne fonctionne pas bien comme sur Debian

je ne peux ecrire ou faire aucun changement dans visudo sur ma Arch :oops:

==============================

Pour désactiver certains mot-de-passe --> Si vous savez ce que vous faite ( ou encourrer comme risques ) en terminal..

https://doc.ubuntu-fr.org/desactiver_mo ... e_securite

==============================


sur Arch .. si j'ouvre GParted .. je suis obliger de mettre un mdp :oops:
tandis qu avec Debian apres avoir parametrer visudo .. --> pas de mdp :D
Dernière modification par mine le mar. 21 janv. 2020, 21:02, modifié 1 fois.

mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

Re: [ visudo ] ne fonctionne pas .. ( Resolu )

Message par mine » mar. 21 janv. 2020, 20:08

PolicyKit

Policykit est un utilitaire autre que sudo. il demande le mot de passe graphiquement (exemple: lors du lancement de gparted, synaptic…)

Vous devez être administrateur de l'ordinateur. C'est-à-dire que votre utilisateur doit être dans le groupe unix sudo.

Vous pouvez vérifier vos groupes par la commande groups (sans les guillemets évidement).

Si vous n'êtes pas dans le groupe adéquat, exécuter la commande suivante en remplaçant "votrenomdutilisateur" par…votre nom d'utilisateur :

usermod -aG adm votrenomdutilisateur

Puis créer une nouvelle règle:

sudo gedit /var/lib/polkit-1/localauthority/50-local.d/disable-passwords.pkla

Ajouter ceci comme contenu du fichier:

[Install package file]
Identity=unix-group:adm
Action=*
ResultActive=yes

Sauvegarder et redémarrer.
===================================================

sudo gedit /var/lib/polkit-1/localauthority/50-local.d/disable-passwords.pkla

sur Arch .. Gedit ne peux pas enregistrer ;-((((

bobo
Elfe
Messages : 589
Inscription : mar. 08 avr. 2014, 22:47

Re: [ visudo ] ne fonctionne pas .. ( Resolu )

Message par bobo » mar. 21 janv. 2020, 20:16

là je conseillerais d'ouvrir un nouveau sujet sur ces trucs

je fais parti des vilains canards qui en ont historiquement rien à faire des gksudo et kdesudo parce que sudo <n'importe quel programme graphique et ses arguments> fonctionne pour moi et que je fais aussi tout à la ligne de commande, du coup il y a tout un tas de problèmes que je n'ai jamais rencontrés :french:
dwm — BÉPO — vim — “more is less !”

mine
archer de cavalerie
Messages : 172
Inscription : ven. 01 mai 2015, 15:46

Re: [ visudo ] ne fonctionne pas .. ( Resolu )

Message par mine » mar. 21 janv. 2020, 21:11

# gedit /etc/sudoers
j'ai parametrer ..

et ouvert visudo

visudo a changer de parametrage :D

mais GParted demande toujours un mdp .. :oops:

Avatar de l’utilisateur
Kristen
Elfe
Messages : 664
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [ visudo ] ne fonctionne pas .. ( Resolu )

Message par Kristen » mer. 22 janv. 2020, 09:31

mine a écrit :
mar. 21 janv. 2020, 21:11
# gedit /etc/sudoers
j'ai parametrer ..

et ouvert visudo

visudo a changer de parametrage :D

mais GParted demande toujours un mdp .. :oops:
Salut
Archlinux n'est pas Debian ou Ubuntu.
Je te conseille vivement de lire le wiki concernant sudo. Wiki en français ET en anglais. Notamment le Warning ici
visudo vérifie si une erreur à été faite, gedit ne le fait pas !
Depuis le 14 octobre 2011 sur archlinux avec actuellement Gnome sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i
Debian Buster sur Lenovo Ideapad S130-14IGM

bobo
Elfe
Messages : 589
Inscription : mar. 08 avr. 2014, 22:47

Re: [ visudo ] ne fonctionne pas .. ( Resolu )

Message par bobo » mer. 22 janv. 2020, 20:04

ah cool le lien, merci Kristen
dwm — BÉPO — vim — “more is less !”

Répondre