[swap non active] partition swap qui n'est pas montée [résolu]

Questions et astuces concernant l'installation et la configuration d'archlinux
nestorburma
Chu Ko Nu
Messages : 349
Inscription : lun. 31 mars 2014, 17:28
Localisation : 13105

[swap non active] partition swap qui n'est pas montée [résolu]

Message par nestorburma » jeu. 27 févr. 2020, 18:48

bonjour
sur mon ordi j'ai un ssd et un hdd j'ai installé les partitions swap,var et home sur le hdd pour réduire l'usure du ssd,les partitions home et var sont montées mais pas la swap comment faire pour la monter
voici mon fichier fstab archlinux

Code : Tout sélectionner

# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>
# /dev/sdb6
UUID=43e72f57-a9a9-492c-bd8a-0919143d95bb	/         	ext4      	rw,relatime	0 1

# /dev/sda6
UUID=fb866c97-d3b4-4226-9edb-bfc9c9a81298	/var      	ext4      	rw,relatime	0 2

# /dev/sda7
UUID=0cbbd6bf-a965-4196-975d-512a77f95843	/home     	ext4      	rw,relatime	0 2

# /dev/sdb1 LABEL=SYSTEM
UUID=088C-8028      	/boot/efi 	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro	0 2
voici le fstab de ma debian

Code : Tout sélectionner

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb5 during installation
UUID=be550373-309d-4e3a-a80b-bdd55e25ed7f /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sdb1 during installation
UUID=088C-8028  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/sda4 during installation
UUID=3672685f-acf8-440b-aeb8-f51533aeab1b /home           ext4    defaults        0       2
# /var was on /dev/sda3 during installation
UUID=22f888f9-e69f-44e1-8916-5bffecf474ab /var            ext4    defaults        0       2
# swap was on /dev/sda2 during installation
UUID=f79fc9df-1dbf-4b6a-ba1e-c86cee0a91ad none            swap    sw              0       0
tmpfs      /tmp            tmpfs        defaults,size=1g           0    0
je pense qu'il faut modifier le fstab de arch mais je ne sais pas comment , je pourrais monter le swap de debian dans le fstab de arch mais j'ai choisi d'avoir des swap pour chaque distro ainsi que les home et je n'ai pas envie de reinstaller toute la distro pour corriger cette erreur
si quelqu'un peut me depanner ça serait une bonne chose
merci
Dernière modification par nestorburma le ven. 28 févr. 2020, 06:14, modifié 1 fois.
asus r702u,mate desktop

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1132
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [swap non active] partition swap qui n'est pas montée

Message par karhu » jeu. 27 févr. 2020, 19:21

Bonne démonstration chez Ubuntu.
Si tu as une partition dédiée pour le swap rajoute ces lignes (modifiées en conséquence) dans ton /etc/fstab :

Code : Tout sélectionner

    # /dev/sda6
    UUID=db245df9-851d-695b-a3f7-d40f039a6cc6 none            swap    sw      0      0
Activation par la commande si tu veux :

Code : Tout sélectionner

swapon
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

nestorburma
Chu Ko Nu
Messages : 349
Inscription : lun. 31 mars 2014, 17:28
Localisation : 13105

Re: [swap non active] partition swap qui n'est pas montée

Message par nestorburma » ven. 28 févr. 2020, 06:13

bonjour karhu
je te remercie,mais j'avais déja fait la modif,avec gparted j'ai genéré un uuid aleatoire et j'ai pris modèle sur le fstab de ma debian pour modifier le fstab de arch et ça fonctionne
asus r702u,mate desktop

Répondre