[GPG signatures] Problème de clés durant l’installation !!

Questions et astuces concernant l'installation et la configuration d'archlinux
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

[GPG signatures] Problème de clés durant l’installation !!

Message par soufianta »

Bonsoir,

Je suppose que je ne suis pas le premier ni le dernier à avoir rencontré ce problème. Durant l’installation (pacstrap) je reçois une erreur de clés (signatures des paquets): »error, invalid signature or corrupted packages ». Il ne me laisse donc pas aller plus loin ! Je dois préciser que c’est une install sur VM (virtual box). J’ai un peu cherché sur le net et je suis tombé sur des soucis de virtualbox mais j’ai essayé pas mal de commandes lié à pacman-keyring (tester avec un autre serveur de clés) etc mais rien n’y fait. L’iso a bien été vérifier également (télécharger plusieurs fois)

Merci.
Dernière modification par soufianta le ven. 12 juin 2020, 22:48, modifié 1 fois.
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

Re: [PGP signatures] Problème de clés durant l’installation !!

Message par soufianta »

Je pense que c’est un soucis de virtual box ou de l’hyper V. J’ai eu des soucis avec plusieurs distributions (pour tester) et 90% plantait. Mais supposons que ça soit virtual box ou l’hyper-V, comment se fait-il que ça soit cette erreur de clés qui me tombe dessus ?? Je veux bien que ça plante ou mauvaises perf mais pas une erreur de clés :-( . Je devrais la tester en dur mais je n’ai pas de machine de test à portée de mains.
Avatar de l’utilisateur
CoudUr
yeomen
Messages : 217
Inscription : sam. 06 avr. 2013, 17:12

Re: [GPG signatures] Problème de clés durant l’installation !!

Message par CoudUr »

Salut,

Pas sûr que la virtualisation soit coupable, ce ne serait pas le même type de problème que tu as rencontré précédemment, de quand date ton iso ?
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

Re: [GPG signatures] Problème de clés durant l’installation !!

Message par soufianta »

@CoudUr: pas du tout le même soucis. Je pense vraiment que c’est lié à la virtualisation car j’ai ce soucis depuis avoir essayer WSL sur ma machine Windows ! Depuis la désinstallation de WSL, plus rien ne fonctionne en vm. Je vais essayer de voir de ce côté car ce soucis de clés ne peut pas être anodin (instabilités sur les autres distributions également) ! Mon iso est celle qui se trouve actuellement sur les miroirs = très récente !
Dernière modification par soufianta le dim. 14 juin 2020, 00:19, modifié 1 fois.
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

Re: [GPG signatures] Problème de clés durant l’installation !!

Message par soufianta »

@coudUr: par contre je remarque qu’à chaque fois que je poste quelque chose, tu scrutes tout mes posts ici ou ailleurs au lieu d’essayer de m’aider ! Ps: ça ne sert à rien d’aller chercher sur d’autres forums cette fois-ci ;-)
Avatar de l’utilisateur
CoudUr
yeomen
Messages : 217
Inscription : sam. 06 avr. 2013, 17:12

Re: [GPG signatures] Problème de clés durant l’installation !!

Message par CoudUr »

par contre je remarque qu’à chaque fois que je poste quelque chose, tu scrutes tout mes posts
Paranoïa quand tu nous tiens, bois un verre d'eau et détends toi tout va bien.
[...] au lieu d’essayer de m’aider
Il me semble pourtant t'avoir aidé lors du problème dont j'ai indiqué le lien dans mon message précédent.
Merci d'éviter les jugements à l'emporte-pièce, si tu souhaites solliciter l'attention en vue d'une aide à la mesure de tes attentes tu t'y prends très mal.
pas du tout le même soucis. Je pense vraiment que c’est lié à la virtualisation car j’ai ce soucis depuis avec essayer WSL sur ma machine Windows ! Depuis la désinstallation de WSL, plus rien ne fonctionne en vm. Je vais essayer de voir de ce côté car ce soucis de clés ne peut pas être anodin (instabilités sur les autres distributions également) !
Si c'est le cas on ne parle plus du tout d'Archlinux alors mais d'un problème propre à Windows10, je passe mon tour.
Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10596
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [GPG signatures] Problème de clés durant l’installation !!

Message par FoolEcho »

«Je vous demande de vous arrêter» :mrgreen: et de revenir au sujet. :chinois: :moderationok:

Il y a des tas de causes possibles à ce type de problème: https://wiki.archlinux.org/index.php/Pa ... leshooting .

... Je ne sais pas comment ça se comporte dans une vm mais comme tu as le problème avec d'autres distributions peut-être jeter un oeil sur l'horloge système ? (la gestion diffère entre windows et linux à ce niveau, par exemple https://www.numetopia.fr/dual-boot-corr ... ows-linux/ -- faut déjà vérifier comment est configuré l'heure de windows).
«The following statement is not true. The previous statement is true.» :nage:
soufianta
Daikyu
Messages : 58
Inscription : mer. 13 févr. 2019, 10:14

Re: [GPG signatures] Problème de clés durant l’installation !!

Message par soufianta »

@CoudUr: tu es d’accord avec moi que ce n’est pas la première fois hein ?? Elle m’a fait du bien la gorgée d’eau ..

@FoolEcho: tu as bien pu constaté mon calme olympique et je ne suis nullement à la recherche d’une querelle ou autre mais j’essaie juste de comprendre. Pour moi, ce soucis est apparu après que j’ai chipoté à mon hyper-V sous Windows. Je vais donc chercher de ce côté là et vérifier l’horloge interne (même si cela me semble bizarre).
Répondre