[grub] Installation impossible de grub

Questions et astuces concernant l'installation et la configuration d'archlinux
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

[grub] Installation impossible de grub

Message par vlotho »

Salut,

Je fais une nouvelle install dans une vm et je n'arrive pas à installer grub.
Je fais toute la procédure de la page https://wiki.archlinux.fr/installation jusqu’à bootloader mais que je soit chrooter ou pas j'obtient toujours l'erreur :
error; failed to update community ( invalid url for server )
error: failed all synchronize all databases

pourtant j'ai installé d'autre paquet avant et je n'ai pas eu de problèmes.
je fait pacman -S grub en chroot
ou pacstrap /mnt grub en non chroot
laurent85
Elfe
Messages : 688
Inscription : mar. 16 oct. 2018, 21:05

Re: [grub] Installation impossible de grub

Message par laurent85 »

Bonjour,
Quel est le retour dans le chroot de :

Code : Tout sélectionner

pacman -Sy
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

Re: [grub] Installation impossible de grub

Message par vlotho »

Image

Image

Je ping bien ma machine ainsi que mon nas ou les machines de mon réseau mais rien ne sort.
C'est bisare vue que j'ai quand même pu installer mon système, à part qu'il ai en fait utilisé les paquets du media d'install ...

Je suis un peu nouveau sur arch ...
habituellement je bosse plutôt sur Debian :)
laurent85
Elfe
Messages : 688
Inscription : mar. 16 oct. 2018, 21:05

Re: [grub] Installation impossible de grub

Message par laurent85 »

La résolution de nom de fonctionne pas, c'est lié à la configuration réseau de la vm.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

Re: [grub] Installation impossible de grub

Message par vlotho »

Je vois pas trop pourquoi ça serait lié à la config de la vm :

Image
laurent85
Elfe
Messages : 688
Inscription : mar. 16 oct. 2018, 21:05

Re: [grub] Installation impossible de grub

Message par laurent85 »

Regarde le contenu de /etc/resolv.conf
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

Re: [grub] Installation impossible de grub

Message par vlotho »

Image

j'ai rajouté les dns de google mais ça fonctionne pas mieux
je sais pas trop à quoi correspond les autres valeur
laurent85
Elfe
Messages : 688
Inscription : mar. 16 oct. 2018, 21:05

Re: [grub] Installation impossible de grub

Message par laurent85 »

Laisse uniquement les dns google et fais un :

Code : Tout sélectionner

ping forums.archlinux.fr -c3
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

Re: [grub] Installation impossible de grub

Message par vlotho »

resolvectl status

Image

Image

Image
laurent85
Elfe
Messages : 688
Inscription : mar. 16 oct. 2018, 21:05

Re: [grub] Installation impossible de grub

Message par laurent85 »

Arrête le service systemd-resolved.

Code : Tout sélectionner

sudo systemctl stop systemd-resolved
Et refais un test de ping avec les dns google dans /etc/resolv.conf
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

Re: [grub] Installation impossible de grub

Message par vlotho »

Image

les ping renvoi bien la réponse de google
laurent85
Elfe
Messages : 688
Inscription : mar. 16 oct. 2018, 21:05

Re: [grub] Installation impossible de grub

Message par laurent85 »

vlotho a écrit :
jeu. 18 juin 2020, 19:02
les ping renvoi bien la réponse de google
Et pacman -Sy fonctionne maintenant ?
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

Re: [grub] Installation impossible de grub

Message par vlotho »

non toujours pas
laurent85
Elfe
Messages : 688
Inscription : mar. 16 oct. 2018, 21:05

Re: [grub] Installation impossible de grub

Message par laurent85 »

S'il y a toujours "Could not resolve host:..." c'est que le problème de résolution de nom n'est toujours pas résolu. Ça m'étonne que le ping sur le nom du forum fonctionne lui.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

Re: [grub] Installation impossible de grub

Message par vlotho »

bein non il fonctionne pas, regarde la capture
c'est clairement la résolution de noms qui pose problème mais je vois pas comment le résoudre ...
laurent85
Elfe
Messages : 688
Inscription : mar. 16 oct. 2018, 21:05

Re: [grub] Installation impossible de grub

Message par laurent85 »

vlotho a écrit :
jeu. 18 juin 2020, 19:02
les ping renvoi bien la réponse de google
J'ai mal compris cette phrase alors.

Le ping de 8.8.8.8 fonctionne lui ?
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

Re: [grub] Installation impossible de grub

Message par vlotho »

oui
le ping avec l'ip oui mais pas avec le nom
laurent85
Elfe
Messages : 688
Inscription : mar. 16 oct. 2018, 21:05

Re: [grub] Installation impossible de grub

Message par laurent85 »

Donc le chroot n'utilise pas les dns google.
L'arrêt du service systemd-resolved se fait en dehors du chroot.

Fais les tests de ping hors chroot, contrôle le continu /etc/resolv.conf après arrêt du service.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

Re: [grub] Installation impossible de grub

Message par vlotho »

Image
vlotho
Hankyu
Messages : 18
Inscription : mar. 31 déc. 2013, 11:20

Re: [grub] Installation impossible de grub

Message par vlotho »

j'ai essayé de rajouter les dns google au resolv.conf en non chroot mais c'e'st pareil
Répondre