Page 1 sur 1

[démarrage] freeze après bootloader

Publié : ven. 10 juil. 2020, 18:53
par Rapty
Bonjour Forum

Je suis bien embêté, je ne sais pas trop comment expliquer ce qu'il se passe.
Je suis en train de réinstaller un pc portable. J'ai fait une installation neuve, en suivant le wiki, jusqu'à Gnome... J'ai mis trop de paquet (j'ai tout accepté le groupe, un peu trop fort) avec, plutôt que d'en enlever, je recommence à zéro. Réinstallation complète, ca va, j'arrive à Gnome, cool, mais cette fois je me dis j'aurais quand même du mettre une partition swap. Je recommence de zéro, j'arrive à Gnome, un peu lourd (c'est un vieux pc) je me dis aller! je recommence mais cette fois je mets LXDE.

Sauf que maintenant (après 4 tentatives fructueuses mais pas acceptable pour des raisons futiles), après l’installation de base (base linux linux-firmware) puis quelques paquets utiles (dhcpcd dhclient vim intel-ucode syslinux) je redémarre et ... rien ! je devrais créer un user et continuer la conf, mais le PC ne passe pas l'étape après SYSLINUX.

j'ai bien (de tête, pas 100% exacte) :

Code : Tout sélectionner

Loading ../vmlinuz-linux....
Loading ../intel-ucode.img...
Loading ../initram-linux.img....
Probing EDD (edd=off to disable)... ok
puis un flash fugitif de l'écran (passage au démarrage du noyau?) mais rien de plus. L'écran revient au texte précédent puis reste complètement figé.

J'ai recommencé encore et encore. J'ai essayé GRUB au lieu de SYSLINUX. Le problème ne semble pas venir du bootloader.
Comme le système ne démarre pas vraiment, je n'ai pas vraiment de log.

Je pense que j'ai fait quelque chose de mauvais, je n'arrive pas à trouver. Je n'arrive pas à chercher efficacement sur google en l'absence de mot clef sur ce qu'il se passe.

Please help! Si vous aviez ne serait-ce que l'idée du nom de l'action qui échoue... :?

Re: [démarrage] freeze après bootloader

Publié : sam. 11 juil. 2020, 09:38
par FoolEcho
Salut,

A minima il faut vérifier la cohérence entre les entrées de ton gestionnaire de démarrage, le contenu de /etc/fstab de ton système et ce qui est effectivement présent (blkid et cie). Si tu as formaté les partitions à chaque tentative ça a forcément bougé pas mal...

À côté de ça... ça ne sert à rien de réinstaller 15 fois le système parce que tu as des paquets dont tu ne veux pas... Le principe du gestionnaire de paquets est bien d'installer ou de désinstaller paquets ou groupe une fois le système en place (gnome trop lourd ? il suffisait de le désinstaller et d'installer lxde... réinstaller l'ensemble du système n'a pas de sens)...

Re: [démarrage] freeze après bootloader

Publié : sam. 11 juil. 2020, 11:18
par Rapty
Salut FoolEcho

Ok je comprends seulement avant, j'étais plus proche du début que de la fin, et je me disais que 10min de résintall pour avoir une base saine c'était acceptable.
Évidemment maintenant que j'arrive plus à rien la donne a changé...

/boot/syslinux/syslinux.cfg

Code : Tout sélectionner

LABEL arch
   MENU LABEL Arch Linux
   LINUX ../vmlinuz-lunux
   APPEND root=/dev/sda1 rw
   INITRID ../initramfs-linux.img
/etc/fstab (résultat de genfstab de l'iso)

Code : Tout sélectionner

# /dev/sda1
UUID=xxxxxxxxxxxxx		/	ext4		rw,relatime	0 1
blkid

Code : Tout sélectionner

/dev/sda1: UUID="xxxxx" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="xxxx"
Note: afin de retirer tout élément perturbateur je suis revenu à un système extrêmement simplifié d'une seule partition avec aucune option (pas de nvidia, pas de ucode, etc.)

Re: [démarrage] freeze après bootloader

Publié : sam. 11 juil. 2020, 15:49
par Rapty
Ok je viens de remarquer que ce n'est pas un freeze... Il faut pas loin de 15min de freeze apparent puis ensuite ça enchaîne ("early hook").
Mon problème n'est donc pas ce que j'ai expliqué dans ce sujet...

J'ai de la recherche à faire.
Merci FoolEcho !

Re: [démarrage] freeze après bootloader

Publié : dim. 19 juil. 2020, 11:12
par Jpm
Rapty a écrit :
sam. 11 juil. 2020, 15:49
Ok je viens de remarquer que ce n'est pas un freeze... Il faut pas loin de 15min de freeze apparent puis ensuite ça enchaîne ("early hook").
Mon problème n'est donc pas ce que j'ai expliqué dans ce sujet...

J'ai de la recherche à faire.
Merci FoolEcho !
Bonjour,
J'ai le meme probleme, environ 5mn entre le message "Probig EDD ... OK" et "runniing early hook" puis chargement du systeme.
Ceci est arrivé après une simple mise à jour (vers le 4 juin) sans aucune modif hard ou logiciel.
C'est donc bien le contenu de la mise à jour qui a créé le problème.
Je cherche la raison, mais je ne sais pas si cela vient du chargeur ou de systemd.
Je ne trouve rien dans les log et je ne sais pas si il est possible d'avoir des messages plus précis du début du lancement.

Re: [démarrage] freeze après bootloader

Publié : dim. 19 juil. 2020, 18:25
par papajoke
Rapty a écrit :
sam. 11 juil. 2020, 15:49
"early hook"
bonjour
donc apparemment un problème hook dans mkinitcpio

Re: [démarrage] freeze après bootloader

Publié : mer. 22 juil. 2020, 18:29
par Rapty
Jpm a écrit :
dim. 19 juil. 2020, 11:12
Je cherche la raison, mais je ne sais pas si cela vient du chargeur ou de systemd.
Je ne trouve rien dans les log et je ne sais pas si il est possible d'avoir des messages plus précis du début du lancement.
il faut indiquer au noyau de donner plus de détail dès le bootloader. Par exemple le niveau 6 qui est plutôt bavard (il existe le niveau 7 pour le debug, mais comme on a un noyau standard ça ne devrait pas être nécessaire)

Code : Tout sélectionner

loglevel=6
Pour Syslinux, c'est à mettre dans le APPEND

Dans mon cas, on voit qu'après le "flash" (basculement du bootloader vers le noyau), là où avant ça avait l'air freezé, il y a maintenant plein de log.
Mais bon, pour trouver qu'est ce qui a changé de plus, sans connaître les logs de quand ça allait bien, c'est pas évident.
papajoke a écrit :
dim. 19 juil. 2020, 18:25
donc apparemment un problème hook dans mkinitcpio
Non je ne pense pas, enfin pour moi en tous cas. C'est juste que le early hook est l'étape où le noyau est bavard même sans loglevel.