Page 1 sur 1

[SSD M2 NVME] Démarrage impossible (RÉSOLU)

Publié : mar. 14 juil. 2020, 19:34
par L_Indien
Bonjour à toutes et à tous,

Je viens de monter, sur une carte pci-e 4x, un ssd m2 nvme.
Sous arch : nickel (bien vue, tests ok)
Installation : nickel. Pour éviter trop de complication, j'ai mis la table de partition en msdos. J'ai créé une partition au début en vfat (pour grub) et le système en ext4. Le swap est sur un autre disque.
Par contre, le ssd n'étant pas vu pas le bios, je dois installer grub sur une clef usb ou modifier le grub qui fait appel au premier système arch.
Et c'est là que ça se complique...
Sous l'ancien arch, j'ai mis à jour grub avec os-prober (le nouvel arch est bien détecté).
Lors du redémarrage, quand je sélectionne le nouvel arch, grub me signale qu'il n'arrive pas à trouver la partition. Mais, il boote tout de même dessus. J'arrive sous l'écran de connexion en ligne de commande, mais rien ne répond : obligé de reset le pc au bouton.

On peut se poser la question : suis-je sur de booter sur le bon arch ?
Oui, car en chroot sur le nouvel arch, les journaux n'ont rien à voir avec l'ancien.

Avez-vous déjà rencontré ce type de problème ?

Bonne soirée.

Re: [SSD M2 NVME] Démarrage impossible (EN COURS...)

Publié : mar. 14 juil. 2020, 19:41
par benjarobin
Bonjour,
Avec ce genre de matos, il est plus que recommandé de faire un boot UEFI avec une table de partition GPT.
Au contraire avec une table GPT c'est plus simple qu'avec du msdos...
Pourquoi parles tu de partition vfat pour Grub ? Tu parles de la partition ESP ?

Re: [SSD M2 NVME] Démarrage impossible (EN COURS...)

Publié : mar. 14 juil. 2020, 20:04
par L_Indien
Bonsoir Benjarobin,

Je te remercie pour ta réponse.

OK, merci pour le l'info : ayant juste installé le minimum, je compte recommancer mais avec une table de partition en GPT.
Concernant le vfat pour grub, de souvenirs ça posait moins de problème... Oui, c'est dans le cas où le bios soit EUFI...

Bonne soirée.

Re: [SSD M2 NVME] Démarrage impossible (EN COURS...)

Publié : sam. 25 juil. 2020, 16:10
par L_Indien
Bonjour,

Je reviens pour donner un peu de news.

Ma carte ne gére pas le EUFI (la mise à jour ne change rien), et l'appel par le BIOS du ssd en nvme n'est pas possible.

J'ai réussi à booter sur le ssd nvme et avoir un système qui répond...

Voici les étapes que j'ai du effectuer :
- mettre le ssd en GPT,
- mettre le répertoire de /boot sur une clef USB et y installer grub normalement (# grub-install --no-floppy --recheck /dev/dev_clefUSB et # grub-mkconfig -o /boot/grub/grub.cfg). Dans le fstab, le /boot pointe donc sur la clef,
- dans le /etc/mkinitcpio.conf mis le module nvme et dans les hooks remplacer udev par systemd.

Voilou :-)

Merci pour tes conseils benjarobin.

Bon week-end.

Re: [SSD M2 NVME] Démarrage impossible (RÉSOLU)

Publié : sam. 25 juil. 2020, 16:21
par benjarobin
Peux tu donner le modèle de la carte mère par curiosité ? Elle a quel age ?

Re: [SSD M2 NVME] Démarrage impossible (RÉSOLU)

Publié : sam. 25 juil. 2020, 17:01
par L_Indien
C'est une CM SuperMirco : X9SRA.

Jeune d'1 an, mais ancien modèle. C'est un vieux proc dessus (i7 3930k)

Re: [SSD M2 NVME] Démarrage impossible (RÉSOLU)

Publié : sam. 25 juil. 2020, 18:58
par benjarobin
D'après son manuel (https://www.supermicro.com/manuals/moth ... L-1281.pdf), elle a un boot UEFI. Il faut vraiment avoir du vieux matos pour ne pas avoir une carte mère UEFI. Ce que tu as est "récent".
Après la question est : Est ce que la carte mère détecte le disque NVME sur une "carte d'extension" en PCI express, et permet le boot dessus...

Re: [SSD M2 NVME] Démarrage impossible (RÉSOLU)

Publié : dim. 26 juil. 2020, 08:45
par L_Indien
Salut benjarobin,

Je te remercie pour ton retour.
benjarobin a écrit :
sam. 25 juil. 2020, 18:58
D'après son manuel (https://www.supermicro.com/manuals/moth ... L-1281.pdf), elle a un boot UEFI. Il faut vraiment avoir du vieux matos pour ne pas avoir une carte mère UEFI. Ce que tu as est "récent".
Exact... Mais, j'ignore pourquoi, en suivant le wiki sur l'installation, arch m'informe que la carte ne supporte pas l'UEFI (Impossible de retrouver la page... De souvenirs, il est possible de voir ça depuis le live...)
benjarobin a écrit :
sam. 25 juil. 2020, 18:58
Après la question est : Est ce que la carte mère détecte le disque NVME sur une "carte d'extension" en PCI express, et permet le boot dessus...
C'est sûr que la carte maman (ou la carte d'extension...) ne peut booter dessus. Mais pourquoi... Essayer de voir ça avec supermicro (ils répondent aux problèmes techniques. C'est plutôt cool), sachant qu'il est possible de booter dessus en passant par une clef USB. Est-ce que ça vaut vraiment le coup ?

Au passage, j'ai réussi à booter une fois dessus. Et depuis, nan... Il arrive à botter dessus, mais une fois à l'invite de commande pour se loguer c'est bloqué. Je travaille dessus pour essayer de trouver ce qui déconne.

Bon dimanche.

Re: [SSD M2 NVME] Démarrage impossible (RÉSOLU)

Publié : dim. 06 sept. 2020, 16:17
par L_Indien
Salut Benjaronbin,

Je reviens en rapidement concernant le sujet.

Donc, impossible de booter dessus (toujours et encore).
En installant le /boot sur une clef USB, c'est OK.

J'ai également installé les softs suivants : nvme-cli samsung-ssd-dc-toolkit, et mis "nvme" dans la partie « MODULES » du fichier /etc/mkinitcpio.conf

Et clac... Archlinux sur un ssd m2 nvme.

Bonne fin de journée.

Re: [SSD M2 NVME] Démarrage impossible (RÉSOLU)

Publié : dim. 06 sept. 2020, 18:37
par CoudUr
C'est étonnant que tu ne puisses pas booter dessus directement, surtout une carte mère type professionnel.

Tu n'as pas d'options de ce genre ou quelque chose qui s'en approche ?
BIOS -> Advanced -> PCIe/PCI/PnP Configuration -> Launch Storage OpROM policy -> "UEFI only"

https://www.supermicro.com/support/faqs ... ?faq=22976

Re: [SSD M2 NVME] Démarrage impossible (RÉSOLU)

Publié : dim. 06 sept. 2020, 19:20
par L_Indien
Bonsoir CoudUr,

Je te remercie pour ton retour.
CoudUr a écrit :
dim. 06 sept. 2020, 18:37
C'est étonnant que tu ne puisses pas booter dessus directement, surtout une carte mère type professionnel.
Je te l'avoue. Mais, le ssd est sur une carte d'extension... Je ne pense pas que ça est un rapport. Normalement, ça devrait être possible.
Après, la CM ne manque pas de port USB...
CoudUr a écrit :
dim. 06 sept. 2020, 18:37
Tu n'as pas d'options de ce genre ou quelque chose qui s'en approche ?
BIOS -> Advanced -> PCIe/PCI/PnP Configuration -> Launch Storage OpROM policy -> "UEFI only"

https://www.supermicro.com/support/faqs ... ?faq=22976
J'ai pas mal regardé dans le BIOS avant de faire la manip, mais personne n'est à l'abri de louper un menu.
Merci pour l'info. Je regarde et te tiens informé.

Bonne soirée.

Re: [SSD M2 NVME] Démarrage impossible (RÉSOLU)

Publié : mar. 08 sept. 2020, 06:42
par L_Indien
Bonjour CoudUr,

Je reviens pour donner des nouvelles.
CoudUr a écrit :
dim. 06 sept. 2020, 18:37
Tu n'as pas d'options de ce genre ou quelque chose qui s'en approche ?
BIOS -> Advanced -> PCIe/PCI/PnP Configuration -> Launch Storage OpROM policy -> "UEFI only"
Oui, mais non... : j'ai bien trouvé le menu en question, mais j'ai du faire un reset du BIOS (par le retrait de la pile... Sur ce type de CM, pas de bouton RAZ).

Donc, je n'ai pas retenté le diable (le pc n'est pas des plus accessibles. C'est relativement lourd pour effectuer des manips dans la tour).
Après, ce n'est pas trop contraignant. Au lieux de passer en UEFI, je passe par grub installé sur une clef usb qui fait appel au ssd.

Merci en tout cas pour l'info.

Bonne journée.

Re: [SSD M2 NVME] Démarrage impossible (RÉSOLU)

Publié : sam. 03 oct. 2020, 14:48
par CoudUr
Salut,

Désolé pour le retard.
Oui si t'es obligé de retirer la pile pour chaque essai non concluant c'est pas ce qu'il y a de mieux.
En plus si la machine n'est pas trop accessible c'est pas pratique, dans ce cas là on a tendance à aller au plus simple, du moment que ça fonctionne je comprends ;)