[XFCE4] ssh, su, sudo impossibles en graphique, mais possibles en console TTY.

Questions et astuces concernant l'installation et la configuration d'archlinux
LapSpatial
newbie
Messages : 5
Inscription : dim. 20 sept. 2020, 13:28

[XFCE4] ssh, su, sudo impossibles en graphique, mais possibles en console TTY.

Message par LapSpatial »

Bonjour,

Ceci est mon premier poste, alors merci de votre indulgence.

Installation minimale d'Archlinux : mode console par défaut, accès à l'environnement graphique par "startlxde" ou "startxfce4".

En mode console, toutes les commandes suivantes passent sans problème : ssh <localhost>, su -, sudo -s
En mode graphique, aucune ne passent. Aucun souci de fontes dans une console "xterm", "lxterminal", etc. Avec le mode graphique, le verrouillage de la session ne peut être retiré avec le mot de passe.



En regardant les logs de "systemd' avec "journalctl -e -n 20" :

Code : Tout sélectionner

juil. 14 17:58:26 black xfce4-screensaver-dialog[8142]: PAM unable to dlopen(/usr/lib/security/pam_gnome_keyring.so): /usr/lib/security/pam_gnome_keyring.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
juil. 14 17:58:26 ordi xfce4-screensaver-dialog[8142]: PAM adding faulty module: /usr/lib/security/pam_gnome_keyring.so
Ajout du paquet "pacman -S pam_gnome_keyring". Aucun succès :

Code : Tout sélectionner

sept. 20 12:38:20 ordi kernel: audit: type=1104 audit(1600598300.854:304): pid=47151 uid=0 auid=1000 ses=13 msg='op=PAM:setcred grantors=pam_faillock,pam_permit,pam_env,pam_faillock acct="root" exe="/usr/bin/sudo" hostname=ordi addr=? terminal=/dev/tty6 res=success'
sept. 20 12:40:17 ordi sudo[47405]: pam_unix(sudo:auth): authentication failure; logname= uid=1000 euid=0 tty=/dev/pts/1 ruser=lapstatial rhost=  user=lapstatial
sept. 20 12:40:17 ordi dbus-daemon[367]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.6248' (uid=0 pid=47405 comm="sudo -s ")
sept. 20 12:40:17 ordi dbus-daemon[367]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
sept. 20 12:40:17 ordi sudo[47405]: pam_systemd_home(sudo:auth): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
sept. 20 12:40:17 ordi audit[47405]: USER_AUTH pid=47405 uid=1000 auid=1000 ses=11 msg='op=PAM:authentication grantors=? acct="lapstatial" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=failed'
sept. 20 12:40:17 ordi kernel: audit: type=1100 audit(1600598417.144:305): pid=47405 uid=1000 auid=1000 ses=11 msg='op=PAM:authentication grantors=? acct="lapstatial" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=failed'
sept. 20 12:40:36 ordi audit[47405]: USER_AUTH pid=47405 uid=1000 auid=1000 ses=11 msg='op=PAM:authentication grantors=? acct="lapstatial" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=failed'
sept. 20 12:40:36 ordi kernel: audit: type=1100 audit(1600598436.568:306): pid=47405 uid=1000 auid=1000 ses=11 msg='op=PAM:authentication grantors=? acct="lapstatial" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=failed'
sept. 20 12:40:43 ordi audit[47405]: USER_AUTH pid=47405 uid=1000 auid=1000 ses=11 msg='op=PAM:authentication grantors=? acct="lapstatial" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=failed'
sept. 20 12:40:43 ordi kernel: audit: type=1100 audit(1600598443.711:307): pid=47405 uid=1000 auid=1000 ses=11 msg='op=PAM:authentication grantors=? acct="lapstatial" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=failed'
sept. 20 12:40:45 ordi sudo[47405]:     lapstatial : 3 incorrect password attempts ; TTY=pts/1 ; PWD=/home/lapstatial ; USER=root ; COMMAND=/bin/bash
Le répertoire "/etc/pam.d" :

Code : Tout sélectionner

$ ls /etc/pam.d/
chage      chsh       groupmod  other     rsh        sshd  system-auth         system-remote-login  usermod
chfn       groupadd   login     passwd    runuser    su    systemd-user        system-services      vlock
chgpasswd  groupdel   lxdm      polkit-1  runuser-l  sudo  system-local-login  useradd              xfce4-screensaver
chpasswd   groupmems  newusers  rlogin    shadow     su-l  system-login        userdel
État du service "polkit" :

Code : Tout sélectionner

 polkit.service - Authorization Manager
     Loaded: loaded (/usr/lib/systemd/system/polkit.service; static)
     Active: active (running) since Mon 2020-09-14 00:25:48 CEST; 6 days ago
       Docs: man:polkit(8)
   Main PID: 491 (polkitd)
      Tasks: 8 (limit: 19045)
     Memory: 17.3M
     CGroup: /system.slice/polkit.service
             └─491 /usr/lib/polkit-1/polkitd --no-debug

sept. 14 19:32:17 ordi polkitd[491]: Finished loading, compiling and executing 4 rules
sept. 14 19:32:17 ordi polkitd[491]: Reloading rules
sept. 14 19:32:17 ordi polkitd[491]: Collecting garbage unconditionally...
sept. 14 19:32:17 ordi polkitd[491]: Loading rules from directory /etc/polkit-1/rules.d
sept. 14 19:32:17 ordi polkitd[491]: Loading rules from directory /usr/share/polkit-1/rules.d
sept. 14 19:32:17 ordi polkitd[491]: Finished loading, compiling and executing 4 rules
sept. 14 19:37:35 ordi polkitd[491]: Unregistered Authentication Agent for unix-session:1 (system bus name :1.1277, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale fr_FR.UTF-8) (disconnected from bus)
sept. 14 19:38:11 ordi polkitd[491]: Registered Authentication Agent for unix-session:7 (system bus name :1.3059 [/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale fr_FR.UTF-8)
sept. 14 19:54:19 ordi polkitd[491]: Unregistered Authentication Agent for unix-session:7 (system bus name :1.3059, object path /org/gnome/PolicyKit1/AuthenticationAgent, locale fr_FR.UTF-8) (disconnected from bus)
sept. 14 20:19:39 ordi polkitd[491]: Registered Authentication Agent for unix-session:11 (system bus name :1.3119 [/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale fr_FR.UTF-8)




Mes investigations : statut de l'utilisateur ? permissions ? gestion des fontes ?

Le mot de passe "utilisateur" et "root" sont pour l'instant identiques.

id :

Code : Tout sélectionner

uid=1000(lapstatial) gid=1000(lapstatial) groupes=1000(lapstatial),96(scanner),98(power),985(users),986(video),988(storage),990(optical),991(lp),994(disk),995(audio),998(wheel)
Droits "sudo" déclaré dans /etc/sudoers :

Code : Tout sélectionner

%wheel ALL=(ALL) ALL
lapstatial ALL=(ALL) ALL
En mode console, la commande "locale" donne le même résultat pour "root" et l'utilisateur :

Code : Tout sélectionner

LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

Code : Tout sélectionner

$ cat /etc/locale.conf 
LANG=fr_FR.UTF-8
LANGUAGE="fr_FR:en_US"
LC_COLLATE=C

Code : Tout sélectionner

$ grep -v '#' /etc/locale.gen
en_US.UTF-8 UTF-8  
fr_FR.UTF-8 UTF-8 

Code : Tout sélectionner

$ cat /etc/X11/xorg.conf.d/00-keyboard.conf 
Section "InputClass"
    Identifier         "Keyboard Layout"
    MatchIsKeyboard    "yes"
    Option             "XkbLayout"  "fr"
    Option             "XkbVariant" "latin9" # accès aux caractères spéciaux plus logique avec "Alt Gr" (ex : « » avec "Alt Gr" w x)
EndSection
Le commentaire ne correspond pas à ce que j'ai. Pour obtenir les guillemets à la française, je dois utiliser "AltGr z" et "AltGr x". Le mot de passe tapé dans un "lxterminal' n'est pas visuellement altéré. La saisie du mot de passe a aussi été essayée avec 'xterm".

J'ignore si c'est utile :

Code : Tout sélectionner

$ cat /etc/X11/xinit/xinitrc.d/50-systemd-user.sh
#!/bin/sh

systemctl --user import-environment DISPLAY XAUTHORITY

if command -v dbus-update-activation-environment >/dev/null 2>&1; then
    dbus-update-activation-environment DISPLAY XAUTHORITY
fi

Utilisation du script "locale-check.sh" en mode "console" :

Code : Tout sélectionner

* Parent:         1 /usr/lib/systemd/systemd --system --deserialize 23
 * Terminal:   12108 login -- lapstatial
 * Shell:      47046 -bash

notice: Also skipping term=parent checks.

Looks good, but you still need to check your terminal:  --> ★ <--
 * a star             -- font and terminal are okay.
 * 3 question marks   -- your terminal does not correctly interpret UTF-8.
 * a box or rectangle -- UTF-8 works fine, but you need a better font.
 * empty area         -- you really need a better font or something.

Utilisation du script "locale-check.sh" en mode "graphique" :

Code : Tout sélectionner

$ ~/bin/locale-check.sh
 * Parent:     12955 xfce4-session
 * Terminal:   13251 xfce4-terminal --geometry=80x21 --display :0.0 --role=xfce4-terminal-1599510356-836753215 --show-menubar --show-borders --hide-toolbar --active-tab --working-directory /home/lapstatial --window --geometry=79x43 --display :0.0 --role=xfce4-terminal-1599510300-4118929497 --show-menubar --show-borders --hide-toolbar --active-tab --working-directory /home/lapstatial --window --geometry=91x51 --display :0.0 --role=xfce4-terminal-1595141491-954356452 --show-menubar --show-borders --hide-toolbar --active-tab --working-directory /home/lapstatial/ --sm-client-id 22b201f84-3372-404f-b2ec-72e47edddfd4
 * Shell:      13338 bash

Looks good. ♥
 * You are using the fr_FR.UTF-8 locale.
 * Shell's locale matches terminal's locale.
 * Terminal's locale matches parent process locale. 

Pour rappel : tout passe en mode console, rien en mode graphique. Le mode graphique est lancé à la main.

Merci par avance pour votre aide.

Bonne journée.
laurent85
Elfe
Messages : 688
Inscription : mar. 16 oct. 2018, 21:05

Re: [XFCE4] ssh, su, sudo impossibles en graphique, mais possibles en console TTY.

Message par laurent85 »

Bonjour,
LapSpatial a écrit :
dim. 20 sept. 2020, 15:02
sept. 20 12:40:45 ordi sudo[47405]: lapstatial : 3 incorrect password attempts ; TTY=pts/1 ; PWD=/home/lapstatial ; USER=root ; COMMAND=/bin/bash
Vérifie que le mot de passe saisi en clair correspond aux caractères attendus.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
LapSpatial
newbie
Messages : 5
Inscription : dim. 20 sept. 2020, 13:28

Re: [XFCE4] ssh, su, sudo impossibles en graphique, mais possibles en console TTY.

Message par LapSpatial »

laurent85 a écrit :
dim. 20 sept. 2020, 16:12
Bonjour,
LapSpatial a écrit :
dim. 20 sept. 2020, 15:02
sept. 20 12:40:45 ordi sudo[47405]: lapstatial : 3 incorrect password attempts ; TTY=pts/1 ; PWD=/home/lapstatial ; USER=root ; COMMAND=/bin/bash
Vérifie que le mot de passe saisi en clair correspond aux caractères attendus.
Bon conseil :bravo:

J'avais vérifié en mode graphique, mais c'est en mode console que ça foire :shock:
C'est bien la première fois que je vois cela.
Que le clavier AZERTY habituel ne soit pas reconnu en mode console complètement, je ne l'avais pas imaginé.

Comment résoudre le problème ?
LapSpatial
newbie
Messages : 5
Inscription : dim. 20 sept. 2020, 13:28

Re: [XFCE4] ssh, su, sudo impossibles en graphique, mais possibles en console TTY.

Message par LapSpatial »

J'ai trouvé et modifié /etc/vconsole :

Code : Tout sélectionner

 cat /etc/vconsole.conf 
KEYMAP=fr-latin9
# FONT=police
FONT_MAP=fr-latin9
Comment définir la fonte "FONT" ?

Dommage que dans le wiki https://wiki.archlinux.fr/Vconsole, il y est :

Code : Tout sélectionner

Pour l'établir au niveau système, vous pouvez ajouter au fichier /etc/vconsole.conf :

KEYMAP=fr
Pourquoi ne pas mettre tout de suite "fr-latin9" ?
benjarobin
Maître du Kyudo
Messages : 16075
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [XFCE4] ssh, su, sudo impossibles en graphique, mais possibles en console TTY.

Message par benjarobin »

Salut, le plus simple est de modifier ton mot de passe depuis le console tty par quelque chose de simple (de manière temporaire)
Puis de vérifier que le login en session graphique fonctionne.
Et finalement vérifier la configuration du clavier sous Xorg (/etc/X11/xorg.conf.d/00-keyboard.conf) et de la console tty(/etc/vconsole.conf)

Personnellement dans /etc/vconsole.conf j'ai

Code : Tout sélectionner

KEYMAP=fr-latin9
FONT=lat9w-16
FONT_MAP=
Et dans /etc/X11/xorg.conf.d/00-keyboard.conf

Code : Tout sélectionner

# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "fr"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "oss_latin9"
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
LapSpatial
newbie
Messages : 5
Inscription : dim. 20 sept. 2020, 13:28

Re: [XFCE4] ssh, su, sudo impossibles en graphique, mais possibles en console TTY. [Résolu]

Message par LapSpatial »

Merci beaucoup pour l'aide.

Le "KEYMAP=fr-latin9" résout le problème. Comme je démarre à la main X11, aucun souci.
Je vais essayer de voir ce que donne la police avec "FONT=lat9w-16".

Bonne soirée à tous et :merci:
Avatar de l’utilisateur
RoyalPanda
yeomen
Messages : 211
Inscription : lun. 19 mai 2014, 09:08

Re: [XFCE4] ssh, su, sudo impossibles en graphique, mais possibles en console TTY.

Message par RoyalPanda »

:resolu:
Répondre