[Gestion d'énergie] Désactiver la mise en veille automatique (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
freegreg
newbie
Messages : 3
Inscription : dim. 20 sept. 2020, 17:52

[Gestion d'énergie] Désactiver la mise en veille automatique (résolu)

Message par freegreg »

Bonjour la communauté ArchLinux !

Je suis un nouvel utilisateur d'Arch. Plutôt habitué de Debian, et tombant souvent sur le wiki d'Arch quand je cherche des infos techniques, je me suis fait un devoir d'enfin l'essayer.

J'ai donc installé cette distrib récemment sur un ordi de bureau un peu ancien (i7-2600K), avec dans la foulée xorg et Gnome histoire de voir comment ça tourne. Bah nickel !

Mais bon le bureau c'est pas vraiment le but à part occasionnellement, c'est plutôt pour une utilisation headless en SSH.

C'est là que mon problème de veille survient : au bout d'une heure, systématiquement, l'ordi se met en veille (suspend to RAM je pense : bouton power qui clignote, ventilo et disques à l'arrêt, rallumage super rapide) et ce même si je suis en train de m'en servir par SSH.


N'étant pas familier de la gestion d'énergie, je me log dans l'interface graphique, trouve l'option de mise en veille auto, la désactive. Je ne sais plus si je me déconnecte ou pas de l'interface mais la machine reste enfin allumée.

Par contre, au démarrage suivant, rebelote, mise en veille après 60 minutes. En fait, le réglage que j'ai fait ne fonctionne que quand je suis connecté dans l'interface graphique et ça ne correspond pas à mon besoin, j'aimerais pouvoir y déployer des services et pouvoir m'y connecter à distance quand nécessaire, donc pas de mise en veille.

Après quelques heures de recherche sur les moteurs et le wiki, je ne trouve pas de solution ni même de personne ayant le même problème.
Il me semble que c'est lié à l'interface graphique qui fait du zèle mais ce n'est qu'un hypothèse.

Comment désactiver ce système de veille de façon globale au système ?

Merci des réponses que vous pourrez m'apporter :)


PS: le BIOS de la machine ne présente aucune option type "ACPI" à part l'action à faire quand le courant revient après coupure et différents moyens d'allumage type Wake on LAN.
Dernière modification par freegreg le dim. 20 sept. 2020, 23:21, modifié 1 fois.
benjarobin
Maître du Kyudo
Messages : 16075
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Gestion d'énergie] Désactiver la mise en veille automatique

Message par benjarobin »

Bonjour,
Sans aucune interface graphique de lancée le PC ne se met jamais en veille.
Donc c'est ton interface graphique (ou ton login manager) qui met le PC en veille. Tu utilises GDM ?
Je ne connais pas vraiment GDM, as tu regardé ceci : https://unix.stackexchange.com/question ... ock-screen
Il y a même une page sur le Wiki : https://wiki.archlinux.org/index.php/GD ... NOME_3.28)
Donc tu veux sûrement ceci :

Code : Tout sélectionner

sudo -u gdm dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'nothing'
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
freegreg
newbie
Messages : 3
Inscription : dim. 20 sept. 2020, 17:52

Re: [Gestion d'énergie] Désactiver la mise en veille automatique

Message par freegreg »

Oui c'est GDM. Je vais essayer et je vous tiens au courant, merci !
freegreg
newbie
Messages : 3
Inscription : dim. 20 sept. 2020, 17:52

Re: [Gestion d'énergie] Désactiver la mise en veille automatique (résolu)

Message par freegreg »

Ça semble fonctionner, merci bien !
Répondre