[Xterm] clavier qwerty (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
banditblue
Elfe
Messages : 556
Inscription : dim. 10 janv. 2010, 10:19

[Xterm] clavier qwerty (résolu)

Message par banditblue »

Bonjour la communauté

apres avoir installé la base , je n'ai eu aucun probleme avec ca, puis me suis attaqué avec openbox et juste pour tester j'ai lancé xterm, qui lui est en qwerty
comment fait-on pour le mettre en francais sachant que le fichier /etc/X11/xorg-conf.d/10-keyboard.conf est bien configuré

Code : Tout sélectionner

"/etc/X11/xorg.conf.d/00-keyboard.conf"

Section "InputClass"
    Identifier         "Keyboard Layout"
    MatchIsKeyboard    "yes"
    Option             "XkbLayout"  "fr"
    Option             "XkbVariant" "latin9"
EndSection
Dernière modification par banditblue le dim. 04 oct. 2020, 11:45, modifié 1 fois.
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- Z170A Sli Plus, I7-6700K, GTX980, 24Go DDR4, SSD 860 EVO 500Go, SSD 830 Serie,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> Clique ICI
Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10615
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Xterm] clavier qwerty (en cour)

Message par FoolEcho »

Salut,

À moins qu'il s'agisse d'une coquille, préfixer le fichier par 00 n'est pas forcément un bon plan (ça lui donne une priorité maximale), mettre au moins 10.

Si ça ne vient pas de là, il faudra récupérer le log de X (/var/log/Xorg.0.log) et celui de la session (qui dépend de comment tu lances openbox, ça peut être ta session utilisateur ou le gestionnaire de connexion qui écrase le paramétrage de X ).
«The following statement is not true. The previous statement is true.» :nage:
Avatar de l’utilisateur
banditblue
Elfe
Messages : 556
Inscription : dim. 10 janv. 2010, 10:19

Re: [Xterm] clavier qwerty (en cour)

Message par banditblue »

actuellement je n'ai pas de gestionnaire de connexion
juste installé Openbox et en mode commande de ligne pour le lancer, j’exécute startx

je vais modifier le fichier
"/etc/X11/xorg.conf.d/00-keyboard.conf"
par

Code : Tout sélectionner

"/etc/X11/xorg.conf.d/05-keyboard.conf"
je vais essayer de récupérer le fichier suivant pour le mettre sur Pastebin si cela fonctionne
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- Z170A Sli Plus, I7-6700K, GTX980, 24Go DDR4, SSD 860 EVO 500Go, SSD 830 Serie,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> Clique ICI
Avatar de l’utilisateur
banditblue
Elfe
Messages : 556
Inscription : dim. 10 janv. 2010, 10:19

Re: [Xterm] clavier qwerty (résolu)

Message par banditblue »

il s'avére que j'ai fait une faute de frappe dans le fichier

Code : Tout sélectionner

"/etc/X11/xorg.conf.d/05-keyboard.conf"
celle de mettre un tiret du 6 entre latin et 9, qui bien évidemment n'est pas reconnu et que j'ai retirer de suite

Code : Tout sélectionner

Option             "XkbVariant" "latin9"
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- Z170A Sli Plus, I7-6700K, GTX980, 24Go DDR4, SSD 860 EVO 500Go, SSD 830 Serie,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> Clique ICI
Répondre