[fbpanel] Erreur de compilation (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
banditblue
Elfe
Messages : 556
Inscription : dim. 10 janv. 2010, 10:19

[fbpanel] Erreur de compilation (résolu)

Message par banditblue »

salut la team, j’essaie tant bien que mal d'installer fbpanel, sans succès
quand j’édite le pkgbuild, je ne sais pas quoi faire !!! idem que se soit en selection 1 ou 2 depuis yaourt

Code : Tout sélectionner

[moi@ArchLinuxi7 ~]$ yaourt fbpanel
1 aur/fbpanel 7.0-2 (4) (0,00)
    NetWM compliant desktop panel
2 aur/fbpanel-git 44.478754b-2 (6) (0,00)
    NetWM compliant desktop panel (git)
==> Numéro(s) des paquets à installer (ex: 1 2 3 ou 1-3)
==> ----------------------------------------------------
==> 2


==> Téléchargement du PKGBUILD de fbpanel-git depuis AUR...
x .SRCINFO
x .gitignore
x PKGBUILD
bidulock commented on <a href="#comment-452370" class="date">2014-08-29 04:21</a>                        
you also need --mandir=/usr/share/man --libexecdir=/usr/lib

Calimero commented on <a href="#comment-452498" class="date">2014-08-29 22:07</a>                        
Yes, I'm checking out r515 on purpose, as you noticed. Any revision between 516 and 521 breaks the localization.
I tried adding the files by hand in install() and it didn't work, so since there is no new feature in 521, I forced the revision to 515.
You can define the desired revision manually in the PKGBUILD, or simply remove ”#revision=515” in the source array. You won't notice the breakage if you have an English locale.
Of course the bugs are reported, but I'm afraid this is going to take years to get fixed. (it's already been 3 years)

bidulock commented on <a href="#comment-474264" class="date">2015-01-07 11:39</a>                        
Correction: you need --mandir=/usr/share/man/man1 to get the manual page in the correct place.

bidulock commented on <a href="#comment-505156" class="date">2015-07-21 04:35</a>                        
Why is the PKGBUILD locked to revision 515?  Revsion 521 is available, just remove the patch and it builds.

Calimero commented on <a href="#comment-505896" class="date">2015-07-28 21:24</a>                        
bidulock: look two comments ahead.

fbpanel-git 44.478754b-2  (2017-02-10 22:59)
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> n

==> Dépendances de fbpanel-git :
 - gtk2 (déjà installé)
 - python2 (déjà installé)
 - automake (déjà installé) [makedepend]
 - autoconf (déjà installé) [makedepend]


==> Lancer la compilation de fbpanel-git ? [O/n]
==> --------------------------------------------
==> 
==> Construction et installation du paquet
==> Création du paquet fbpanel-git 44.478754b-2 (dim. 04 oct. 2020 14:18:14)
==> Vérification des dépendances pour l’exécution…
==> Vérification des dépendances pour la compilation…
==> Récupération des sources…
  -> Clonage du dépôt fbpanel git…
Clonage dans le dépôt nu '/tmp/yaourt-tmp-moi/aur-fbpanel-git/fbpanel'
remote: Enumerating objects: 399, done.
remote: Counting objects: 100% (399/399), done.
remote: Compressing objects: 100% (238/238), done.
remote: Total 1176 (delta 190), reused 280 (delta 121), pack-reused 777
Réception d'objets: 100% (1176/1176), 3.83 Mio | 4.29 Mio/s, fait.
Résolution des deltas: 100% (512/512), fait.
==> Validation des fichiers source avec sha512sums…
    fbpanel ... Ignoré
==> Extraction des sources…
  -> Création d’une copie de travail du dépot fbpanel git…
Clonage dans 'fbpanel'...
fait.
==> Lancement de prepare()…
Created config.mk
Created config.h
Configuration:
  Sound plugin:  yes
==> Lancement de pkgver()…
==> Lancement de build()…
 TEXT   default
 TEXT   pager
 TEXT   fbpanel.1
 TEXT   make_profile
 CC     panel/bg.o
 CC     panel/ev.o
 CC     panel/gconf.o
 CC     panel/gconf_panel.o
 CC     panel/gconf_plugins.o
 CC     panel/gtkbar.o
 CC     panel/gtkbgbox.o
 CC     panel/misc.o
 CC     panel/panel.o
 CC     panel/plugin.o
 CC     panel/run.o
 CC     panel/xconf.o
 BIN    panel/fbpanel
make[1]: *** [../.config/rules.mk:276 : fbpanel] Erreur 1
make: *** [.config/rules.mk:46 : panel] Erreur 2
==> ERREUR : Une erreur s’est produite dans build().
    Abandon…
==> ERREUR : Makepkg n'a pas pu construire fbpanel-git.
==> Relancer la compilation de fbpanel-git ? [o/N]
==> ----------------------------------------------
Dernière modification par banditblue le dim. 04 oct. 2020, 21:05, modifié 1 fois.
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- Z170A Sli Plus, I7-6700K, GTX980, 24Go DDR4, SSD 860 EVO 500Go, SSD 830 Serie,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> Clique ICI
Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2072
Inscription : jeu. 15 mars 2012, 05:08

Re: [fbpanel] Erreur de compilation (en cour)

Message par waitnsea »

banditblue a écrit :
dim. 04 oct. 2020, 14:23
salut la team, j’essaie tant bien que mal d'installer fbpanel, sans succès
quand j’édite le pkgbuild, je ne sais pas quoi faire !!! idem que se soit en selection 1 ou 2 depuis yaourt
Bonjour,
sur le site AUR tu n'es pas le seul, et le paquet n'a plus été modifié depuis le 2018-01-06
Avatar de l’utilisateur
banditblue
Elfe
Messages : 556
Inscription : dim. 10 janv. 2010, 10:19

Re: [fbpanel] Erreur de compilation (en cour)

Message par banditblue »

waitnsea a écrit :
dim. 04 oct. 2020, 18:03
banditblue a écrit :
dim. 04 oct. 2020, 14:23
salut la team, j’essaie tant bien que mal d'installer fbpanel, sans succès
quand j’édite le pkgbuild, je ne sais pas quoi faire !!! idem que se soit en selection 1 ou 2 depuis yaourt
Bonjour,
sur le site AUR tu n'es pas le seul, et le paquet n'a plus été modifié depuis le 2018-01-06
merci pour l'information, je vais essayer de trouver quelque chose qui y ressemble

alors je viens de faire un tour sur AUR et en relisant les commentaire j'ai pu telecharger fbpanel avec cette commande

Code : Tout sélectionner

$ sudo pacman -U https://archive.org/download/archlinux_pkg_fbpanel/fbpanel-7.0-2-x86_64.pkg.tar.xz
ensuite une copie de usr/share/fbpanel vers mon /home/moi that's all
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- Z170A Sli Plus, I7-6700K, GTX980, 24Go DDR4, SSD 860 EVO 500Go, SSD 830 Serie,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> Clique ICI
Répondre