[Thème] Installation de carte graphique

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
obelix1502
Daikyu
Messages : 69
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

[Thème] Installation de carte graphique

Message par obelix1502 »

Bonjour,

Pour l'installation, je me débrouille. Je suis en dual-boot avec Manjaro-KDE.

Mais, je ne parviens pas à me dépatouiller avec l'installation de la carte graphique qui une NVIDIA Corporation GP107 [GeForce GTX 1050].

D'après tout ce que j'ai lu sur le Wiki, je devrais installer le pilote propriétaire NVIDIA, mais en plus, cette carte bénéficierait de la technologie OPTIMUS.

Bref, je ne parviens pas à installer la carte propriétaire et à la faire fonctionner.

J'ai pris comme environnement de bureau Cinnamon. Et j'ai des hurlantes quant à la carte qui me dit que l'accélération n'est pas installée et que ça me bouffe du CPU.

Il faut dire que le Wiki d'Arch est bien fait, mais pour l'installation des cartes graphiques, c'est un vrai challenge : Je dois bien ouvrir six pages différentes et lire durant je ne sais plus combien de temps pour à la fin n'y rien comprendre.

Je croyais l'avoir bien installée, mais non.

Donc, si vous pouviez, très simplement, m'aider, ce serais sympa.

Merci à tous. :D :D
CPU : 6 x Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz
Carte graphique : NVIDIA Corporation GP107 [GeForce GTX 1050]
Audio : NVIDIA Corporation GP107GL High Definition Audio Controller
Network controller : Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
PCI bridge : Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16)
Host bridge : Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers
Ram : 16 Go
benjarobin
Maître du Kyudo
Messages : 16006
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Thème] Installation de carte graphique

Message par benjarobin »

Bonjour,
C'est un PC portable comme tu fais référence à la technologie OPTIMUS ?
Peux tu donner le log de Xorg complet (généralement ici : /var/log/Xorg.0.log, vérifie la date...) ainsi que la sortie de :

Code : Tout sélectionner

pacman -Qs "nvidia|libglvnd|mesa"
grep -Evr "^ *$|^ *#" /etc/X11/xorg*
lsmod | grep -E "nouveau|nv"
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
obelix1502
Daikyu
Messages : 69
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

Re: [Thème] Installation de carte graphique

Message par obelix1502 »

Merci à toi de bien vouloir m'aider.

Je suis en pleine installation donc je dois te donner tous les retours à la main.

Première commande :

Code : Tout sélectionner

local/libvdpau 1.4-1
	Nvidia VDPAU library
Deuxième commande : ne retourne rien

Troisième commande, donc lsmod | grep -E "nouveau|nv" :

Code : Tout sélectionner

nouveau			2326520	1	
mxm_wmi			16384	1	nouveau	
i2c_algo_bit			221184	1	nouveau
ttm			118784	1	nouveau
drm_kms_helper			221184	1	nouveau
wmi			36864	4	hp_wmi,wmi_bmof,mxm_wmi,nouveau
drm			520192	4	drm_kms_helper,ttm,nouveau
agpgart			53248	3	ttm,nouveau,drm
Pour le log de Xorg, je n'ai pas encore le dossier,je suis occupé à l'installation, je dois seulement installer la partie graphique. :o :o

J'ai rebooté et j'ai une erreur :

Code : Tout sélectionner

error: no such device: eca723de-1a3b-4bed-9eb9-d6ed26dc47fa
error: disk 'hd2,gp1' not found
error: you need to loadthe kernel first
:oops: :oops: :oops:
Dernière modification par obelix1502 le mar. 20 oct. 2020, 21:37, modifié 1 fois.
CPU : 6 x Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz
Carte graphique : NVIDIA Corporation GP107 [GeForce GTX 1050]
Audio : NVIDIA Corporation GP107GL High Definition Audio Controller
Network controller : Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
PCI bridge : Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16)
Host bridge : Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers
Ram : 16 Go
benjarobin
Maître du Kyudo
Messages : 16006
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Thème] Installation de carte graphique

Message par benjarobin »

obelix1502 a écrit :
mar. 20 oct. 2020, 21:04
Pour le log de Xorg, je n'ai pas encore le dossier,je suis occupé à l'installation, je dois seulement installer la partie graphique.
obelix1502 a écrit :
mar. 20 oct. 2020, 14:22
J'ai pris comme environnement de bureau Cinnamon. Et j'ai des hurlantes quant à la carte qui me dit que l'accélération n'est pas installée et que ça me bouffe du CPU.
C'est un peu contradictoire... Et d'après les commandes tu n'as rien installé, pas installé les drivers nvidia, pas configuré, rien fait... Donc cela ne risque pas de fonctionner
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
obelix1502
Daikyu
Messages : 69
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

Re: [Thème] Installation de carte graphique

Message par obelix1502 »

Non, je n'ai plus cinnamon. J'ai tout formaté et tout recommencé

Je dois encore installer la partie graphique, mais maintenant,je ne sais plus booter. J'ai l'erreur décrite plus haut :

Code : Tout sélectionner

error: no such device: eca723de-1a3b-4bed-9eb9-d6ed26dc47fa
error: disk 'hd2,gp1' not found
error: you need to loadthe kernel first
CPU : 6 x Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz
Carte graphique : NVIDIA Corporation GP107 [GeForce GTX 1050]
Audio : NVIDIA Corporation GP107GL High Definition Audio Controller
Network controller : Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
PCI bridge : Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16)
Host bridge : Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers
Ram : 16 Go
obelix1502
Daikyu
Messages : 69
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

Re: [Thème] Installation de carte graphique

Message par obelix1502 »

J'ai installé le paquet nvidia et nouveau.
J'ai aussi installé XFCE comme bureau et je n'ai pas d'hurlante graphique.
Donc, ça a l'air de fonctionner.
Il faut maintenant que j'apprivoise la bête : quelle différence avec Manjaro ou pamac s'affiche directement.
Puis, installer yay : quelle galère. J'ai voulu faire l'installation dans /tmp avec git, mais quand je voulais faire # chown -R obelix:obelix ./yay-git à chaque fois l'erreur "obelix et groupe".
Je l'ai donc installé, toujours avec git, mais à partir de mon /home.
Pourtant l'utilisateur obelix appartient au groupe "wheel" qui si je ne m'abuse renvoie vers le groupe "root" donc je pensais que cela fonctionnerait. Mais non. J'essaie toujours de comprendre.
CPU : 6 x Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz
Carte graphique : NVIDIA Corporation GP107 [GeForce GTX 1050]
Audio : NVIDIA Corporation GP107GL High Definition Audio Controller
Network controller : Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
PCI bridge : Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16)
Host bridge : Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers
Ram : 16 Go
NerdyWinter
newbie
Messages : 1
Inscription : mer. 21 oct. 2020, 01:49

Re: [Thème] Installation de carte graphique

Message par NerdyWinter »

obelix1502 a écrit :
mer. 21 oct. 2020, 01:39
Puis, installer yay : quelle galère. J'ai voulu faire l'installation dans /tmp avec git, mais quand je voulais faire # chown -R obelix:obelix ./yay-git à chaque fois l'erreur "obelix et groupe".
Je l'ai donc installé, toujours avec git, mais à partir de mon /home.
Pourtant l'utilisateur obelix appartient au groupe "wheel" qui si je ne m'abuse renvoie vers le groupe "root" donc je pensais que cela fonctionnerait. Mais non. J'essaie toujours de comprendre.
Pour installer un paquet sans wrapper :

Code : Tout sélectionner

git clone https://aur.archlinux.org/yay-git.git
cd yay-git
makepkg -si
Est-ce que tu as pensé à décommenter la ligne %wheel ALL=(ALL) ALL ?
Vérifie avec su -c visudo

Pourquoi est-ce que tu as installé nouveau ET nvidia... ?
Tu as une GTX 750 donc les paquets à installer sont : nvidia, nvidia-utils et lib32-nvidia-utils (au besoin pour celui-ci)
obelix1502
Daikyu
Messages : 69
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

Re: [Thème] Installation de carte graphique

Message par obelix1502 »

Merci de ta réponse.

J'ai bien décoché la ligne : %wheel ALL=(ALL) ALL avec visudo (il m'a fallu d'ailleurs me remémorer les commandes de vi :D )

Je vais voir ceci le plus vite possible car :

je me logue depuis hier sans problème.

Et ce matin, le démarrage reste bloqué sur "Reached target graphical interface" avec le curseur clignotant en dessous.

J'avais pensé que c'était du fait que j'ai monté un disque dans fstab (qui a été auparavant monté dans /mnt/disque1, mais en tty, fstab est en lecture seulement !! Et même en root, je ne peux changer les droits sur le fichier. :shock: :shock:

Là, je ne vois pas ce que je peux faire.

Merci. Mais dès que j'ai accès au terminal, j'installe les bons drivers pour la carte graphique. Ma signature n'est plus à jour, j'ai la NVIDIA 1050 GTX maintenant. :D :D
CPU : 6 x Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz
Carte graphique : NVIDIA Corporation GP107 [GeForce GTX 1050]
Audio : NVIDIA Corporation GP107GL High Definition Audio Controller
Network controller : Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
PCI bridge : Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16)
Host bridge : Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers
Ram : 16 Go
obelix1502
Daikyu
Messages : 69
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

Re: [Thème] Installation de carte graphique

Message par obelix1502 »

Je suis parvenu, grâce à Manjaro à modifier mon fstab.

C'est bien lui qui coinçait, mais je m'attendais à avoir un kernel panic et pas être coincé sur "Reached target graphical interface".

MAIS au redémarrage, il affiche ma page d'identification, mais n'accepte plus mon mot de passe : je vais manger la clé si cela continue. :D :D

Comment puis-je faire en live pour remettre mon mot de passe ?
CPU : 6 x Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz
Carte graphique : NVIDIA Corporation GP107 [GeForce GTX 1050]
Audio : NVIDIA Corporation GP107GL High Definition Audio Controller
Network controller : Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
PCI bridge : Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16)
Host bridge : Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers
Ram : 16 Go
laurent85
Elfe
Messages : 670
Inscription : mar. 16 oct. 2018, 21:05

Re: [Thème] Installation de carte graphique

Message par laurent85 »

Bonjour,
Regarde le sujet sur cette page du wiki https://wiki.archlinux.org/index.php/Re ... t_password
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
Répondre