[GRUB] Dual boot windows grub en invite de commande (Résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
PowaBanga
archer
Messages : 129
Inscription : mar. 12 sept. 2017, 21:15

[GRUB] Dual boot windows grub en invite de commande (Résolu)

Message par PowaBanga »

Salut à tous

j'ai installé archlinux en dualboot avec windows, mais je rencontre un souci avec grub.
Par facilité, j'ai repartitionné mes disques dur ave gparted via un liveusb d'ubuntu, j'ai ensuite reformaté mes partitions individuellement avec fdisk.
L'installation s'est bien déroulée, et donc, pour l'instant je sais choisir de lancer windows (qui fonctionne nickel) ou linux directement depuis le boot si je veux, je ne me préoccupe donc pas des masse d'insérer le démarrage de windows dans grub
je suis en uefi donc, et j'ai lancé la commande en chroot :

Code : Tout sélectionner

grub-install --target=x84_64-efi --efi-directory=/boot --bootloader-id=Archlinux
grub-mkconfig -o /boot/grub/grub.cfg
mais il y a un truc qui a fail, ca n'aurait pas dû pourtant...
grub démarre, mais sur un invite de commande genre

Code : Tout sélectionner

Édition de ligne basique de type Bash possible. ...
grub>
Quelqu'un saurait-il m'aider ?
Dernière modification par PowaBanga le dim. 28 mars 2021, 12:44, modifié 1 fois.
benjarobin
Maître du Kyudo
Messages : 16161
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [GRUB] Dual boot windows grub en invite de commande

Message par benjarobin »

Bonjour,
Ce n'est clairement pas une installation typique de Grub ?
As tu une partition ESP ? Une partition de boot ? Comment tout cela est monté ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
PowaBanga
archer
Messages : 129
Inscription : mar. 12 sept. 2017, 21:15

Re: [GRUB] Dual boot windows grub en invite de commande

Message par PowaBanga »

Alors concernant la partition "ESP", soit j'ai pas bien compris un détail, soit j'en ai jamais fait, et ça a toujours bien fonctionné.

enfin bref, voici les réponses des commande que j'ai récupéré via x0.at (ca a mi des caractère spéciaux un peu partout, mais ca ne fonctionnait pas avec ix.io...):

Code : Tout sélectionner

fdisk -l 
Disque /dev/nvme0n1Â : 238,47 GiB, 256060514304Â octets, 500118192Â secteurs
Modèle de disque : SK hynix PC401 HFS256GD9TNG-62A0A       
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique)Â : 512Â octets / 512Â octets
taille d'E/S (minimale / optimale)Â : 512Â octets / 512Â octets
Type d'étiquette de disque : gpt
Identifiant de disque : 8A4B6931-07E7-420D-87D7-AA535BF65553

Périphérique       Début       Fin  Secteurs Taille Type
/dev/nvme0n1p1      2048    534527    532480   260M Système EFI
/dev/nvme0n1p2    534528    567295     32768    16M Réservé Microsoft
/dev/nvme0n1p3    567296 333912063 333344768   159G Données de base Microsoft
/dev/nvme0n1p4 333912064 334960639   1048576   512M Système EFI
/dev/nvme0n1p5 334960640 483733503 148772864  70,9G Système de fichiers Linux
/dev/nvme0n1p6 483733504 500118158  16384655   7,8G Partition d'échange Linux


Disque /dev/sda : 931,51 GiB, 1000204886016 octets, 1953525168 secteurs
Modèle de disque : HGST HTS541010B7
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique)Â : 512Â octets / 4096Â octets
taille d'E/S (minimale / optimale)Â : 4096Â octets / 4096Â octets
Type d'étiquette de disque : gpt
Identifiant de disque : 4DCDA4F0-E410-4DE2-95D9-D6822446CE71

Périphérique      Début        Fin   Secteurs Taille Type
/dev/sda1          2048  629147647  629145600   300G Données de base Microsoft
/dev/sda2    1917784064 1953523711   35739648    17G Données de base Microsoft
/dev/sda3     629147648 1917784063 1288636416 614,5G Système de fichiers Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque.
Mauvaise concordance des tailles de partition du secteur d'amorçage GPT (2375031 != 61341695), elles seront corrigées par l'écriture.


Disque /dev/sdb : 29,25 GiB, 31406948352 octets, 61341696 secteurs
Modèle de disque : Cruzer Blade    
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique)Â : 512Â octets / 512Â octets
taille d'E/S (minimale / optimale)Â : 512Â octets / 512Â octets
Type d'étiquette de disque : gpt
Identifiant de disque : 31323032-3130-4830-B130-303131343334

Périphérique   Début     Fin Secteurs Taille Type
/dev/sdb1         64 2249439  2249376   1,1G Système de fichiers Linux
/dev/sdb2    2249440 2374367   124928    61M Système EFI
/dev/sdb3    2374368 2374967      600   300K Données de base Microsoft


Disque /dev/loop0Â : 1,01 GiB, 1086939136Â octets, 2122928Â secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique)Â : 512Â octets / 512Â octets
taille d'E/S (minimale / optimale)Â : 512Â octets / 512Â octets

donc là je commence par un

Code : Tout sélectionner

mkdir mnt
et ici comme archlinux est déjà installé, je fait donc :

Code : Tout sélectionner

mount /dev/nvme0n1p5 mnt
mount /dev/nvme0n1p4 mnt/boot
mount /dev/sda3 mnt/home
swapon /dev/nvme0n1p6
de nouveau x0.at met des caractères spéciaux partout mais l'info est lisible :

Code : Tout sélectionner

lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0         7:0    0     1G  1 loop /run/archiso/sfs/airootfs
sda           8:0    0 931,5G  0 disk 
├─sda1        8:1    0   300G  0 part 
├─sda2        8:2    0    17G  0 part 
└─sda3        8:3    0 614,5G  0 part /root/mnt/home
sdb           8:16   1  29,3G  0 disk 
├─sdb1        8:17   1   1,1G  0 part /run/archiso/bootmnt
├─sdb2        8:18   1    61M  0 part 
└─sdb3        8:19   1   300K  0 part 
nvme0n1     259:0    0 238,5G  0 disk 
├─nvme0n1p1 259:1    0   260M  0 part 
├─nvme0n1p2 259:2    0    16M  0 part 
├─nvme0n1p3 259:3    0   159G  0 part 
├─nvme0n1p4 259:4    0   512M  0 part /root/mnt/boot
├─nvme0n1p5 259:5    0  70,9G  0 part /root/mnt
└─nvme0n1p6 259:6    0   7,8G  0 part [SWAP]
puis là je fais :

Code : Tout sélectionner

arch-chroot mnt
grub-install --target=x84_64-efi --efi-directory=/boot --bootloader-id=Archlinux
Installation pour la plate-forme X86_64-efi.
Installation terminée, sans erreur.
grub-mkconfig -o /boot/grub/grub.cfg
generating grub configuration file ...
done
[EDIT]
J'ai finalement réglé ce souci en mettant ma clef usb à jour.
Répondre