[problème de demarrage] archlinux ne demarre pas

Questions et astuces concernant l'installation et la configuration d'archlinux
bricomega
Hankyu
Messages : 26
Inscription : ven. 17 janv. 2020, 16:53

[problème de demarrage] archlinux ne demarre pas

Message par bricomega »

Bonjour
j'ai un pc en double boot,windows 10,debian buster,j'ai installé en troisieme distro archlinux avec l'installeur anarchy linux,l'installation s'est bien passée,quand j'ai redemarré la machine grub ne mentionnait pas archlinux,j'ai donc fait un update-grub sous debian qui gere grub,j'ai redemarré la machine,cette fois l'entrée arch est bien presente dans grub mais quand je veux demarrer arch ça ne demarre pas
il doit y avoir un problème car quand je fait un update-grub la machine tourne pendant un long moment et chauffe avant de donner le resultat
voila le resultat de update-grub avec debian

Code : Tout sélectionner

jean@jean:~$ sudo update-grub
[sudo] Mot de passe de jean : 
Création du fichier de configuration GRUB…
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Image Linux trouvée : /boot/vmlinuz-4.19.0-16-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.19.0-16-amd64
Image Linux trouvée : /boot/vmlinuz-4.19.0-14-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.19.0-14-amd64
Windows Boot Manager trouvé sur /dev/sdb1@/EFI/Microsoft/Boot/bootmgfw.efi
Arch Linux trouvé sur /dev/sdb6
Adding boot menu entry for EFI firmware configuration
fait
jean@jean:~$ 
si quelqu'un peut m'aider
merci
Avatar de l’utilisateur
papajoke
Elfe
Messages : 615
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [problème de demarrage] archlinux ne demarre pas

Message par papajoke »

re-bonjour

normal et déjà répondu (3 ème même sujet ...)
papajoke a écrit :
mar. 23 mars 2021, 16:52
Avoir grub sur ta debian ne veut rien dire et normalement debian ne sait pas gérer une entrée valide pour archlinux (micro-code)
donc tu reviens exactement au même point qu'il y a un mois ... installer archlinux ou une autre distribution basée sur arch ne changera rien au grub de debian
Cette incompatibilité existe depuis au moins 5 ans, donc existe pas mal de littérature ici et sur le web en général à ce sujet
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau
bricomega
Hankyu
Messages : 26
Inscription : ven. 17 janv. 2020, 16:53

Re: [problème de demarrage] archlinux ne demarre pas

Message par bricomega »

bonjour papajpke
donc ,je fais quoi ?je renonce à installer arch ?la premiere fois que j'avais installé arch sur la même machine je l'avais installée avec anarchy et j'avais pas eu de problème et ça remonte à moins de 5ans,suite au plantage d'arch il y a un mois j'avais installé une open suse ,et j'avais du faire la même manip update-grub dans debian et ça avait fonctionné sans problème,j'avais l'entrée suse dans grub et dans l'uefi,et dans ma premiere installation de arch j'avais aussi l'entrée dans grub et dans l'uefi,alors que actuellement j'ai l'entrée arch dans grub mais pas dans l'uefi,ça m'embête de laisser tomber car j'aime bien arch,
Avatar de l’utilisateur
papajoke
Elfe
Messages : 615
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [problème de demarrage] archlinux ne demarre pas

Message par papajoke »

bricomega a écrit :
ven. 23 avr. 2021, 05:46
j'avais pas eu de problème et ça remonte à moins de 5ans,
C'est que tu utilisais le grub de arch :wink: avec une petite recherche ici tu aurais du trouver pas mal de vieux sujets là dessus 1 2 et donc la façon de faire

Comme dis dans tes autres sujets, le plus simple est d'installer le grub arch , je ne connais pas ton installateur et tu ne veux pas faire de chroot donc il faut oublier ? (possible aussi d'éditer manuellement les entrées dans grub)
Sinon, avec ta debian (même avec un grub arch), tu peux utiliser une entrée "custum" dans grub, mais pourquoi demander puisque tu connais
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau
bricomega
Hankyu
Messages : 26
Inscription : ven. 17 janv. 2020, 16:53

Re: [problème de demarrage] archlinux ne demarre pas

Message par bricomega »

re
a priori c'est l'uefi qui a un probleme,j'ai reinstallé une suze pour voir,dans debian j'ai fait update-grub,maintenant j'ai mes trois entrées operationnelles dans grub,debian,windows boot manager et suze,par contre dans le boot uefi ,j'ai bien trois entrées ,windows boot manager ,mais par contre j'ai deux debian,je n'ai pas suze
Avatar de l’utilisateur
papajoke
Elfe
Messages : 615
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [problème de demarrage] archlinux ne demarre pas

Message par papajoke »

tu glisses vers un autre sujet ...
Debian/ubuntu ne sait pas gérer un microcode externe ! Tu sais comment réparer("customiser") ton grub debian sinon tu installes le grub arch. puisque tu es un ancien utilisateur arch et nulti-os cela devrait être acquis depuis longtemps.
sur forum debian , le grubcustom "ça me gonfle": abandonné et ici tu ne veux pas faire de chroot ... difficile de t'aider

uefi: anarchy n'est pas un installateur classique arch, apparemment tu n'as pas installer grub avec cet installateur :
- c'était volontaire de ta part ? donc tout cela est normal et voulu
- sinon tu étais bien en uefi et non mbr ?
- sinon aucune idée de comment cet installateur fait sa propre popote à l'install (et si il la fait bien)
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau
bricomega
Hankyu
Messages : 26
Inscription : ven. 17 janv. 2020, 16:53

Re: [problème de demarrage] archlinux ne demarre pas

Message par bricomega »

re
je n'ai plus envie de me prendre la tête,j'abandonne archlinux
merci pour tous ceux qui ont pris la peine d'essayer de m'aider
merci encore
Répondre