[Problème de wifi carte réseau] RTL8111/8168/8411

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
yapapa
newbie
Messages : 9
Inscription : mar. 22 juin 2021, 17:36

[Problème de wifi carte réseau] RTL8111/8168/8411

Message par yapapa »

Bonjour à tous,
Ma carte réseau qui m’empêche de me connecter par wifi.
Je suis sur Manjaro

Code : Tout sélectionner

lspci | grep -i realtek
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
Ça fonctionnait normalement, mais c'est un nouveau pc (Asus), et une fois, je le démarre et il n'a plus voulu se connecter par wifi, il ne me met même plus la liste des wifi a proximité. Par contre tout fonctionne par Ethernet...
J'ai essayé d'installer ces paquets ci https://aur.archlinux.org/packages/?O=0 ... _Search=Go
et le r8168-ck fonctionnait [aur]https://aur.archlinux.org/packages/r8168-ck/[/aur], mais comme je l'ai dit (j’ai sûrement fait une fausse manœuvre en chipotant) je n'ai plus de wifi...
Je l’installais comme expliqué ici https://archived.forum.manjaro.org/t/in ... er/52343/3 avec notamment la commande "pamac build r8168-ck", mais la j'ai beau ressayer ca ne fonctionne pas...

Comment puis-je remettre ma carte ou je ne sais quoi a zéro pour la redémarrer ou quelque chose comme ça...?

PS : je suis en dual-boot avec Windows et le wifi fonctionne. Donc le problème réside dans Manjaro...

Merci énormément d'avance
laurent85
Elfe
Messages : 776
Inscription : mar. 16 oct. 2018, 21:05

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par laurent85 »

Bonjour,
C'est pas la carte wifi la RTL8111/8168/8411. Quel est le retour de :

Code : Tout sélectionner

lspci -nnk
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
yapapa
newbie
Messages : 9
Inscription : mar. 22 juin 2021, 17:36

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par yapapa »

Salut, merci de ta réponse !

Voila le retour :

Code : Tout sélectionner

lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation 10th Gen Core Processor Host Bridge/DRAM Registers [8086:9b44] (rev 02)
	DeviceName: Onboard - Other
	Subsystem: ASUSTeK Computer Inc. Device [1043:1e91]
	Kernel driver in use: skl_uncore
00:01.0 PCI bridge [0604]: Intel Corporation 6th-9th Gen Core Processor PCIe Controller (x16) [8086:1901] (rev 02)
	Kernel driver in use: pcieport
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics [8086:9bc4] (rev 05)
	DeviceName: Onboard - Video
	Subsystem: ASUSTeK Computer Inc. Device [1043:178f]
	Kernel driver in use: i915
	Kernel modules: i915
00:04.0 Signal processing controller [1180]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem [8086:1903] (rev 02)
	DeviceName: Onboard - Other
	Subsystem: ASUSTeK Computer Inc. Device [1043:1e91]
	Kernel driver in use: proc_thermal
	Kernel modules: processor_thermal_device
00:08.0 System peripheral [0880]: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model [8086:1911]
	DeviceName: Onboard - Other
	Subsystem: ASUSTeK Computer Inc. Device [1043:1e91]
00:12.0 Signal processing controller [1180]: Intel Corporation Comet Lake PCH Thermal Controller [8086:06f9]
	DeviceName: Onboard - Other
	Subsystem: ASUSTeK Computer Inc. Device [1043:1e91]
	Kernel driver in use: intel_pch_thermal
	Kernel modules: intel_pch_thermal
00:14.0 USB controller [0c03]: Intel Corporation Comet Lake USB 3.1 xHCI Host Controller [8086:06ed]
	DeviceName: Onboard - Other
	Subsystem: ASUSTeK Computer Inc. Device [1043:201f]
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
00:14.2 RAM memory [0500]: Intel Corporation Comet Lake PCH Shared SRAM [8086:06ef]
	DeviceName: Onboard - Other
	Subsystem: Intel Corporation Device [8086:7270]
00:15.0 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH Serial IO I2C Controller #0 [8086:06e8]
	DeviceName: Onboard - Other
	Subsystem: ASUSTeK Computer Inc. Device [1043:1e91]
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:16.0 Communication controller [0780]: Intel Corporation Comet Lake HECI Controller [8086:06e0]
	DeviceName: Onboard - Other
	Subsystem: ASUSTeK Computer Inc. Device [1043:1e91]
	Kernel driver in use: mei_me
	Kernel modules: mei_me
00:17.0 SATA controller [0106]: Intel Corporation Device [8086:06d3]
	DeviceName: Onboard - SATA
	Subsystem: ASUSTeK Computer Inc. Device [1043:1e91]
	Kernel driver in use: ahci
00:1d.0 PCI bridge [0604]: Intel Corporation Comet Lake PCI Express Root Port #9 [8086:06b0] (rev f0)
	Kernel driver in use: pcieport
00:1d.5 PCI bridge [0604]: Intel Corporation Device [8086:06b5] (rev f0)
	Kernel driver in use: pcieport
00:1d.6 PCI bridge [0604]: Intel Corporation Device [8086:06b6] (rev f0)
	Kernel driver in use: pcieport
00:1f.0 ISA bridge [0601]: Intel Corporation Comet Lake LPC Controller [8086:068d]
	DeviceName: Onboard - Other
	Subsystem: ASUSTeK Computer Inc. Device [1043:1e91]
00:1f.3 Audio device [0403]: Intel Corporation Comet Lake PCH cAVS [8086:06c8]
	DeviceName: Onboard - Sound
	Subsystem: ASUSTeK Computer Inc. Device [1043:1a2e]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel, snd_soc_skl, snd_sof_pci_intel_cnl
00:1f.4 SMBus [0c05]: Intel Corporation Comet Lake PCH SMBus Controller [8086:06a3]
	DeviceName: Onboard - Other
	Subsystem: ASUSTeK Computer Inc. Device [1043:1e91]
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
00:1f.5 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH SPI Controller [8086:06a4]
	DeviceName: Onboard - Other
	Subsystem: ASUSTeK Computer Inc. Device [1043:1e91]
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU117M [GeForce GTX 1650 Ti Mobile] [10de:1f95] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device [1043:178f]
	Kernel modules: nouveau
02:00.0 Non-Volatile memory controller [0108]: Micron Technology Inc Device [1344:5404] (rev 03)
	Subsystem: Micron Technology Inc Device [1344:1100]
	Kernel driver in use: nvme
03:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:7961]
	Subsystem: AzureWave Device [1a3b:4680]
	Kernel driver in use: mt7921e
	Kernel modules: mt7921e
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
	Subsystem: ASUSTeK Computer Inc. Device [1043:208f]
	Kernel driver in use: r8168
	Kernel modules: r8169, r8168
Par contre, je viens d'allumer mon PC et pour le wifi refonctionne... Du moins pour le moment.
Je ne comprends pas trop mais il est possible que lors de mes essais, je redémarrais juste le pc pour voir si le wifi se remettait. Or ici, je l'ai totalement éteint et puis rallumé. Je ne sais pas du tout si c'est à cause de çà mais c'est peut-etre possible...

Je te recontacterai si son fonctionnement est temporaire mais je ne l'espère pas :D :lol:

Merci encore et désolé pour le dérangement... :|
yapapa
newbie
Messages : 9
Inscription : mar. 22 juin 2021, 17:36

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par yapapa »

Salut, je te recontacte car avec la nouvelle mise a jour. Je n'ai de nouveau plus de wifi... Je n'ai rien fait de spécial et ça fonctionne par Ethernet
benjarobin
Maître du Kyudo
Messages : 16232
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par benjarobin »

Bonjour, quel paquet as tu installé ? Le seul qui fonctionnera après une mise à jour du kernel est r8168-dkms.
Attention de bien installer les headers de ton kernel
Zsh | KDE | PC fixe : core i7, carte nvidia
Titre d'un sujet : [Thème] Sujet (état) / Règles du forum
yapapa
newbie
Messages : 9
Inscription : mar. 22 juin 2021, 17:36

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par yapapa »

Salut, merci de ta réponse. Je ne suis pas expert mais je me souviens avoir installé avec un truc que javais trouvé ou j'ai installé avec

Code : Tout sélectionner

pamac build r8168-ck
Je ne sais pas si c’est la bonne technique mais ça avait fonctionné... Est ce que le refaire la réactiverais ?

Merci encore
benjarobin
Maître du Kyudo
Messages : 16232
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par benjarobin »

Vraiment je te conseil d'installer à la place r8168-dkms. C'est exactement la même chose, sauf que le paquet est automatiquement recompilé à chaque changement de kernel
Mais oui réinstaller le paquet r8168-ck est une solution (si tu utilises bien ce kernel), mais vraiment pas du tout pratique... En tout cas c'est normal que cela ne fonctionne plus après une mise à jour du kernel.
Zsh | KDE | PC fixe : core i7, carte nvidia
Titre d'un sujet : [Thème] Sujet (état) / Règles du forum
yapapa
newbie
Messages : 9
Inscription : mar. 22 juin 2021, 17:36

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par yapapa »

Salut, et est ce que tu pourrais me donner la marche a suivre pour installer le drivers en passant par le r8168-dkms ?
Pour être sur de pas faire n'importe quoi... :D
laurent85
Elfe
Messages : 776
Inscription : mar. 16 oct. 2018, 21:05

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par laurent85 »

yapapa a écrit : mar. 13 juil. 2021, 18:31 Je n'ai de nouveau plus de wifi... Je n'ai rien fait de spécial et ça fonctionne par Ethernet
@benjarobin La carte Ethernet r8168 fonctionne, le problème concerne la carte wifi :
03:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:7961]
Subsystem: AzureWave Device [1a3b:4680]
Kernel driver in use: mt7921e
Kernel modules: mt7921e
Envoie les logs sur un pastebin, donne le lien obtenu par cette commande :

Code : Tout sélectionner

journalctl -b | curl --data-binary @- https://paste.rs
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
benjarobin
Maître du Kyudo
Messages : 16232
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par benjarobin »

Hum, en effet, j'ai lu trop vite. Le titre qui est faux m'a induit en erreur. La carte Wifi c'est mt7921e. Et le port Ethernet c'est r8168.
Mais cela ne change en rien mon propos, toujours privilégier le driver dkms quand disponible

En complément de la demande de log, quelle est la sortie de

Code : Tout sélectionner

ip a
iw dev wlan0 scan # Remplace wlan0 par le nom de ton interface Wifi
Zsh | KDE | PC fixe : core i7, carte nvidia
Titre d'un sujet : [Thème] Sujet (état) / Règles du forum
yapapa
newbie
Messages : 9
Inscription : mar. 22 juin 2021, 17:36

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par yapapa »

Salut @benjarobin et @laurent85, merci beaucoup de vos réponses.
Effectivement erreur de ma part, j'ai confondu. Je comprends maintenant pourquoi ça ne fonctionnait pas, j'installais les drivers de la mauvaise carte... :shock:
Vu que ça concerne maintenant la mt7921e ça change tout.

Cela dit, ça m'as encore fait le même coup que l'autre fois. Je fais tout ce qui est en mon pouvoir, je demande de l'aide et voila qui se remet a fonctionner ! A se demander s'il ne le fait pas exprès. C'est peut être le fait que je redémarre tout le temps alors qu'il faudrait plutôt éteindre puis rallumer. Je n'en sait rien mais c'est la deuxième fois qu'il me fait le coup du mort puis il revient de nulle part...
Mais je l'ai redémarré, été sur Windows (j’ai un dual-boot) et puis revenu sur Linux toujours en redémarrant, et la ça ne fonctionnais plus. Ici je viens de l'éteindre puis allumé. Et le wifi fonctionne... J'ai l'impression qu'il est bipolaire
laurent85
Elfe
Messages : 776
Inscription : mar. 16 oct. 2018, 21:05

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par laurent85 »

Pour avoir une idée de ce qu'il se passe envoie les logs dans les deux cas, les logs la fois où ça marche + les logs la fois où ça marche pas.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Live USB avec persistance Archuseriso
yapapa
newbie
Messages : 9
Inscription : mar. 22 juin 2021, 17:36

Re: [Problème de wifi carte réseau] RTL8111/8168/8411

Message par yapapa »

Oui tant que maintenant il fonctionne...
Il faudrait qu'il ne fonctionne plus pour que je puisse te l'envoyer.
Voici déjà quand il fonctionne : https://paste.rs/Itx

UPDATE : et voila quand il ne fonctionne pas : https://paste.rs/E3s

En fait j'ai un dual boot avec windows, et quand je suis sur windows, que je redémarre le PC pour arriver sur grub, et de la je démarre Linux, ça ne fonctionne pas.
Il faut l'éteindre, puis l'allumer et ensuite démarrer sur Linux, et la il est actif, il fonctionne.
Dans l'autre cas, le mode avion est activé car il détecte aucune carte...
Au final il fonctionne, mais que dans certains cas de démarrage... C'est bizarre
Répondre